Question Impossible de charger le module “canberra-gtk-module”… mais déjà installé


Gtk-Message: Failed to load module "canberra-gtk-module"

mais j'ai déjà le libcanberra-gtk-module  et libcanberra-gtk3-module installée. (c'est à dire j'ai essayé cette solution, mais il est déjà installé.)

Cela se produit par exemple lorsque je cours ipython --pylab

J'utilise Ubuntu 13.04 - raring.


79
2017-09-06 14:33


origine




Réponses:


Ce problème peut se produire sur un ordinateur 64 bits lorsque l'on installe un logiciel 32 bits nécessitant canberra-gtk-module. Acroread, par exemple, peut causer ce problème. Dans ce cas, la solution consiste à installer la version 32 bits:

sudo apt-get install libcanberra-gtk-module:i386

Il faut laisser la version 64 bits aussi bien que nécessaire pour les programmes 64 bits qui tentent de l’utiliser.


75
2017-09-24 21:50



J'ai un système 32 bits donc je ne pense pas que cela s'applique. D'autres idées? C'est le client Copy.com qui génère l'erreur. - endolith
Il a corrigé mon Firefox 32 bits sur Ubuntu 64 bits. - Dielson Sales
Cela n'a pas aidé pour moi. J'ai aussi essayé sudo apt-get remove libcanberra-gtk-module avant sudo apt-get install libcanberra-gtk-module:i386, ne fonctionne toujours pas. - Mads Skjern
Ne travaille pas pour moi. - dspacejs


installer le module gtk et gtk3 devrait le résoudre.

sudo apt install libcanberra-gtk-module libcanberra-gtk3-module

54
2018-01-16 03:54



Pour moi sudo apt-get install libcanberra-gtk-module a bien fonctionné - NZD
Pareil ici. Résolu le problème. - SDsolar
Cela devrait être la réponse acceptée - Brij Raj Kishore
Même chose ici - sudo apt-get install libcanberra-gtk-module a bien fonctionné - Banee Ishaque K
Cela a fonctionné pour moi sur Ubuntu 18 - Guus


J'ai eu le même problème et le résoudre avec la solution donnée dans ce problème de tableau de bord.

sudo apt-get install --reinstall libcanberra-gtk-module

13
2018-02-10 14:29



N'a pas fonctionné pour moi - Dan H
ATTENTION: L'utilisateur Paparazio a signalé que cette commande supprimait beaucoup plus de logiciels que prévu. Voir sa question pour plus de détails. - wjandrea


Peut-être trop mais cela a résolu mon problème:

$ sudo apt-get install libcanberra-gtk*

0
2017-10-24 21:46



idée terrible et ne s'est même pas débarrassé de cette erreur quand je l'ai essayé. - tatsu