Question Utilisation de ressources VPN externes depuis VirtualBox


J'utilise NetworkManager pour me connecter à OpenVPN. Cela fonctionne bien, mais les invités VirtualBox (connectés à l'hôte avec NAT) ne peuvent pas résoudre les noms d'hôte liés au travail.

Le serveur OpenVPN envoie un "dhcp-option DNS" au client, de sorte que l'hôte PEUT résoudre ces noms d'hôte, mais il semble que l'invité ne puisse pas ... Est-ce attendu? Est-ce que je manque quelque chose?

(L'hôte et l'invité sont Xubuntu Lucid)


2
2017-09-05 16:32


origine




Réponses:


Êtes-vous capable de vous connecter à n'importe quel vpn-IP? Essayez d'abord de faire un ping sur l'une de ces IP. Si cela réussit et que vous ne pouvez pas envoyer de commande ping à un nom d'hôte VPN, vous rencontrez un problème DNS.

Ce qui fonctionne pour moi est d'avoir la carte réseau virtualbox définie sur Bridged et l'interface définie sur le vpn (tap0 dans mon cas). Soit dit en passant, puisque le mode est ponté, si vous avez un problème de réseau sur l'invité, il est très probable que vous l'ayez également sur l'hôte.


0
2017-11-30 22:33



Ping fonctionne, mais la conversion ne montre pas l'interface VPN (tun0) ... Quoi qu'il en soit, j'ai remarqué que si je redémarre la VM alors que le VPN est actif Est-ce que travailler, alors que si je reconnecte juste eth0 ce n'est pas ... Étrange! Merci quand même pour vôtre aide :) - Joril
Eh bien, l'interface est une chose, mais vous avez également la possibilité de choisir le type d'adaptateur, à savoir NAT ou Bridge, etc. Vous pouvez essayer de le remplacer par Bridged. Et oui, je commencerais toujours par démarrer le vpn puis amorcer la machine virtuelle. - rosch
Je l'ai réglé sur un adaptateur ponté mais il n'y a pas d'option tap0 dans le menu déroulant. Cela ne semble pas fonctionner. Je ne peux pas cingler une adresse IP sur le réseau. - danielcooperxyz