Question google-chrome-stable continue à demander si elle doit être définie par défaut


Depuis la mise à niveau d'Ubuntu 15.10, google-chrome-stable continue à demander s'il doit être défini comme navigateur par défaut, même s'il l'est déjà. J'ai essayé de le réinstaller, mais cela n'a pas aidé. Des idées?


77
2017-10-23 08:07


origine


iirc, aller aux paramètres généraux -> décocher Always check if chrome is your default browser - Ravan
Mais il ne devrait pas signaler que ce n'est pas le navigateur par défaut alors qu'il l'est déjà. Je soupçonne un bug ici. (Je l'ai aussi remarqué. Mis à jour ce matin, je ne peux donc pas enquêter maintenant.) - Jos
Oui, c'est le but. Il dit que ce n'est pas le navigateur par défaut dans les paramètres, et si je clique sur "Définir sur le navigateur par défaut", rien ne change. - Yanick Nedderhoff
Tout d'abord, ce forum n'est pas destiné aux rapports de bogues, comme indiqué dans FAQ. Voici des informations comment signaler des bugs. Et voici un solution de contournement pour votre problème: - Yurii Kolesnykov
@YanickNedderhoff J'ai proposé de modifier pour la réponse mentionnée. Mais avant de les revoir, remplacez "Profile 1" par "Default" dans le chemin. - Yurii Kolesnykov


Réponses:


Pour le correctif de travail, voir la fin de cette réponse.

RÉPONSE INITIALE 28 octobre 2015 (correction obsolète)

Pour éviter de vous demander si vous souhaitez utiliser Chrome comme navigateur par défaut, utilisez la solution de contournement suivante (proposée ici et suggéré dans la section commentaire de cette question par Yurii Kolesnykov):

Ouvrez le fichier ~/.config/google-chrome/Default/Preferences avec un éditeur de texte.

Trouver la ligne

"check_default_browser": true,

et le remplacer par

"check_default_browser": false,

Dans mon cas, le fichier contenait plus de 200 000 caractères, raison pour laquelle Gedit est tombé à plusieurs reprises. Si c'est le cas dans votre cas, vous voudrez probablement utiliser un éditeur basé sur un terminal comme vi.

Veuillez noter qu'il s'agit d'une solution de contournement, le problème lui-même doit être résolu par les développeurs Chrome.

MISE À JOUR 24 novembre 2015

Comme Danilo Piazzalunga mentionné, le bug est confirmé. Comme NicDumZ suggéré, s'il vous plaît voter ce bug en cliquant sur

Does this Bug affect you?

pour attirer l'attention. Merci!

MISE À JOUR 20 février 2016

Comme rapporté en premier par Ron Thompson et 3vi1 dans la section des commentaires; et finalement confirmé par moi-même (en utilisant Ubuntu 15.10), cette solution ne semble plus fonctionner, du moins pas pour tout le monde, après la réinstallation de Google Chrome. Tous ceux qui ont utilisé cette solution de contournement doivent essayer d'éviter de réinstaller Chrome.

Je vous encourage à nouveau à dire que vous êtes affecté par le bug sur rampe de lancement (actuellement 302 personnes).

MISE À JOUR du 5 avril 2016 (correctif de travail!)

UNE réparer a été proposé le rampe de lancement qui a apparemment fait le travail pour quelques personnes:

Pour appliquer le correctif, changez la ligne n ° 198 dans le fichier /usr/bin/xdg-settings de

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//'`"

à

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//' | head -n 1`"

MISE À JOUR 25 juillet 2016 (Correctif de travail!)

Mise à jour du correctif proposé pour (K) Ubuntu 16.04:

Pour appliquer le correctif, changez les lignes # 177 et # 202 dans le fichier /usr/bin/xdg-settings de

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word"

à

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word | tête -n 1`"

Accédez ensuite aux paramètres de Google Chrome et définissez Chrome comme navigateur par défaut.

MISE À JOUR 1er juin 2017

le Punaise a été fermé et marqué comme "Fix Released" à partir d'aujourd'hui. Citant l'utilisateur Olivier Tilloy (osomon):

Si je lis le rapport correctement, le problème a été résolu dans xdg-utils dans xenial. Wily est EOL depuis presque un an, alors je ferme le bug.

no longer affects: chromium-browser no longer affects: google-chrome-beta (Ubuntu) no longer affects: google-chrome (Ubuntu) Changed in chromium-browser (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: In Progress → Invalid Changed in xdg-utils (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: Confirmed → Fix Released


54
2017-10-28 11:48



Pourriez-vous suggérer de suivre le punaise, et en votant en cliquant sur "Est-ce que ce bug vous affecte?" ? Merci! - Nicolas Dumazet
Il semble que le rapport de bogue concerne Chromium, mais cette erreur s’applique également à Google Chrome. Est-ce important? De plus, la ligne "check_default_browser" n'apparaît pas dans ce fichier de configuration pour moi. - Portugalthephilosoph
Oui, cela affecte à la fois Chrome et Chrome. Mais Chrome est basé sur Chrome, donc s'il est corrigé, il devrait être corrigé pour les deux. A propos de cette ligne manquante: je ne sais pas. Peut-on ajouter la ligne et voir si cela fonctionne? - Yanick Nedderhoff
Juste pour confirmer ... la nouvelle solution proposée (en remplacement de la commande regex) fonctionne pour moi le 15.10 :) Merci. - TacB0sS
MISE À JOUR du 5 avril 2016 (correctif de travail!) A résolu ce problème pour moi, sur Ubuntu 15.10 avec la version 50.0.2661.102 de Chrome (64 bits) - CharlyDelta


Cela a été détecté comme un bogue dans les utilitaires XDG, et cela affecte également Chromium Browser.

Voir Bogue LP # 1509139.


3
2017-11-11 22:01



Comment sur une suggestion de voter en cliquant sur "Est-ce que ce bug vous affecte?" ? Merci! - Nicolas Dumazet


J'avais le même problème avec 15.10. Chaque fois que j'ai redémarré et démarré chrome, il s'est plaint que ce n'était pas le navigateur par défaut même si les détails des paramètres des applications par défaut le montrent par défaut pour le web. J'ai remarqué que firefox était la valeur par défaut pour les photos, définissez donc cela sur le visualiseur d'images. Après un redémarrage total, chrome ne se plaint plus. Je devrais essayer quelques fois avant de prétendre que cela a résolu mon problème mais je voulais partager le résultat initial si quelqu'un est en train d'essayer les choses lui-même.


-1
2017-12-31 17:22



Mise à jour: Peut-être un hareng. chrome: // settings montre toujours que chrome n'est pas mon navigateur par défaut. J'ai dû appuyer sur le bouton "Don't Ask Again" par accident pendant les tests. Je ne trouve pas le fichier de préférences pour inverser cette décision - mrh53