Question Le gnome-langage classique est devenu chinois, comment puis-je le reconvertir en anglais? [dupliquer]


Cette question a déjà une réponse ici:

enter image description hereMon Ubuntu 12.04 gnome-classic nouvellement installé vient de se transformer en chinois après le redémarrage, comment puis-je le changer en anglais?

Je ne trouve aucun menu de langue, et ceux que j'ai ouverts sont, bien, en chinois ...

Lorsque j'ouvre un terminal et exécute gnome-language-selector, J'en reçois beaucoup dans l'invite:

locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory

Des idées?

Si je vais à la section Langue dans Utilisateurs, je n’obtiens que les options de la photo.


12
2018-05-05 22:17


origine


Je l'ai résolu en suivant les instructions de ce post: askubuntu.com/questions/2855/locale-reset-lost-settings - 719016


Réponses:


Je vous recommande de vous connecter à la session Unity, car je ne sais pas où je peux trouver toutes ces options dans une session Gnome Classic.


Cliquez sur votre nom d'utilisateur dans le coin supérieur droit de l'écran et choisissez l'option du bas dans le menu qui apparaît.

User menu

Dans la boîte de dialogue qui s'ouvre, la deuxième option vous permet de changer de langue.

User account

Revenez en anglais ou quelle que soit la langue de votre choix. Ensuite, redémarrez.


4
2018-05-05 22:26





Solution:

  1. modifier /etc/default/locale:

    LANG="en_US"
    LANGUAGE="en_US:en"
    
  2. modifier ~/.pam_environment:

    LANG=en_US
    Language=en_US
    

Déconnexion et connexion ou redémarrage.


20
2018-05-07 16:55



Travaillé pour moi, il était difficile de naviguer dans les menus en chinois ... - Martin Hansen
Travaillé ici aussi, surtout après avoir édité le second fichier (.pam_enviroment) - Merci! - techexpert


J'ai le même problème que j'ai résolu il y a juste une minute.

Vous devez sélectionner la première option de langue, puis relancer la session Gnome.

REMARQUE: si vous effectuez des modifications depuis la session Unity, vous ne coudrez pas de résultat.

À votre santé!


0
2018-05-07 16:51





Ayant juste fait face à un problème similaire, je l'ai résolu en traduisant mon choix de langue en chinois traditionnel en utilisant Google Translate, puis en correspondance avec les modèles. Dans la capture d'écran de la question, la première entrée se traduit par "anglais" et la seconde par "anglais (Royaume-Uni)". En choisissant un et en vous déconnectant, vous devez réinitialiser l'interface utilisateur.


0
2018-02-20 17:22