Question Installer php5.5 sur Ubuntu 16 avec apache2 [dupliquer]


Cette question a déjà une réponse ici:

Je dois utiliser une ancienne version de php pour mon projet (je sais que ce n'est pas supporté). J'ai essayé d'ajouter PPA ppa:ondrej/php , mais ça ne marche pas - Il n'a pas pu trouver le paquet. Y a-t-il une autre façon? Simple

sudo apt-get install php5

ne fonctionne pas non plus; il retourne no installation candidate


1
2017-11-15 18:01


origine


Essayez d'installer php5.5 au lieu de php5. - bc2946088
@ bc2946088 idem: "E: Impossible de trouver un paquet par glob 'php5.5'" - Katarzyna
5.5 ne peut pas être pris en charge le 16.04. Essayez 5.6 et regardez le lien ^^ pour des commandes supplémentaires et des informations si nécessaire. - bc2946088


Réponses:


Après avoir ajouté le référentiel http://ppa.launchpad.net/ondrej/php/ubuntu vous devez mettre à jour vos référentiels. Veuillez essayer ceci:

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php5.5

Vous pouvez utiliser php5.6 à la place.


4
2017-11-15 19:27



Cela ne fonctionne plus. 5.5 a été retiré du dépôt. - jowan sebastian
PHP 5.5 a été supprimé de ppa: ondrej / php, la version la plus basse est php5.6. Notez qu'il existe des différences entre php5.5 et php5.6, vous devez donc tester votre code. Il y a une différence majeure avec la sérialisation des objets. - Milos