Question Comment rendre le système de fichiers en lecture seule accessible en écriture?


  1. Je ne suis pas sûr depuis quand système de fichiers sur mon audio numérique le joueur a été changé pour être lecture seulement. Je ne peux pas copier des fichiers dans ou supprimer des fichiers dessus.

    Y at-il des raisons possibles pour le système de fichiers du lecteur à changer l'autorisation de son système de fichiers?

  2. J'ai essayé le chmod:

    $ sudo chmod a+rw SGTL\ MSCN/ 
    chomd: changing permissions of `SGTL MSCN/': Read-only file system
    

    où "SGTL MSCN" est le monté point du lecteur audio numérique.

    Je me demandais comment faire inscriptible?

Merci et salutations!


75
2018-06-07 19:58


origine


Merci! J'ai déjà essayé cela, et même sortie. Je vais l'ajouter à mon post. - Tim
Pourriez-vous également ajouter la marque du joueur? :) la recherche de 'SGTL MSN' n'aborde en réalité que ce sujet: D Si vous êtes vraiment malchanceux, c'est le périphérique qui a été bogue: en dernier lieu (!), réinitialisez le lecteur. Mais seulement quand tu n'obtiens pas de bonnes réponses bientôt (ish) :) - Rinzwind
Ma faute. Le nom est "SGTL MSCN". - Tim
quelles sont les options de montage mount| grep SGTL  ? - Emmanuel
Tout essayé et trouvé une solution simple (hérétique). Branchez le port USB à Windows 8 ou 7, cliquez sur "Repair External Drive", retournez à Linux. J'espère que cela aide quelqu'un. - alejoss


Réponses:


Si un système de fichiers a été monté en lecture seule, chmod ne fonctionnera pas car c'est une opération d'écriture aussi.

Essayez de le remonter en lecture-écriture:

sudo mount -o remount,rw '/media/SGTL MSCN'

Si l'appareil est équipé d'un verrou en écriture (comme les cartes mémoire SD), vous devez le désactiver. Les verrous matériels ne peuvent pas être désactivés par le logiciel. Notez que le verrouillage en écriture sur les cartes mémoire SD est situé à la vue des lettres près du coin supérieur gauche et ressemble à un très petit commutateur.

Certains pilotes de système de fichiers peuvent également ne pas prendre en charge les opérations d'écriture, c'est le cas avec l'ancien module NTFS pris en charge par Linux. Pour les systèmes de fichiers NTFS, veillez à utiliser le ntfs-3g pilote qui devrait être choisi automatiquement de nos jours. Sinon, vous pouvez forcer le conducteur avec quelque chose comme:

sudo mount -t ntfs-3g -o uid=$(id -u) /dev/sdb1 /mnt/

(où /dev/sdb1 doit être substitué à votre périphérique de bloc et /mnt/ pour votre destination)


99
2018-06-07 20:28



J'essaie ceci et obtenir "DRIVE non monté ou mauvaise option". - JeanSibelius
@mattshepherd si vous avez des espaces dans le nom du fichier, vous devez l'entourer de guillemets. - Lekensteyn
Non, pas d'espaces blancs. Je, euh, fini par le faire sous Windows. - JeanSibelius
@XavierStuvw Si lecture / écriture protégée signifie en lecture seule, ok. Sinon, vous pouvez essayer de l'essuyer et de le réutiliser. le wipefs La commande peut être utilisée sur une partition pour garantir qu'aucun système de fichiers n'est reconnu. Voir man wipefs (partie de util-linux). - Lekensteyn
@JoshuaSalazar comment l'avez-vous monté? Peut-être que vous pourriez créer une nouvelle question et inclure ces détails, cette section de commentaires devient un peu trop grande. - Lekensteyn


Si la clé USB est montée en lecture seule. Accédez à Utilitaire de disque et démontez le disque. Cliquez ensuite sur Vérifier le système de fichiers s'il n'y a pas de problèmes de remontage du disque. Après avoir monté le disque, celui-ci devrait fonctionner correctement, du moins c'est comme ça que j'ai résolu ce problème.


4
2017-12-02 11:12



On dirait que ça ne fait rien, mais ça a réglé ça pour moi - Karthik T


J'ai eu ce problème sur plusieurs clés USB. Chaque fois, je cherchais une réponse et essayais diverses suggestions, y compris l'utilisation de Terminal pour exécuter des commandes, le reformatage sur des machines Linux et Windows, etc. Tout cela en vain.

Cela m'est arrivé encore aujourd'hui alors je suis encore allé voir si je pouvais trouver une solution. J'ai essayé les choses ici, mais elles n'ont pas fonctionné.

En désespoir de cause, je suis de nouveau allé à Utilitaire de disque. J'ai démonté le lecteur et puis appuyez sur "Format" sur la partie de la partition, pas la partie du lecteur - USB avait seulement la partition unique. Cette fois ça a fonctionné !!!!. Puis je suis allé à la partie lecteur et à nouveau reformaté la partition unique en tant que lecteur de démarrage principal et sonné un peu plus avec elle.

Le résultat est que je suis maintenant capable de lire et d'écrire à nouveau sur le lecteur.

Je ne sais pas si j'ai eu de la chance cette fois-ci ou non. Mais ça marche encore.


4
2017-07-07 21:38





S'il s'agit d'un lecteur fixe et non d'un lecteur amovible, vous pouvez ajouter l'entrée de manière permanente.

sudo vi /etc/fstab

Ajoutez une entrée au format suivant:

<file-system> <mount-point> <type> <options> <dump> <pass>

Et puis faites:

mount -a

1
2018-06-07 23:14





Pour les systèmes de fichiers NTFS, ce problème peut se produire lorsqu'il n'est pas correctement démonté (probablement par un arrêt inattendu de Windows). Dans de tels cas, les systèmes de fichiers sont marqués comme verrouillés.

Vous pouvez les monter correctement en utilisant la commande suivante après avoir remplacé /dev/sda3 avec votre propre nom d'appareil:

sudo ntfsfix /dev/sda3

1
2018-05-07 13:25