Question Comment ajouter des boutons minimiser / agrandir aux fenêtres shell GNOME?


Juste installé Ubuntu 12.04, alors je l'ai fait

sudo apt-get install gnome-shell

et les fenêtres ont seulement un bouton de fermeture, comment puis-je activer minimiser / maximiser? L'ancien éditeur gconf ne semble pas fonctionner car il contient les trois boutons de la configuration.


71
2018-04-27 01:25


origine


Duplicata possible de Comment ramener minimiser et maximiser les boutons dans Gnome 3


Réponses:


Vous avez besoin d'un outil de réglage de gnome.

Cliquez sur le bouton Télécharger pour installer avec Ubuntu Software Center:

Install via the software center


Ou vous pouvez installer dans Terminal:

sudo apt-get update; sudo apt-get install gnome-tweak-tool

Ensuite, ouvrez Paramètres avancés pour modifier les boutons Réduire et Agrandir.


83
2018-04-27 01:31



Hmmm ... n'a pas pu trouver l'option spécifique, j'ai dû utiliser ubuntu-tweak. Merci quand même. - Rmano
@Rmano Shell> Disposition des boutons dans la barre de titre [Fermer uniquement est le paramètre par défaut] - Chris Granger
FYI dans Ubuntu 14.04 (Tweak Tool 3.10.4) les bascules pour montrer Maximiser et Minimiser les boutons de la barre de titre sont dans la section Windows - rakslice
Pourquoi ce n'est pas par défaut? - Jan M.


Installer dconf-editor:

sudo apt-get install dconf-tools
dconf-editor

Puis naviguez vers:

org.gnome.shell.overrides >> button-layout

et définir la valeur à:

close,minimize,maximize: **OR** :maximize, minimize,close

Notez que vous pouvez également effectuer cela depuis la console:

gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: 

Dans les versions actuelles de Gnome, vous devrez peut-être plutôt utiliser ceci:

gsettings set org.gnome.desktop.wm.preferences button-layout 'close,minimize,maximize:'

43
2018-04-30 18:25



Bien joué vanlong. Juste pour ajouter ceci peut être fait du terminal aussi: gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: - Todd Partridge 'Gen2ly'
merci Todd, les choses ont bien fonctionné après avoir utilisé le tweak que vous avez mentionné. :) - Ankit
le bouton de menu sur les boutons de la fenêtre est également disponible. J'ai ma mise en page comme close,minimize,maximize:menu - Peter
Comment puis-je le désactiver dans le terminal? - Binoy Babu
Je devais naviguer vers org.gnome.desktop.wm.preferences >> button-layout pour le faire fonctionner avec dconf-editor. - JivanAmara


C'est très simple les gars, tapez simplement la commande suivante dans le terminal, cela a fonctionné pour moi:

gsettings set  org.gnome.shell.overrides button-layout ':minimize,maximize,close'

Dans Ubuntu 17.10 (et Debian 9 Stretch) avec la commande gnome 3.26.1 est:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

(grâce à Ohto Nordberg répond).


16
2018-05-23 12:52



Je pense que cette option est meilleure que tweak-tool. Ça marche pour moi. Merci - Naai Sekar
Cette option est très cool - manix
Dans Ubuntu 17.10 avec la commande gnome 3.26.1, gsettings set org.gnome.desktop.wm.preferences button-layout ': minimiser, maximiser, fermer' - Ohto Nordberg


J'ai eu le même problème lorsque mes fenêtres Ubuntu 12.04 ont seulement montré le bouton de fermeture. Je me rends compte qu'il est possible de cliquer avec le bouton droit de la souris sur la barre de menus pour obtenir les fonctionnalités de minimisation et de maximisation manquantes, mais je souhaitais récupérer les boutons.

J'allais installer Ubuntu Tweak mais j'ai trouvé l'application "Paramètres avancés". Je suis juste allé à l'onglet "Shell" et définissez "Disposition des boutons sur la barre de titre" de "Fermer seulement" à "Tous". Cela a restauré les boutons manquants sur mes fenêtres.

J'espère que cette solution alternative aidera les personnes ayant le même problème.


4
2018-02-24 02:57





j'ai trouvé cette page quand je cherchais une réponse à cette question. Je pensais que certaines personnes apprécieraient cette information.

Voici la commande du terminal pour ceux qui sont deux paresseux pour ouvrir un lien. Je voulais juste faire crédit au contributeur original de cette information.

gconftool -s /apps/metacity/general/button_layout -t string menu:minimize,maximize,close 

3
2017-07-05 19:59



Re: liens, les gens peuvent ne pas vouloir ouvrir des liens parce qu'ils ne savent pas sur quoi ils atterrissent. Pour askubuntu / stackoverflow et autres, les liens sans info sont mauvais car le lien peut se briser et la réponse n'est pas autonome. - belacqua


Pour Ubuntu 14.04+, vous devrez peut-être exécuter les opérations suivantes:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DecorationLayout': <':minimize,maximize,close'>}"

3
2018-04-20 16:41



Est-ce que cela entre en conflit avec la solution gnome-tweaking-tool? - ofaurax


Les 12.04 et 14.04, la réponse donnée par @ user161127 a bien fonctionné pour moi (en entrant les informations suivantes dans le terminal)

gsettings set org.gnome.shell.overrides button-layout ':minimize,maximize,close'

Cependant, le 16.04, je devais utiliser le chemin donné par @JivanAmara à la place:

gsettings set org.gnome.desktop.wm.preferences button-layout ':minimize,maximize,close'

2
2017-08-06 19:12





Installez ubuntu tweak.Open tweak ubuntu et allez dans Tweaks> Window et définissez "off" dans le bouton Fermer uniquement. Mais je n'aimais pas ce type de solution bien que je partage cette solution.


1
2018-04-27 07:46





Pour maximiser, vous pouvez double-cliquer sur le cadre de la fenêtre avec le bouton gauche. Pour minimiser, cliquez une fois sur le bouton du milieu du cadre de la fenêtre.


1
2018-01-10 09:12



Le clic sur le bouton central ne fonctionne pas pour que je minimise. - Alexey


En guise d'alternative aux boutons, vous pouvez toujours minimiser / maximiser les fenêtres en cliquant avec le bouton droit de la souris sur leur barre de titre et en sélectionnant l'entrée appropriée dans le menu.


0
2018-04-27 05:04





Dans Gnome tweak tool -> cliquez sur Shell dans la colonne de gauche puis dans la colonne de droite pour Disposition des boutons dans la barre de titre, sélectionnez "all", au lieu de "close only".


0
2018-05-20 00:52