Question Comment faire fonctionner xfce4-power-manager dans Lubuntu 14.04?


Je n'ai eu que des problèmes avec elle. Lors de l'installation, tout s'est bien passé, mais je ne pouvais pas modifier l'action du couvercle et la suspension était très buggée - parfois cela fonctionnait, parfois pas.

Puis j'ai découvert que xfce4-power-manager 1.4.1 corrige le problème du couvercle du portable, alors j'ai téléchargé un deb et l'ai installé. Au premier tour, il est allé magnifiquement, mais au redémarrage, ça ne marche pas du tout. Il lance deux instances au démarrage, parfois il montre même que la suspension n'est pas disponible, et les actions de couvercle et les actions d'alimentation ne fonctionnent pas du tout.

Aidez-moi?


1
2017-10-05 09:21


origine




Réponses:


Si vous devez vraiment utiliser Lubuntu au lieu de changer votre session par défaut en XFCE (Xubuntu) Voici le lien vous devriez visiter pour trouver des solutions de contournement pour votre problème qui affecte de nombreux utilisateurs à part vous. Bien que vous puissiez penser à première vue que le post traite d'un bug spécifique à Lubuntu 13.10, lisez à l'avance sur cette page pour découvrir que le même bogue s'applique également à Lubuntu 14.04.

C'est la raison pour laquelle je vous ai invité à utiliser la session xfce au lieu de la session lxde, ce qui peut être utile pour les ordinateurs de bureau, mais ce n'est pas très bon pour les ordinateurs portables.

Pour pouvoir utiliser les fonctionnalités complètes de xfce4-power-manager dans Lubuntu, vous devez, et je cite cette page:

  1. Vous pouvez accéder à ---> Menu> Préférences> application par défaut pour LXsession> Power Manager> Autre> xfce4-power-manager> Appliquer>   Redémarrez.

Cependant, veuillez noter que cela ne suffit pas et que cette fonctionnalité devrait   être chargé par défaut, comme avant.

  1. Une autre solution consiste à ouvrir Preferences -> Applications par défaut pour LXSession, puis à accéder à l’onglet Autostart et à modifier ici l’option   "Désactiver les applications démarrées automatiquement" par défaut "config-only" à   "non". Vous devrez peut-être modifier les paramètres pour le mode ordinateur portable de "non" à   "Oui". (onglet Paramètres).

Notez que vous devez désactiver "network" de Prefereces -> Desktop   Paramètres de session ou vous aurez deux nm-applet en cours d'exécution à la même   temps.

Il existe d'autres solutions de contournement non officielles conçues pour que xfce power manager fonctionne dans Lubuntu, et vous pouvez également vérifier les réponses simplement pour trouver un autre bon lien. à cette page où vous pouvez trouver encore une autre «solution de travail» pour votre problème:

  1. J'ai eu ce problème, j'ai décoché "Power Manager" de la liste "Application Autostart" dans Paramètres -> Session et démarrage et ajouté un autre   application avec cette commande xfce4-power-manager --no-daemon alors je   n'ont pas encore ce problème.

2
2017-10-05 09:39



je fais ne pas veux faire ça. Outre, xfce4-power-manager est installé par défaut dans Lubuntu 14.04. - Juraj Fiala
Ensuite, vous devez ouvrir le Gestionnaire de paquets Synaptic, et utiliser pour mot-clé dans le champ de recherche celui-ci: lxde . Regardez dans la liste des résultats spécifiques au paquet LXDE et aux autres paquets liés à LXDE, en particulier ceux liés à la gestion de l'alimentation. Il est impératif que vous installiez lxdequi n'est pas installé par défaut dans Lubuntu pour rendre votre système un peu plus stable. N'oubliez pas le reste des paquets liés à lxde qui pourraient s'avérer utiles pour les utilisateurs d'ordinateurs portables. - Taz D.
Taz - c'est comment utiliser Xfce (Xubuntu), pas comment utiliser xfce4-power-manager dans LXDE (Lubuntu) ... - Wilf
Vous voulez dire que l’installation de LXDE et d’autres paquets liés à LXDE n’est pas une bonne chose pour Lubuntu? Je suppose que vous voulez dire ma réponse publiée à sa question (installer xubuntu-desktop), mais je prévois de supprimer celle-ci dès qu’il installe réellement ces paquets lxde et dit qu’il est satisfait de la gestion de l’alimentation. Quoi qu’il en soit, pourquoi Lubuntu doit-il utiliser xfce4-power-manager et non un package de gestionnaire d’alimentation natif pour LXDE? - Taz D.
Numéro 1) m'a mis sur la bonne voie. Sur Lubuntu 15.04, ce qui a fonctionné pour moi a été: Menu> Préférences> application par défaut pour LXsession> Applications principales: définir "Power Manager" et "Lock Screen Manager" à "xfce4-power-manager - drodsou