Question Analyse sans fil automatique au démarrage / connexion et reprise


J'exécute le 12.04 sur mon MacBook Pro 5,5 et mon Wi-Fi fonctionne correctement, mais j'ai du mal à le faire analyser automatiquement au démarrage.

Lors de la première connexion, je reçois une notification indiquant que je suis déconnecté et qu'aucun réseau n'est répertorié dans le widget de la barre d'état du Gestionnaire de réseau, même si Enable Wireless est coché.

Si je vais au terminal et que je fais une analyse manuelle, Network Manager intervient après une seconde ou deux, remplit la liste et se connecte automatiquement à un réseau enregistré, le cas échéant.

$ sudo iwlist wlan0 s

J'ai exécuté les commandes suivantes immédiatement après le démarrage pour diagnostiquer la situation

$ iwconfig
$ sudo lshw -C network
$ sudo lspci -nn | grep 0280

(sortie ici)

Je ne suis pas un expert, mais pour autant que je sache, le pilote est chargé et tout fonctionne, mais Network Manager ne lance pas une analyse sans coup férir. J'ai passé beaucoup de temps à chercher, mais je n'arrive pas à trouver quelqu'un avec le même problème. Quelqu'un sait comment je peux résoudre ce problème? Merci d'avance.


1
2017-08-30 12:44


origine




Réponses:


Comme je le pensais, c'était probablement un problème avec Gestionnaire de réseau, et non lié au pilote. j'ai installé Wicd comme solution de contournement et a supprimé Network Manager, et maintenant tout fonctionne parfaitement.

Si j'essaie de réinstaller Network Manager et de supprimer wicd à nouveau, je posterai les résultats ici, au cas où le problème serait un fichier de configuration corrompu ou quelque chose de similaire.


1
2017-09-07 07:03





De ubuntuforums, ceci est lié à un bogue sur Network-Manager, une solution de contournement valide ici:

Changer la dernière partie dans /usr/lib/pm-utils/sleep.d/55NetworkManager

from
  thaw|resume)
    resume_nm

to
  thaw|resume)
  resume_nm
  sleep 2 && iwlist eth1 scanning &

Cela forcera une nouvelle analyse du réseau sur chaque CV.

Félicitations à https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/274405/comments/74


1
2018-01-20 17:57





Ouvrez votre terminal et tapez comme

sudo nano /etc/modprobe.d/iwlwifi.conf

Il va ouvrir un éditeur de texte et ensuite

coller ces lignes

options iwlwifi bt_coex_active=0
options iwlwifi 11n_disable=1

Puis redémarrez votre système pour appliquer les modifications. À partir de maintenant, même si vous avez suspendu votre système, après le réveil, il se reconnectera à nouveau.

Crédit: Ubuntuforums

Note: assurez-vous de ne pas avoir trop de connexions sauvegardées.


0
2017-09-06 09:28



Merci pour la réponse, mais malheureusement cela n'a eu aucun effet. - Henrik
Regardez le lien des forums dans ma réponse. c'est un fil de recherche des années. - Ten-Coin
Je suis désolé, mais c'était une impasse. - Henrik