Question Comment puis-je désactiver le déplacement de la fenêtre avec alt + bouton gauche de la souris dans Shell GNOME?


Il y a beaucoup de des postes à propos de l'unité, c'est à propos de gnome-shell.

Comme avec d'autres affiches, j'utilise des applications (Inkscape en particulier) qui utilisent Alt-Click et Alt-glisser. Gnome-shell m'empêche et désactive ainsi les fonctionnalités de l'application.

j'ai essayé

  • en utilisant le plug-in Move de ccsm - vous pouvez désactiver cette option et vous pouvez toujours faire glisser la fenêtre Alt.

  • utiliser l'éditeur gconf pour changer / apps / metacity / general / mouse_button_modifier - cela n'a aucun effet AFAICS.

Ça me gêne vraiment. Sinon, je trouve gnome-shell un environnement vraiment productif.


69
2018-04-02 11:02


origine


Duplicata possible de Comment désactiver le déplacement de la fenêtre avec alt + bouton gauche de la souris? - hellocatfood
Je tiens à souligner que ce n'est pas GNOME, mais plutôt Ubuntu. Le défaut pour GNOME Shell est d'avoir <Super> soit la touche de modification de la fenêtre. - Daniel Quinn
@DanielQuinn En effet. Filed bugs.launchpad.net/ubuntu/+source/mutter/+bug/1704580 demander à Ubuntu de le ramener à la touche Super / Windows. - Mikel


Réponses:


Tout d'abord, installez dconf-tools  Install dconf-tools.

Pour ce faire, exécutez la commande suivante:

sudo apt-get install dconf-tools

Alors ouvre-le, Alt+F2 → dconf-editor.

Faites défiler jusqu'à org → gnome → desktop → wm → preferences → mouse-button-modifier → Réglez-le sur la touche de votre choix.

enter image description here


Ou équivalent,

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

dans le terminal. (Cela ne nécessite ni dconf-editor, ni dconf-tools  Install dconf-tools)

Attention: Ne rien définir signifie que tous les clics déplacent les fenêtres au lieu de les désactiver!


103
2018-04-02 12:34



Attention! Ne rien définir signifie que tout clique sur déplacer les fenêtres, au lieu de le désactiver! - Andrea
J'ai essayé la méthode dconf-editor, mais rien ne semble être arrivé. <ALT> est toujours ma touche de modification. J'ai essayé "['<Control> <Alt>']" (en suivant la syntaxe des options de raccourcis clavier) et "<Control> <Alt>". Dois-je redémarrer pour que cela prenne effet? - Gordon Bean
Je l'ai d'abord essayé avec le gsettings commande, et il semble avoir changé avec succès, mais Alt + Drag déplacerait toujours la fenêtre. Même après un redémarrage. J'ai ensuite installé dconf-tools et confirmé avec le éditeur de dconf cette mouse-button-modifier effectivement était changé, mais comme je l'ai dit, Alt + Drag déplace toujours les fenêtres. (Je suis sur Mint Cinnamon 17.2 64bit) - Bloke
"<Alt> + <Super>" valeur jolie fonctionne pour moi - vp_arth
@Bloke: je pense pour Cannelle, CA devrait etre org.cinnamon.desktop.wm.preferences au lieu. Au moins c'est ce qui a fonctionné pour moi. - Giraldi


Pour résoudre le problème de déplacement de la fenêtre Alt + Click:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

Fait la même chose, en réalité, avec un outil de configuration différent, et moins de recherche et de clic.

Pour les nouvelles versions utilisant dconf / gsettings, utilisez ceci:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

8
2018-05-18 18:03



gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>" pour dconf. - ulidtko


Utilisez l'outil Tweak (gnome-tweak-tool):

Windows> Clé d'action de la fenêtre


7
2018-02-20 23:34



Je vous remercie! Cela a fonctionné pour moi quand tout en utilisant dconf-editor ou la ligne de commande ou compiz a échoué. Maintenant, je peux utiliser alt pour d'autres raccourcis et restaurer la fonctionnalité de plusieurs programmes. - Silvestris


Je mets Alt+Super comme une solution temporaire. Je peux donc utiliser le Alt clé dans Inkscape et Super pour les activités.


6
2018-04-19 01:34



que voulez-vous dire par "activités"? j'ai changé Alt à Super et ça marche bien pour moi. Je n'ai pas remarqué d'effets secondaires. Pourquoi aurais-tu besoin Alt + Super? - faizal
wiki.gnome.org/Projects/GnomeShell/Tour#Activities_Overview  Si vous définissez "Super" pour les fenêtres en mouvement, vous ne pouvez pas l'utiliser pour afficher "Aperçu des activités". Regardez l'heure de publication, c'était il y a deux ans. - KEIII
Deux ans, c'est rien. - Johan Boulé


Dans UBUNTU 14.04, LTS utilise la syntaxe dconf comme

<Alt><Super>

Fonctionne bien pour moi.

BTW: Si vous définissez quelque chose de mal, il commence à déplacer la fenêtre à chaque clic. Utilisez pour naviguer jusqu'au bouton "Définir par défaut". Et frappe.

enter image description here


3
2018-03-31 08:05





En menthe, cela peut être changé ou désactivé dans system settings > windows > behavior > 'Special key to move and resize window'


2
2018-01-29 11:11





  1. Aller aux paramètres du système
  2. Sélectionnez le clavier
  3. En bas à gauche, cliquez sur "Paramètres de mise en page"
  4. Sélectionnez votre langue et cliquez sur le bouton "Options" en bas à droite
  5. Sélectionnez le comportement de la touche Alt / Win
  6. Changez-le en celui que vous aimez. J'utilise "Left Alt est échangé avec Left Win".

1
2018-03-25 16:32





dans CentOS 7, je devais utiliser

 gsettings set org.gnome.desktop.wm.keybindings activate-window-menu "['<Alt>F10']"

Ce paramètre n'avait pas été spécifié, ce qui signifiait que le bouton central de la souris activait le menu de la fenêtre. Même mise

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier '<Super>'

n'a pas déplacé cette action à Alt-middle; Je devais lier activate-window-menu.


0
2018-04-19 19:54