Question Comment installer Kodos en 12.10?


Dans la version précédente d'Ubuntu, j'ai utilisé Kodos largement. Mais le paquet a été supprimé en 12.10.

C'est chouette outil de test d'expressions régulières. Il est difficile de trouver une alternative qui n’est pas uniquement Windows (ou Air, ou qui utilise un script d’action qui se moque de RegEx plus compliqué, ou fonctionne dans Wine - un peu, mais pas vraiment…, etc.).

J'ai donc essayé d'installer Kodos depuis la source, ce qui semble fonctionner (télécharger le sourceball et setup.py) mais il ne fonctionnera pas à cause de l'absence PyQT dépendances (que je n'arrive pas à remplir avec tout ce qui peut être installé via des paquets standard). J'ai ensuite essayé d'installer PyQT manuellement (ce qui semble nécessiter une installation manuelle de siroter et QT aussi) et au lieu de pip Je dois utiliser configure.py et qmake. Il me jette une erreur après une erreur. J'ai essayé de surmonter l'un après l'autre pendant plus d'une heure mais pas de chance.

Il a même réussi à briser Caliber et Music Brains Picard. J'ai donc purgé toutes les choses, réinstallé python-sipet python-qt4 des paquets standard et abandonné.

Est-ce que quelqu'un a réussi à faire fonctionner Kodos le 12.10? Ou des conseils sur la façon de le faire?


1
2017-11-29 17:06


origine


Pourriez-vous poster les erreurs que vous obtenez? - MiJyn


Réponses:


Vous ne pouvez pas le faire fonctionner facilement. Kodos utilise toujours le très ancien Qt3 qui est déposé dans Quantal. Debian l'a déjà abandonnée en mai. Voir Bogue Debian # 604359. Citant:

Un an et demi plus tard, il est temps de supprimer Qt3 et python-qt3.   Veuillez migrer vers la version Qt4 (si existante) ou archiver pour supprimer votre   paquet.

Parlez avec les développeurs de Kodos afin de le réparer. Selon Qt3 est une impasse de nos jours. Et c'est pourquoi l'installation des packages Qt4 ne vous aide pas.


2
2017-11-29 17:17