Question ntpdate: aucun serveur adapté à la synchronisation trouvé


Mon horloge est éteinte, donc je voudrais le synchroniser en utilisant ntpdate. J'ai essayé plusieurs serveurs NTP différents, mais pour une raison quelconque, je reçois toujours le message d'erreur suivant:

$ sudo ntpdate ntp.ubuntu.com
4 Mar 12:27:35 ntpdate[1258]: no server suitable for synchronization found
$ sudo ntpdate pool.ntp.org
4 Mar 12:27:50 ntpdate[1267]: no server suitable for synchronization found
$ sudo ntpdate de.pool.ntp.org
4 Mar 12:28:01 ntpdate[1273]: no server suitable for synchronization found
$ sudo ntpdate us.pool.ntp.org
4 Mar 12:28:12 ntpdate[1276]: no server suitable for synchronization found

Questions connexes

J'ai regardé à travers questions connexes, mais aucun ne résout mon problème:

Les choses que j'ai essayées

J'ai installé le package ntp

... et a essayé d'utiliser le ntpd démon au lieu de ntpdate utilitaire. Il ne synchronisera pas non plus mon temps; le démon commence bien, mais mon horloge reste éteinte. J'ai même essayé d'utiliser l'exact /etc/ntp.conf de la réponse acceptée dans ce dernier post, et redémarrage du démon. Ne pas aller. Quoi qu'il en soit, je ne veux pas utiliser le démon. Je suis parfaitement conscient que ntpdate est considéré comme "déconseillé", et il est conseillé d'utiliser ntpd -q au lieu. Voir aussi ici:

Mais depuis ntpd ne fonctionne pas pour moi non plus, le problème est ailleurs. Et je trouve que je préférerais ne pas avoir à installer de paquetages supplémentaires uniquement pour synchroniser l'horloge. ntpdate est pré-installé avec Ubuntu, et Il devrait fonctionner parfaitement. J'ai donc désinstallé le ntp paquet à nouveau.

Peut-être que le port 123 est bloqué?

De cet article:

... J'ai eu l'idée que le port 123 pourrait être bloqué de mon ordinateur / réseau sur mon lieu de travail. Effectivement,

$ sudo nmap -p123 -sU -P0 localhost
...
PORT    STATE  SERVICE
123/udp closed ntp 
...
$ sudo ufw allow 123/udp
Rules updated
Rules updated (v6)
$ sudo nmap -p123 -sU -P0 localhost
...
PORT    STATE SERVICE
123/udp open  ntp
...

Mais reste:

$ sudo ntpdate ntp.ubuntu.com
4 Mar 13:06:16 ntpdate[4361]: no server suitable for synchronization found

Même avec le -u option, qui dit ntpdate utiliser un port non privilégié pour la synchronisation (au lieu du port 123) qui n'est certainement pas bloqué depuis mon lieu de travail:

$ sudo ntpdate -u ntp.ubuntu.com
4 Mar 13:06:28 ntpdate[4427]: no server suitable for synchronization found

Peut-être que les strates sont trop hautes?

Enfin, à partir de ce post sur serverfault:

... Je pensais que les strates des serveurs NTP étaient peut-être trop hautes. Ils ne sont pas, cependant. Voyons un peu plus d'informations de débogage:

$ sudo ntpdate -dv ntp.ubuntu.com
 4 Mar 13:12:24 ntpdate[4523]: ntpdate 4.2.6p5@1.2349-o Wed Oct  9 19:08:07 UTC 2013 (1)
Looking for host ntp.ubuntu.com and service ntp
host found : golem.canonical.com
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
91.189.89.199: Server dropped: no data
91.189.94.4: Server dropped: no data
server 91.189.89.199, port 123
stratum 0, precision 0, leap 00, trust 000
refid [91.189.89.199], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Mon, Jan  1 1900  1:00:00.000
originate timestamp: 00000000.00000000  Mon, Jan  1 1900  1:00:00.000
transmit timestamp:  d6c041ae.e6166441  Tue, Mar  4 2014 13:12:30.898
filter delay:  0.00000  0.00000  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

server 91.189.94.4, port 123
stratum 0, precision 0, leap 00, trust 000
refid [91.189.94.4], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Mon, Jan  1 1900  1:00:00.000
originate timestamp: 00000000.00000000  Mon, Jan  1 1900  1:00:00.000
transmit timestamp:  d6c041af.1948fc50  Tue, Mar  4 2014 13:12:31.098
filter delay:  0.00000  0.00000  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

 4 Mar 13:12:33 ntpdate[4523]: no server suitable for synchronization found

Pfeeewww ... c'était long, désolé pour ça. Je suis déconcerté Des indices?

Mise à jour: infos complémentaires

Peu importe si un serveur NTP HOSTNAME chiffres dans /etc/ntp.conf, et peu importe si le ntpd le service fonctionne ou non, chaque fois que je cours sudo ntpdate -u HOSTNAME, Je reçois no server suitable for synchronization found. Même chose quand le ntpd le service est ne pas en cours d'exécution et je omettre la -u option. Quand le ntpd un service est en cours d'exécution et je omet le -u option, je reçois plutôt the NTP socket is in use, exiting.

Aussi:

$ timedatectl status
      Local time: Wed 2014-03-05 13:11:54 CET
  Universal time: Wed 2014-03-05 12:11:54 UTC
        Timezone: Europe/Berlin (CET, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2013-10-27 02:59:59 CEST
                  Sun 2013-10-27 02:00:00 CET
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2014-03-30 01:59:59 CET
                  Sun 2014-03-30 03:00:00 CEST

Mais l'heure UTC n'est pas correcte ici. En ce moment, l'heure UTC est 11:11, ne pas 12:11.

Et:

$ sudo hwclock --show
Wed 05 Mar 2014 01:11:56 PM CET  -0.625627 seconds

69
2018-03-04 11:38


origine


vous avez dit que vous aviez lancé `sudo ntpdate ntp.ubuntu.com` mais l'avez-vous fait après avoir ajouté ntp.ubuntu.com à /etc/ntp.conf s le champ serveur? Si pas voir la réponse suivante - Stormvirux
essayez `sudo ntpdate 0.ubuntu.pool.ntp.org - Stormvirux
Bonjour, voir mon commentaire sur votre réponse. J'ai essayé d'ajouter server pool.ntp.org à /etc/ntp.conf, mais ntpdate -u pool.ntp.org jette la même erreur. J'ai aussi essayé ceci avec ntp.ubuntu.com (l'ajoutant à /etc/ntp.conf, redémarrer le ntp service, relance ntpdate -u sur le serveur exact que je viens d'ajouter à /etc/ntp.conf). Résumer, ce n'est pas grave si le serveur avec lequel j'essaie de synchroniser est mentionné dans /etc/ntp.conf. Je reçois le no server suitable... erreur dans tous les cas (sauf lorsque le ntp le service est en cours d'exécution et Je omet le -u option, alors je reçois le NTP socket in use Erreur). - Malte Skoruppa
Ok, j'ai aussi essayé sudo ntpdate 0.ubuntu.pool.ntp.org, qui est déjà dans le /etc/ntp.conf fichier. Pas de chance - même erreur. - Malte Skoruppa


Réponses:


Votre hébergeur bloque les paquets ntp. Cette approche lourde a été mise en œuvre par certains FAI en réponse aux attaques DDoS. Vous pouvez voir que ntpdate envoie les paquets sur le ntpdate -vd:

transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)

Je contacterais votre fournisseur de services Internet et lui demanderais s'il bloque les requêtes ntp externes et s'il dispose d'un serveur local que vous pouvez utiliser pour la synchronisation de l'heure.

Il existe plusieurs possibilités plus obscures, mais il est difficile de les exclure, car vous n'avez pas publié de journal à partir de syslog.


44
2018-03-04 23:18



Tu as parfaitement raison. Il semble que notre université bloque les requêtes NTP externes. Il offre également quelques serveurs NTP locaux comme alternative. Celles-ci fonctionnent parfaitement. Je vois maintenant que la sortie de ntpdate -dv devrait également inclure certains receive(...) et pas seulement transmit(...) messages. ;) Merci beaucoup! - Malte Skoruppa
Une question cependant, comment l'université peut-elle bloquer les paquets NTP quand j'utilise ntpdate avec le -u option? Comme cela utilise un port non privilégié au lieu du port 123, cela signifie que leurs règles de pare-feu doivent être plus complexes que simplement "bloquer les paquets entrants sur le port 123". Alors font-ils une sorte d'inspection approfondie des paquets, alors? - Malte Skoruppa
Ils auront une règle de pare-feu indiquant "Bloquer tout le trafic avec un port de destination de 123", puis quelques exceptions pour leurs hôtes ntp. - dfc
J'ai eu le même problème. J'ai été capable de le résoudre en faisant un traceroute sortant et j'ai trouvé un serveur local sur la route vers laquelle je pouvais me synchroniser et qui exécutait ntp. L'un d'entre eux le bloquait cependant. Merci pour les conseils! - jonespm
Pour moi, ntpdate -vd dit no servers can be used, exiting. - highBandWidth


Ce n'est pas une réponse ntp, cependant ...

sudo date -s "$(wget -qSO- --max-redirect=0 google.com 2>&1 | grep Date: | cut -d' ' -f5-8)Z"

ceci et la version curl ici.


27
2017-08-02 02:17



C'est terrible, mais ça marche. - Alan Plum
Transférer des données non homologuées vers la commande bash s'exécute en tant que root? Merci pour jouer. Cette réponse devrait être abaissée avec des préjugés extrêmes. - dfc
Beaucoup moins pénible que de devoir gérer le support des FAI. En outre, pas critique du tout si exécuté dans une machine virtuelle locale à des fins de test. - Yalok Iy
Pouvez-vous m'expliquer ce que cela fait? - Suraj Jain
@SurajJain De nombreux serveurs Web retournent Date entête. Dans cette commande date -s pour la date définie, wget -S pour stocker tous les en-têtes, 2> & 1 pour enregistrer les erreurs dans stdout, grep pour la ligne de sélection avec en-tête Date, couper pour le jour de bande et GMT. Z à la fin pour traiter la date comme UTC. La précision dépendra de la vitesse du réseau. - user1516873


J'ai eu le même problème et c'est comme ça que je l'ai résolu. J'ai donné une réponse détaillée de haut en bas. Vous voudrez peut-être passer au milieu de ma réponse ou simplement renvoyer les captures d'écran ci-dessous pour en comprendre le fonctionnement.

Premier installez ntpdate (évidemment vous l'avez fait)

sudo apt-get install ntpdate

PROCHAIN Vous devez configurer ntp avec les serveurs comme suit:

Vous devez au moins définir le paramètre suivant dans le fichier de configuration /etc/ntp.conf: server 

Par exemple, ouvrez le fichier /etc/ntp.conf en utilisant l'éditeur de texte nano:

sudo nano /etc/ntp.conf

Localisez le paramètre du serveur et s'il est vide, définissez-le comme suit:

server pool.ntp.org

Mais généralement, dans Ubuntu déjà certains serveurs sont pré-écrits qui pourraient être

server 0.ubuntu.pool.ntp.org
server 1.ubuntu.pool.ntp.org
server 2.ubuntu.pool.ntp.org
server 3.ubuntu.pool.ntp.org

enter image description here

Ensuite, enregistrez le fichier et redémarrez le service ntpd:

sudo /etc/init.d/ntpd start

Vous pouvez synchroniser l’horloge système sur un serveur NTP immédiatement avec la commande suivante:

sudo ntpdate pool.ntp.org

ou juste exécuter déjà les serveurs sont définis

sudo ntpdate 0.ubuntu.pool.ntp.org

ou d'autres serveurs définis à l'aide du serveur

généralement

sudo ntpdate <one of the servername in /etc/ntp.conf>

MAIS après cela, il y a une chance que vous obtenez l'erreur NTP socket in use comme indiqué ci-dessous:

enter image description here

Dans ce cas, lancez simplement

ntpdate -u pool.ntp.org 

mettre à jour lorsque ntp deamon est en cours d'exécution

OU arrêtez simplement le démon, mettez-le à jour et recommencez comme suit:

sudo ntpdate pool.ntp.org
sudo service ntp stop
sudo ntpdate pool.ntp.org
sudo service ntp start

et vous obtiendrez

enter image description here


9
2018-03-04 13:43



Bonjour, merci pour votre réponse détaillée! Malheureusement, cela n'a pas fonctionné pour moi. J'ai le /etc/ntp.conf cela est venu avec Ubuntu, jamais apporté de modifications. Je l'ai collé ici: pastebin.com/bB0sskzv. je aussi essayé d'ajouter server pool.ntp.org en haut de la liste des serveurs, comme indiqué dans votre capture d'écran. Trouvez ça ici: pastebin.com/YH372Jdi. Avec ces deux configurations, J'ai exécuté la séquence de commandes que vous avez proposée: j'ai ajouté une capture d'écran à mon message original. Le résultat était exactement le même avec le non modifié et le modifié /etc/ntp.conf. D'autres idées? Merci! - Malte Skoruppa
qu'est ce que timedatectl status revenir - Stormvirux
Voir sortie du timedatectl status commande dans mon message d'origine. - Malte Skoruppa
J'ai maintenant essayé avec les 4 serveurs prédéfinis (à savoir, {0..3}.ubuntu.pool.ntp.org), avec ou sans -u option. Toujours la même erreur. - Malte Skoruppa
Dis moi juste celui-là aussi. sortie de sudo hwclock --show - Stormvirux


Utilisez htpdate

Si la transmission ntp est bloquée sur votre réseau, installez htpdate. Il synchronise l'heure sur le protocole http. La précision sera de 0,5 seconde, selon la page de manuel.

sudo apt-get install htpdate
sudo htpdate -a google.com

Le service htpdate démarre lorsque vous installez le package. L'heure sera mise à jour immédiatement s'il y a une connexion Internet.


3
2017-08-21 10:22



Veuillez ne pas copier et coller la même réponse dans tous les sujets que vous trouverez sur ntp. - sempaiscuba


Semblable à la réponse d'Alex, cela a fonctionné pour moi pour contourner le port ntp étant protégé par un pare-feu:

sudo date -s "$(curl http://s3.amazonaws.com -v 2>&1 | \
  grep "Date: " | awk '{ print $3 " " $5 " " $4 " " $7 " " $6 " GMT"}')"

2
2018-02-23 01:45





Même nous étions confrontés à ce problème ... Mais nous avons réussi à le résoudre en appuyant sur cette commande:

ssh localhost "sudo apt-get install ntp ntpdate ; sudo service ntp stop; sudo ntpdate 0.ubuntu.pool.ntp.org; sudo service ntp start"

Pour cela, vous devez installer openssh-server.

Supprimez également ntp et ntpdate (sudo apt-get remove --purge ntp ntpdate) avant le tir ci-dessus ssh commander.


0
2018-03-23 10:05



installer le démon ssh pour ... ssh vers lui-même? - Massimo


Juste une suggestion. J'ai eu ce problème pendant un certain temps, puis il a commencé à fonctionner, mais j'ai découvert qu'il y a plus de place sur le disque. 


0
2017-07-20 19:30