Question Comment puis-je «déclasser» gstreamer?


J'utilise Ubuntu 10.04.

Depuis que j'ai mis à jour gstreamer, Movie Player ne fonctionne plus correctement et Rhythmbox non plus.

Comment puis-je continuer à utiliser la version précédente de gstreamer qui fonctionnait?


1
2018-04-26 13:29


origine




Réponses:


Pour rétrograder un package, accédez à Synaptic Package Manager. Trouvez le package que vous souhaitez rétrograder. Sélectionnez-le Puis dans le menu, allez à Package -> Forcer la version ...

Vous pourrez alors sélectionner la version.

Vous pouvez aussi le faire en cli, par exemple:

sudo apt-cache showpkg gstreamer0.10-pulseaudio

Il montrera les dépendances et après Provides montrera les versions: 0.10.21-1ubuntu3 - gstreamer0.10-audiosource gstreamer0.10-audiosink 0.10.21-1ubuntu2 - gstreamer0.10-audiosource gstreamer0.10-audiosink

Ensuite, vous pouvez rétrograder: sudo apt-get installer gstreamer0.10-pulseaudio = 0.10.21-1ubuntu2


2
2018-04-26 14:06



Merci, mais cela n'a pas résolu mon problème. : - \ Je vais essayer de trouver une solution par moi-même pour cela. Encore merci beaucoup. - Paul
il vient de répondre à ce que vous avez demandé: «Comment rétrograder». Vous voulez résoudre votre problème? Posez une question décrivez votre problème et donnez-nous des détails tels que les messages d'erreur ou la sortie du terminal. - xangua