Question La prise casque ne fonctionne pas?


J'ai un Dell Studio XPS 1647 et les écouteurs ne fonctionnent pas (même si les haut-parleurs internes fonctionnent comme un charme), j'ai un double démarrage Windows 7 et un casque fonctionne parfaitement bien ...

J'ai aussi essayé d'ajouter options snd-hda-intel model=eapd probe_mask=1 position_fix=1.

Je l'ai expérimenté avec Oneric Ocelot et le dernier Pangolin Précis (LTS).


66
2018-05-06 04:36


origine


//, S'il vous plaît ajouter une sortie pour la commande suivante: $ lspci | grep Audio. Cela affichera, entre autres, votre chipset audio, par ex. 00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) - Nathan Basanese


Réponses:


J'ai eu le même problème. Suivant ces instructions J'ai fait fonctionner mes écouteurs.

Ouvrez le terminal et entrez les commandes suivantes:

cd /usr/share/pulseaudio/alsa-mixer/paths/
sudo cp analog-output-headphones.conf analog-output-headphones.bak
sudo nano analog-output-headphones.conf

Recherchez la section intitulée [Element Speaker] et changez-la pour qu'elle ressemble à ceci:

[Element Speaker]
switch = on
volume = ignore

Enregistrez les modifications et quittez nano.

Créez une sauvegarde du fichier analog-output-headphones.conf corrigé:

sudo cp analog-output-headphones.conf analog-output-headphones.fixed

Vous pouvez maintenant restaurer le correctif si une installation ou une mise à jour future le remplace.

Redémarrez.

Après le redémarrage, vous devrez peut-être retirer et réinsérer la prise casque pour la faire fonctionner. Une fois que cela fonctionnera, vous pourrez supprimer et insérer la prise et le comportement sera comme prévu.


61
2018-06-07 04:00



Bien que cela puisse théoriquement répondre à la question, ce serait préférable inclure les parties essentielles de la réponse ici, et fournir le lien pour référence. - Oyibo
...comme un charme. - nietaki
Sur LUbuntu 12.04, cela ne fonctionne pas pour moi. Aussi tu peux recharger le système audio, en tuant d'abord pulseaudio pulseaudio -k et redémarrer alsa: sudo alsa force-reload. Aucun redémarrage nécessaire. - Calmarius
Cela n'a pas fonctionné sur un Dell XPS 13 2013 exécutant Ubuntu 16.04. - Mark Stosberg
@OmidHezaveh Non. J'utilise encore alsamixer pour gérer mes volumes maintenant au lieu de la gestion des volumes système habituelle. - Mark Stosberg


J'ai essayé toutes ces réponses. Voici le SEUL moyen qui a fonctionné pour moi (et il a été remarquablement rapide… après avoir passé des heures sur toutes les autres suggestions!). Allez dans le terminal et saisissez simplement ceci dans:

$ alsactl restore

Et c'est ça! :)


57
2017-09-30 06:10



Avez-vous redémarré après avoir exécuté ceci? - mwangi
Non, mais je dois fermer et redémarrer tous les programmes en utilisant l'audio - ou dans le cas d'un onglet dans un navigateur (par exemple, un clip sur youtube), rechargez l'onglet. - Pepe Lebuntu
D'accord. J'ai dû faire un arrêt complet et non un redémarrage. Seulement alors, ça a fonctionné pour moi. J'utilise un ASUS K56--30 - mwangi
Cela a fonctionné sur mon XPS 13 9360 (Ubuntu 16.04.2). Les casques ont commencé à fonctionner immédiatement après. Mon unité perd le casque de façon irrégulière. - sola
Cela n'a pas fonctionné sur Ubuntu 18.04 avec un spectre hp 360. J'ai eu une erreur lors de l'exécution de la commande: alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists - Limok Palantaemon


Enfin, les écouteurs fonctionnent! Suivez ceci ----- (Dell)

Ça y est :


Exécutez la commande suivante dans le terminal:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Faites défiler la liste et ajoutez ces lignes à la fin du fichier:

# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m6-amic

Ensuite, enregistrez, redémarrez et testez le son en utilisant des écouteurs et des haut-parleurs.


33
2018-01-08 13:21



C'est toujours le commentaire que je finis par trouver qui corrige mon son après avoir réinstallé mon ordinateur portable. Alors merci et salut le futur moi :-) - Travis
Je n'ai pas eu à redémarrer. Au lieu de courir sudo alsa force-reload puis débranchez et insérez le casque. - buzypi
n'a pas fonctionné mon Dell XPS 13, 9360 exécutant Ubuntu 16.04 son vient à la fois des haut-parleurs et des écouteurs - Omid
Travaillé comme un charme sur mon ThinkPad P50 avec Ubuntu 16.10 - rafaelcpalmeida
Dans mon cas, cela détecte uniquement le casque lorsqu'il est branché lors du redémarrage. Avant la dernière mise à jour, Ubuntu a détecté l'action du plug-in et vous a demandé s'il s'agissait d'un casque, d'un micro ou d'un casque. Comment puis-je avoir ce comportement? - Daniel Cerecedo


J'ai eu le même problème après l'installation de 16.06 Ubuntu Gnome dans mon Dell XPS. alors je résous ce problème par .......

sudo apt-get install pavucontrol

après l'installation de pavucontrol. ouvrez-le en tapant simplement le terminal pavucontrol.

puis allez dans -> onglet Périphériques de sortie -> changez le port

dans mon cas, le port sélectionné était casque (branché) par défaut après prise casque

enter image description here

changer le port Casque (branché) aux haut-parleurs (indisponible).

enter image description here


C'est un correctif temporaire. Après avoir redémarré votre PC, vous devez recommencer.


18
2017-08-15 05:58



Excellent outil, il a exposé tout ce dont j'avais besoin pour savoir ce qui se passait, sans aucun problème de configuration. - Kzqai


La solution dans un commentaire ci-dessus par buzypy a fonctionné pour moi, sans aucun des autres éléments:

sudo alsa force-reload

puis rouvrir pavucontrol et changer pour l'option Headphones (unplugged) et redémarrez le programme qui jouait le son.

Ce sont des problèmes comme ceux-là qui empêchent les gens d'utiliser Ubuntu!


4
2018-06-07 20:16



Yeeee-haw. Après le test de mod et alsa installer et mettre en sourdine et désactiver le son etc etc etc ... <3 - Lotus


Sur mon ordinateur portable, un Lenovo G465, le son fonctionnait bien: chaque fois que je branche le casque, il est détecté et le son passe dans les écouteurs et assourdit les haut-parleurs. Soudain, il a cessé de fonctionner. Quelque chose de bizarre s'est passé sans aucune modification, installation ou autre. J'ai lu que quelqu'un devait utiliser alsamixer pour l'activer: voilà: j'ai bricolé les volumes et les mutings et soudain, ça a recommencé à fonctionner comme avant !!! Je n'ai aucune explication, honnêtement.


2
2017-11-19 13:07



Vivre la même chose avec mon ordinateur portable Lenovo ce matin - Yura
Redémarrage aidé :) - Yura


J'ai eu le même problème. J'ai fait comme ci-dessous

  • Aller aux paramètres
  • Cliquez sur Paramètres son dans la section matériel
  • Cliquez sur l'onglet de sortie (sélectionné automatiquement par le système)
  • En bas: régler le volume de sortie à 100%

Grâce à https://superuser.com/questions/357623/headset-is-not-working-with-ubuntu-11-10


1
2018-05-06 18:29



J'ai déjà essayé ça. ne fonctionne pas - lexical lemon
Pas une solution parce que seule la prise casque ne fonctionne pas. - Pavel Vlasov
Aidé pour moi Mes écouteurs ont été coupés pour une raison quelconque. - Serge Vinogradoff


Dans mon cas, pour un Dell E5450, il a été résolu après l'exécution:

sudo modprobe snd-hda-codec-idt

1
2017-12-01 16:02





Au jour je l'ai eu dans moyen facile:

Comment utiliser le casque dans Ubuntu:

  1. Installez la mise à jour pour Ubuntu.
  2. Installez GNOME alsa mixer.
  3. Branchez les deux haut-parleurs arrière et le casque avant.
  4. Dans ALSA: désactivez votre colonne avant, réactivez le son dans Headphone.
  5. Aller au réglage du son: désactivez le son créé par ALSA.
  6. Clique le Test sonore bouton pour aller au test des paramètres sonores, cochez gauche et droite ==> SEUL CASQUE a un son, le haut-parleur sera silencieux.

enter image description here 

enter image description here

enter image description here

IMG:


1
2018-03-11 04:50





J'ai dû faire ce qui suit:

  1. Sortir de Google Chrome (j'essaie de faire jouer de la musique dans un languette)
  2. dans un terminal, courir killall chrome - dira probablement "aucun trouvé" ou autre
  3. tuer pulseaudio avec pulseaudio -k à un terminal. (il devrait redémarrer silencieusement en arrière-plan, mais si ne pas essayer pulseaudio -d)
  4. maintenant courir sudo alsa force-reload  (Merci @mjp !!)

0
2017-08-03 19:46