Question Comment installer le plugin Java pour Firefox?


J'essaie d'installer Java et les plugins pour Firefox. J'ai installé à la fois le JDK et JRE.

Quand j'essaie avec le sudo update-alternatives --config java commande il montre un seul choix disponible.

Les plugins ne sont pas utilisables dans Firefox.


66
2017-10-06 11:51


origine


Comme vous n'avez pas encore installé java, un seul choix est affiché. - M.Tarun
Pour moi, le problème n'est pas clair. Java fonctionne-t-il correctement? Pouvez-vous compiler et exécuter des programmes Java? - Luís de Sousa
Si j'ai bien compris, vous avez installé jdk, jre et les plug-ins de navigateur (icedtea). Mais vous ne pouvez pas utiliser les plugins, pouvez-vous expliquer plus en détail le problème? Avez-vous une erreur? Au moins, vous pouvez désinstaller (Supprimer) et réinstaller IcedTea au Software Center. - Luís de Sousa
@Seth mais vous voulez que OP lise tout cela pour quelque chose qui peut être résolu en 1 ligne? L'autre est une réponse exagérée, la question est juste "comment installer Java?" Bien qu'il s'agisse de "comment installer le plug-in de navigateur Java pour Firefox?", ces questions sont différentes et ne peuvent pas être fusionnées. - Braiam
Je suis d'accord avec @Braiam ci-dessus. C'est une question différente car la mise à jour de la version Java utilisée par Firefox n'est pas la même chose que la simple installation de Java. J'ai personnellement des JDK Oracle 6, 7 et 8 mais l'installation de icedtea n'a rien fait pour mon firefox. Je devais suivre ces instructions avec un JRE téléchargé depuis java.com. Alors firefox était content. - hinerm


Réponses:


Si vous utilisez une version après 52 (pas ESR), qui NPAPI désactivévous n'avez pas de chance Si vous en utilisez un auparavant, ce que vous ne voudriez absolument pas, vous pouvez installer le JRE OpenJDK, ce qui vous permettrait d’exécuter des binaires Java localement en utilisant le java binaire. Cela ne suffit cependant pas pour exécuter des applets Web Java sur votre navigateur, ce qui peut être réalisé en installant le plug-in Icedtea:

sudo apt-get install icedtea-plugin

Ensuite aller à about:addons, dans la section plug-in, vérifiez si le plug-in est activé. Mozilla désactive les plug-ins non sécurisés par défaut, ce qui signifie que Java est désactivé même après l'installation en raison de problèmes de sécurité. Vous devez l'activer avant de l'utiliser.


73
2017-10-06 14:26



: +1 c'est vrai, et a besoin d'être exécuté: apt-get install default-jre - kikicarbonell
@kikicarbonell sauf si Ubuntu est quelque chose de différent, ce paquet devrait être installé avec icedtea-plugin. - Braiam
pas pour mon cas @Braiam. J'ai Ubuntu 14.04 et open-jdk installés ... mais si seulement exécuter votre commande mon Firefox n'exécute pas l'applet Java ... Plus tard, j'essaye d'exécuter apt-get install par défaut-jre et les problèmes de firefox ont été résolus. - kikicarbonell
@kikicarbonell firefox désactive le plugin java par défaut. Il faut donc lui dire de l'activer. - Braiam


Installation du plugin Java IcedTea:

Pour installer le plug-in IcedTea Java, ouvrez un terminal et tapez:

sudo apt-get install icedtea-7-plugin

Installez le plug-in Firefox - Oracle

Dans un terminal:

mkdir ~/.mozilla/plugins

Supprimez le plug-in IcedTea, s'il a été installé.

sudo apt-get remove icedtea6-plugin

Supprimer une ancienne version du plug-in Java (éventuellement présente)

rm ~/.mozilla/plugins/libnpjp2.so

Maintenant, vous pouvez installer le plug-in, en créant un lien symbolique (vous dites à Firefox où se trouve le plug-in). Pour Java 32 bits, utilisez

ln -s /usr/lib/jvm/jre1.7.0/lib/i386/libnpjp2.so ~/.mozilla/plugins/

Pour une utilisation Java 64 bits

ln -s /usr/lib/jvm/jre1.7.0/lib/amd64/libnpjp2.so ~/.mozilla/plugins/

Confirmez que le JRE a réussi en utilisant le site officiel Oracle.

La source: Installation Java


23
2018-03-12 21:25



Êtes-vous sûr d'avoir répondu à la question? Le gars dit qu'il a déjà installé le jdk et le jre. - Luís de Sousa
Pourquoi compiler jre de sources, pourquoi! - Braiam
n'a pas vu la question correctement :) - M.Tarun
regarder aussi oracle.com/technetwork/java/javase/… pour tout doute - Victor R. Oliveira
Depuis Ubuntu 14.04, Java n'est plus pris en charge dans la version la plus récente de Chrome / Chromium. - Andreas Hartmann


À partir de Firefox version 52, la prise en charge des plug-ins NPAPI (applets Java) dans Firefox a pris fin, en raison de problèmes de performances et de sécurité, la manière d’exécuter des applets Java consiste à installer la version de support étendue de Firefox.

télécharger ici: https://www.mozilla.org/en-US/firefox/organizations/all/

plus de détails ici: https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069


6
2018-05-26 13:55





Si vous venez de télécharger et d’installer java jdk d’oracle, alors, disons que vous avez installé jdk-8u91-linux-x64.tar.gz sur

/ mon / java / répertoire /

Ensuite, vous aurez un répertoire comme:

/my/java/directory/jdk1.8.0_91/

Tout ce que vous avez à faire est d'aller dans le répertoire des plugins ubuntu firefox et de créer un lien:

$: cd /usr/lib/firefox-addons/plugins/
$: sudo ln -s /my/java/directory/jdk1.8.0_91/jre/lib/amd64/libnpjp2.so

4
2018-06-26 17:28



Avec Firefox 50 sur Ubuntu 16.04.1, j'ai trouvé que ce répertoire n'existait pas. D'autres plugins comme IcedTea ont créé des liens symboliques dans /usr/lib/mozilla/plugins. - Dan Dascalescu


Ceci est un vieux fil, mais je suis tombé dessus tout en cherchant une solution à mon problème aujourd'hui. Je pensais que quelqu'un d'autre pourrait être dans la même situation.

J'ai besoin de Java dans le navigateur pour les sites Web liés au travail hérités, et le plugin oracle java ne le coupe pas. Après une longue période d’essais et d’erreurs, IcedTea a fonctionné de manière cohérente dans une version plus ancienne de Firefox comme celle-ci:

  • Télécharger un tar de Firefox, version 51 (la nouvelle version ne supporte pas le plugin)
  • Installez OpenJDK (7 ou 8)
  • Installez le plugin icedtea et le plugin icedtea
  • Maintenant, votre installation openJDK contiendra un fichier IcedTeaPlugin.so dans le dossier jre / lib
  • copiez ceci dans les dossiers du plug-in mozilla / firefox (je ne pouvais pas savoir lequel le copier, donc je l'ai copié dans n'importe quel firefox / plugins ou mozilla / plugins)
  • lancez votre ancienne version de Firefox
  • vérifier que le plugin est actif (vérifiez à propos de: plugins)

Un de mes collègues a créé un script pour supprimer l'ancien firefox et le désarchiver à chaque exécution. De cette façon, il n'est jamais mis à jour accidentellement. Veillez à ne pas le faire avec votre application firefox principale.

J'espère que ceci vous aide.


3
2018-01-31 13:42





Cela a été une bataille, surtout depuis que j'ai parcouru cela il y a quelques mois avec 14.04, j'ai oublié la solution, mise à niveau vers 16.04 .....

C'est différent, j'avais du thé glacé et Oracle travaillant sous firefox en 14.04. En fait, je préfère Oracle (pas généralement mais mon utilisation en a presque besoin), donc je n’ai que cela maintenant. Je n'ai pas essayé plusieurs installations ou dépôts. Les liens symboliques selon la plupart des instructions ne sont pas non plus bons.

En fin de compte, dans Firefox est allé dans Edition -> Préférences -> Applications puis fait défiler jusqu'à l'extension du fichier JNLP et choisi "Utiliser autre ..." dans le menu déroulant. Ensuite, javaws trouvé dans le répertoire pertinent.

Ce n'est qu'une solution de contournement et je ne suis pas sûr que cela convienne à vos besoins. Gardez à l'esprit que la plupart des plugins seront épuisés d'ici mars.


1