Question «Exiger l'installation de packages non approuvés» lors de la mise à niveau avec le gestionnaire de mise à jour


screenshot

Il n'a pas corrigé l'erreur. Alors, comment puis-je réparer ma mise à jour de l'interface graphique?

Pour chaque logiciel, je dois l'installer à partir de la ligne de commande car j'ai eu la même erreur lors de l'installation du logiciel depuis Ubuntu Software Center.


66
2018-03-29 11:55


origine


Sur les sources de logiciels, onglet logiciel Ubuntu, changez simplement le paramètre "download from" en "Server for España". Cela a fonctionné pour moi.
la réponse est terminée ici Son a très bien fonctionné pour moi. - bademba


Réponses:


  1. Ecrire dans un terminal: sudo apt-get update && sudo apt-get upgrade ou modifiez les paramètres de Update Manager (essayez d’abord si vous avez déjà configuré Update Manager).

    CLI

  2. Lancez Update Manager et réessayez.

    GUI

La mise à jour via un terminal permet d’autoriser ou non les packages non approuvés.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Si vous faites confiance à la source du package, tapez y.


64
2018-03-29 17:14





Cela se produit en raison de l'absence de certaines clés GPG. Pour résoudre ce problème, ouvrez un terminal et exécutez les commandes ci-dessous:

sudo apt-get update

Vous obtiendrez une erreur indiquant que certaines clés publiques ne sont pas disponibles. Notez la chaîne de clé (après le NO_PUBKEY; par exemple: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Remplacez le XXXXX par la chaîne de clé

par exemple : gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

par exemple: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Maintenant, essayez de mettre à jour votre système à nouveau.

Voici un article similaire: "Nécessite d'installer des mises à jour non fiables" Erreur dans le gestionnaire de mise à jour

J'espère que cela t'aides.


43
2017-12-01 09:05



essayé ceci et j'ai reçu le message que quelque chose a été créé, mais la mise à jour ne fonctionnait toujours pas. Mais l'option evgeny a fonctionné, donc pas besoin de résoudre ce qui n'a pas fonctionné avec votre proposition. - rumtscho
désolé rumtsho. J'ai oublié d'ajouter la commande 'gpg --export' dans ma réponse. J'ai mis à jour ma réponse. Essayez-le et vérifier si la mise à jour fonctionne ou non. - aneeshep
hmm, je reçois gpg: keyserver timed out; Aucune suggestion? - gatoatigrado
Peut aussi utiliser sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com XXXXXXXXX de askubuntu.com/questions/71188/… - pd12


Vous pouvez l'installer via la ligne de commande: sudo apt-get install --allow-unauthenticated exiv2.

Pour "faire confiance" de manière permanente au référentiel, exécutez ceci: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update. Je crois que c'est l'APP que vous utilisez.


13
2017-12-01 09:12



Merci, le "faire confiance en permanence au repo" est ce que je voulais réaliser et cela a fonctionné. Je me demande juste pourquoi écrire l'adresse dans la source.list ne la rend pas fiable, mais apt-add-repository le fait. - rumtscho
Tous les packages sont signés avec une clé cryptographique, "faire confiance" au référentiel implique d'obtenir la clé publique pour ce référentiel. Vous pouvez lire sur la cryptographie à clé publique sur Wikipedia. - evgeny


En réponse à votre question, vous ne peux pas "réparer" la mise à jour de l'interface graphique (par exemple, Update Manager), car il est évident que cette application n'a actuellement pas la capacité d'installer des packages non fiables. Si vous souhaitez installer des packages non approuvés, vous devez le faire sur la ligne de commande.

Il existe toutefois deux manières d’empêcher Update Manager de signaler cette erreur: supprimez le logiciel non approuvé de votre système OU confiance le référentiel en question, comme indiqué dans la réponse à l'autre question ( Les mises à jour ne sont pas installées à cause de "paquets non approuvés" ).

La première étape consiste à trouver le référentiel à l'origine du problème. Vous pouvez le trouver en tapant apt-cache policy ambiance-colors sur la ligne de commande.

Cependant, un rapide google révèle que ambiance-colors et radiance-colors sont issus ppa:ravefinity-project. Donc, vous devriez être capable de résoudre votre problème en tapant

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

pris à partir de http://www.webupd8.org/2012/01/ambiance-and-radiance-colors-theme-pack.html


5
2018-06-10 20:06





pourquoi cela dit-il, les paquets que vous essayez d’installer sont des logiciels tiers. Si vous voulez les installer, activez la case à cocher Canonical sur les autres onglets du logiciel dans les paramètres du gestionnaire de mise à jour, puis réessayez.

J'espère que cela pourra aider .


1
2018-03-29 17:21





J'ai eu le même problème. Pour moi, cette commande a fonctionné:

sudo apt-get update --fix-missing

L'avantage de cela par rapport aux autres solutions est sa simplicité. Vous pouvez continuer à utiliser l'interface graphique et vous n'avez pas besoin de savoir quel référentiel est brisé. J'ai trouvé la solution ici dans un commentaire. Je ne connais pas assez Ubuntu pour expliquer, mais je suppose que cela donne les clés nécessaires pour que tous les repos fonctionnent.


1
2017-09-20 08:58





Votre question n'est pas claire: vous "corrigez votre mise à jour de l'interface graphique" en corrigeant l'erreur. L'autre question va vous montrer quoi faire.

Vous pouvez désélectionner n'importe laquelle de vos mises à jour en vous basant sur une source non fiable, ou vous pouvez aller de l'avant et utiliser la ligne de commande pour faire confiance en permanence à cette source particulière. Une fois que vous en avez terminé, le message n'apparaîtra pas. Si vous faites ce dernier, le message n'apparaîtra plus jamais pour cette source spécifique.


0
2018-03-29 17:04