Question Avec le noyau 3.12.15-031215-generic et VMware Workstation 10.0.1 build-1379776 vmware-modconfig --console --install-all a échoué


Here is the log 

Stopping VMware services:
   VMware Authentication Daemon                                        done
   VM communication interface socket family                            done
   Virtual machine communication interface                             done
   Virtual machine monitor                                             done
   Blocking file system                                                done
Using 2.6.x kernel build system.
make: Entering directory `/tmp/modconfig-NlyMwS/vmmon-only'
/usr/bin/make -C /lib/modules/3.12.15-031215-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
      MODULEBUILDDIR= modules
make[1]: Entering directory `/usr/src/linux-headers-3.12.15-031215-generic'
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/linux/driver.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/linux/driverLog.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/linux/hostif.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/apic.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/comport.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/cpuid.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/hashFunc.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/memtrack.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/phystrack.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/task.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/common/vmx86.o
  CC [M]  /tmp/modconfig-NlyMwS/vmmon-only/vmcore/moduleloop.o
  LD [M]  /tmp/modconfig-NlyMwS/vmmon-only/vmmon.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: "mcount" [/tmp/modconfig-NlyMwS/vmmon-only/vmmon.ko] undefined!
  CC      /tmp/modconfig-NlyMwS/vmmon-only/vmmon.mod.o
  LD [M]  /tmp/modconfig-NlyMwS/vmmon-only/vmmon.ko
make[1]: Leaving directory `/usr/src/linux-headers-3.12.15-031215-generic'
/usr/bin/make -C $PWD SRCROOT=$PWD/. \
      MODULEBUILDDIR= postbuild
make[1]: Entering directory `/tmp/modconfig-NlyMwS/vmmon-only'
make[1]: `postbuild' is up to date.
make[1]: Leaving directory `/tmp/modconfig-NlyMwS/vmmon-only'
cp -f vmmon.ko ./../vmmon.o
make: Leaving directory `/tmp/modconfig-NlyMwS/vmmon-only'
Using 2.6.x kernel build system.
make: Entering directory `/tmp/modconfig-NlyMwS/vmnet-only'
/usr/bin/make -C /lib/modules/3.12.15-031215-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. \
      MODULEBUILDDIR= modules
make[1]: Entering directory `/usr/src/linux-headers-3.12.15-031215-generic'
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/driver.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/hub.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/userif.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/netif.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/bridge.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/filter.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/procfs.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/smac_compat.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/smac.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/vnetEvent.o
  CC [M]  /tmp/modconfig-NlyMwS/vmnet-only/vnetUserListener.o
  LD [M]  /tmp/modconfig-NlyMwS/vmnet-only/vmnet.o
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: "mcount" [/tmp/modconfig-NlyMwS/vmnet-only/vmnet.ko] undefined!
  CC      /tmp/modconfig-NlyMwS/vmnet-only/vmnet.mod.o
  LD [M]  /tmp/modconfig-NlyMwS/vmnet-only/vmnet.ko
make[1]: Leaving directory `/usr/src/linux-headers-3.12.15-031215-generic'
/usr/bin/make -C $PWD SRCROOT=$PWD/. \
      MODULEBUILDDIR= postbuild
make[1]: Entering directory `/tmp/modconfig-NlyMwS/vmnet-only'
make[1]: `postbuild' is up to date.
make[1]: Leaving directory `/tmp/modconfig-NlyMwS/vmnet-only'
cp -f vmnet.ko ./../vmnet.o
make: Leaving directory `/tmp/modconfig-NlyMwS/vmnet-only'
Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual machine communication interface                             done
   VM communication interface socket family                            done
   Blocking file system                                                done
   Virtual ethernet                                                   failed
   VMware Authentication Daemon                                        done
Unable to start services


/var/log/syslog
###
Mar 28 21:22:17  kernel: [  173.580452] vmmon: Unknown symbol mcount (err 0)
Mar 28 21:22:17  kernel: [  173.590567] Guest personality initialized and is inactive
Mar 28 21:22:17  kernel: [  173.590614] VMCI host device registered (name=vmci, major=10, minor=56)
Mar 28 21:22:17  kernel: [  173.590616] Initialized host personality
Mar 28 21:22:17  kernel: [  173.603780] NET: Registered protocol family 40
Mar 28 21:22:17  kernel: [  173.647354] vmnet: Unknown symbol mcount (err 0)
Mar 28 21:24:59  kernel: [  335.759663] NET: Unregistered protocol family 40
Mar 28 21:25:03  kernel: [  339.530533] vmmon: Unknown symbol mcount (err 0)
Mar 28 21:25:03  kernel: [  339.537892] Guest personality initialized and is inactive
Mar 28 21:25:03  kernel: [  339.537931] VMCI host device registered (name=vmci, major=10, minor=56)
Mar 28 21:25:03  kernel: [  339.537932] Initialized host personality
Mar 28 21:25:03  kernel: [  339.552037] NET: Registered protocol family 40
Mar 28 21:25:03  kernel: [  339.598377] vmnet: Unknown symbol mcount (err 0)
Mar 28 21:27:59  AptDaemon: INFO: Quitting due to inactivity
Mar 28 21:27:59  AptDaemon: INFO: Quitting was requested
Mar 28 21:30:45  kernel: [  681.570285] NET: Unregistered protocol family 40
Mar 28 21:30:49  kernel: [  685.495775] vmmon: Unknown symbol mcount (err 0)
Mar 28 21:30:49  kernel: [  685.503248] Guest personality initialized and is inactive
Mar 28 21:30:49  kernel: [  685.503287] VMCI host device registered (name=vmci, major=10, minor=56)
Mar 28 21:30:49  kernel: [  685.503288] Initialized host personality
Mar 28 21:30:49  kernel: [  685.516189] NET: Registered protocol family 40
Mar 28 21:30:49  kernel: [  685.561863] vmnet: Unknown symbol mcount (err 0)

1
2018-03-28 13:34


origine




Réponses:


Dans mon environnement, j'installe gcc4.5 par défaut, après la mise à jour de gcc4.6. Ce sera un succès.


1
2018-04-01 02:13



Alors ... tu as trouvé la réponse? - Seth♦
oui, juste utiliser gcc4.6 l'erreur a disparu. Pourquoi gcc4.5 ne fonctionne pas Il faut du temps pour trouver. - jiamo