Question problème d'installation d'une ancienne version de gcc


problème d'installation d'une ancienne version de gcc

Salut,

Je suis nouveau à Ubuntu :)

J'essaie de compiler un programme dans Matlab en utilisant mex (Matlab), mais je reçois une erreur en utilisant la version 4.6.3 de gcc et la version actuellement prise en charge avec mex est 4.4.x.

J'ai donc téléchargé gcc 4.4.3, mais quand j'essaye de l'ouvrir en utilisant le centre logiciel Ubuntu, je reçois une erreur: la dépendance n'est pas satisfaisante: gcc-4.4-base (= 4.4.3-4ubuntu5.1).

Je ne sais pas comment résoudre ce problème. quelqu'un peut-il aider s'il vous plait? toute aide sera grandement appréciée car je suis assez coincé.

Merci d'avance,

Gil.


1
2017-07-15 16:20


origine




Réponses:


Vous n'avez pas besoin de télécharger un package manuellement. Installez-le simplement en utilisant Software Center et il téléchargera les paquets appropriés pour votre installation! C'est comme cela que Software Center fonctionne facilement.

Cliquez ici: gcc-4.4 Install gcc-4.4.

Puis utilisez gcc-4.4 invoquer cette version spécifique. Votre gcc sera conservé la version par défaut si. Si vous avez vraiment besoin de changer la valeur par défaut du système, voir Choisissez la version de gcc et g ++


1
2017-07-15 16:25



@ user175405 Si cela vous a été utile et a résolu votre problème, envisagez d’accepter cette réponse en utilisant la coche. - gertvdijk