Question Impossible de se connecter au WiFI après la mise à niveau vers 15.10, cauchemar de WPA2 Enterprise / PEAP


Impossible de se connecter au réseau WiFi de mon école après une mise à niveau vers Kubuntu 15.10

WPA2 Enterprise
PEAP 
no certificate

Le gestionnaire de réseau continue à demander le mot de passe (même s'il a été fourni), mais ne se connecte jamais.

Je peux me connecter via mon téléphone Android

[connection]
id=Prof
uuid=2c64b06f-d391-47ed-987b-eae020c251b5
type=wifi
permissions=user:fx:;
secondaries=

[wifi]
mac-address-blacklist=
mode=infrastructure
seen-bssids=
ssid=Prof

[wifi-security]
group=
key-mgmt=wpa-eap
pairwise=
proto=

[802-1x]
altsubject-matches=
eap=peap;
identity=fpx
password-flags=1
phase2-altsubject-matches=
phase2-auth=mschapv2

[ipv4]
dns-search=
method=auto

[ipv6]
dns-search=
method=auto

Donc, ce n'est pas le problème système-ca-cert = vrai - la ligne est absente

Aucune suggestion?

sortie dmesg:

[  319.869729] wlp2s0: authenticate with 9c:1c:12:2b:80:01
[  319.890789] wlp2s0: send auth to 9c:1c:12:2b:80:01 (try 1/3)
[  319.893335] wlp2s0: authenticated
[  319.897183] wlp2s0: associate with 9c:1c:12:2b:80:01 (try 1/3)
[  319.903786] wlp2s0: RX AssocResp from 9c:1c:12:2b:80:01 (capab=0x431 status=0 aid=1)
[  319.903880] wlp2s0: associated
[  344.003693] wlp2s0: deauthenticating from 9c:1c:12:2b:80:01 by local choice (Reason: 3=DEAUTH_LEAVING)
[  344.015722] cfg80211: World regulatory domain updated:
[  344.015727] cfg80211:  DFS Master region: unset
[  344.015728] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  344.015732] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  344.015735] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  344.015738] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[  344.015741] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  344.015745] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  344.015747] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[  344.015750] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[  344.015753] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[  344.020244] cfg80211: Regulatory domain changed to country: IN
[  344.020248] cfg80211:  DFS Master region: JP
[  344.020249] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[  344.020252] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[  344.020255] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[  344.020257] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[  344.020258] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[  353.950765] wlp2s0: authenticate with 9c:1c:12:2b:80:01
[  353.971680] wlp2s0: send auth to 9c:1c:12:2b:80:01 (try 1/3)
[  353.977292] wlp2s0: authenticated
[  353.978218] wlp2s0: associate with 9c:1c:12:2b:80:01 (try 1/3)
[  353.983815] wlp2s0: RX AssocResp from 9c:1c:12:2b:80:01 (capab=0x431 status=0 aid=1)
[  353.983907] wlp2s0: associated

1
2017-11-13 11:43


origine


Pouvez-vous vous connecter à d'autres réseaux wifi? - Raphael
Oui, pas de problème avec un autre réseau. Mais mon école est le seul réseau que j'utilise qui utilise WPA2 Enterprise. - FXF
Wow - cela semble très similaire - askubuntu.com/questions/279762/… - Raphael
oui, c'est exactement la même situation. la première solution, changer system-ca-cert = true ne s'applique pas, puisque mon fichier conf n'a pas la ligne. J'ai également essayé de rétrograder wpasupplicant, mais j'ai des problèmes de dépendance et cela brise tout. - FXF


Réponses:


J'ai eu un problème similaire. Actuellement, la solution à ce problème est de rétrograder wpasupplicant:

Après la mise à niveau vers 15.10, le Wifi vers un réseau d'entreprise (WPA2) ne fonctionne plus

echo "deb http://london.mirrors.linode.com/ubuntu/ vivid main" | sudo tee /etc/apt/sources.list.d/vivid.list
echo -e "Package: *\nPin: release o=Ubuntu,n=vivid\nPin-Priority: -1" | sudo tee cat /etc/apt/preferences.d/vivid
sudo apt-get update
sudo apt-get install wpasupplicant=2.1-0ubuntu7
sudo apt-mark hold wpasupplicant
sudo /etc/init.d/network-manager restart

J'utilise actuellement la version 2.1.

wpa_supplicant -v
wpa_supplicant v2.1
Copyright (c) 2003-2014, Jouni Malinen <j@w1.fi> and contributors

0
2018-03-09 19:07



Je suis sur la même version de wpa_supplicant (maintenant avec Ubuntu 16.04) et j'ai un problème presque identique. (Identique sauf que notre réseau utilise un certificat.) - Erik Garrison