Question Comment puis-je désactiver Bluetooth au démarrage du système?


Comment puis-je désactiver Bluetooth au démarrage du système?


277
2017-10-16 21:02


origine


Je ne pense pas que "devrait être la configuration par défaut naturelle", les gens voudront utiliser Bluetooth sur leurs ordinateurs sans avoir à l'allumer (vous ne semblez pas avoir une souris ou un clavier Bluetooth, si c'était votre périphériques d’entrée primaires sur lesquels vous souhaitez que Bluetooth soit démarré). Cependant, je suis d’accord pour dire qu’il serait utile d’avoir un moyen de choisir la façon dont Bluetooth doit être démarré. - roadmr
La chose normale et naturelle est de vous laisser choisir, dans les paramètres Bluetooth, si vous le souhaitez ou non quand il démarre. Il n’est pas naturel d’avoir des gens qui éteignent ou allument chaque fois qu’ils allument leur ordinateur. Nous parlons de faire de Linux le meilleur système de bureau, pas le pire, n'est-ce pas? - Robert
Nous convenons que laisser les gens choisir est la meilleure option. Voyez ici quelques manières possibles de le faire. réponses.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
C'est bug # 1073669. - colan
Il est incroyable de constater que, lors de la 14ème édition, nous "enseignons toujours aux développeurs Ubuntu des choses comme" la possibilité d’avoir un bluetooth allumé ou éteint au démarrage devrait être disponible pour les utilisateurs normaux, et pas seulement pour ceux qui recherchent des lignes interminables. des forums publics ". - Rodrigo


Réponses:


18.04+ utilisateurs qui n'ont pas naturellement un fichier /etc/rc.local, vous devrez en créer un et le rendre exécutable. Pour faciliter les choses, vous pouvez simplement coller la commande suivante dans un terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Courir sudoedit /etc/rc.local et ajoutez ceci avant la ligne avec exit 0:

rfkill block bluetooth

Vous devriez toujours pouvoir activer Bluetooth via l'applet de la barre supérieure.

Ce devrait fonctionne pour la plupart des systèmes, mais il semblerait qu'il y ait quelques bogues dans l'ACPI du noyau pour les Thinkpads. Si vous êtes sur un Thinkpad, ajoutez ce qui suit à /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Ou consultez ibm-acpi - Pilote supplémentaire IBM ThinkPad ACPI - Certains rapports suggèrent qu'ibm-acpi inclut un contrôle Bluetooth (entre autres choses intéressantes). Mais je n'ai pas le matériel, donc je suis complètement incapable de vérifier ces affirmations. Bonne chance.


189
2017-08-18 09:00



Pour les Thinkpads (et uniquement les Thinkpads), cela fonctionne: echo disable > /proc/acpi/ibm/bluetooth dans /etc/rc.local - Marius Gedminas
rfkill block bluetooth travaillé pour Thinkpad T430u - bmaupin
Ni travaillé pour moi (ThinkPad x201) quand je les ai placés un par un dans /etc/rc.local. le rfkill block bluetooth commande fonctionne, mais pas au démarrage. L'indicateur -x est défini sur /etc/rc.local. J'utilise Xubuntu 13.10. - Kyle Falconer
Sur Ubuntu 15.10 avec systemd vous avez besoin de plus pour réactiver l'utilisation du etc/rc.local fichier: askubuntu.com/a/696226/34298 - rubo77
Si notre fichier rc.local est juste un fichier vide, où devrions-nous ajouter «bluetooth block rfkill»? - Sss


J'ai trouvé un tutoriel avec une "solution de contournement" propre ici (lien d'archive pour la postérité)

En train de changer /etc/bluetooth/main.conf était suffisant pour moi

De l'article:

Rechercher l'entrée:

InitiallyPowered = true

et changez la valeur pour:

InitiallyPowered = false

Cela me suffisait, bien que l'article décrive d'autres étapes qui peuvent ou non être nécessaires.

Sur Ubuntu 17.10 et Ubuntu 18.04 l'option InitiallyPowered a été remplacé par AutoEnable


70
2018-06-25 18:00



ne fonctionne pas pour ordinateur portable samsung 530u3b, bluetooth est toujours activé après le redémarrage et le réveil - Maxim Kim
Cela ne marcherait que si j'utilisais aussi la réponse de Saeed Zarinfam pour mettre /etc/init.d/bluetooth stop dans rc.local. Il semble que lorsque le service démarre, il met également le bluetooth sous tension. J'avais besoin des deux pour que cela fonctionne. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Je n'ai pas travaillé sur thinkpad t420 - UpTheCreek
"Rechercher l’entrée" ne sert à rien à ceux d’entre nous dont main.conf ne contient pas ce paramètre ni aucun commentaire indiquant son emplacement par défaut. Donc, sous lequel [Heading] devrions-nous le mettre? - underscore_d
Dans mon cas, c'était AutoEnable = false, mais de toute façon +1 pour la bonne solution du bon endroit. - Arman Petrosyan


Pour désactiver le pilote Bluetooth lors du chargement au démarrage:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

ajouter:

blacklist btusb

L'activer plus tard ne devrait être que:

sudo modprobe btusb

23
2017-08-18 16:59



Merci pour cela, cela semble fonctionner, mais j'essayais d'éviter les choses en ligne de commande conformément à ma question initiale. Vous penseriez que ce serait aussi simple que de cocher une case pour que vous vous souveniez que je ne veux pas que BT démarre automatiquement, mais cela semble plus compliqué que cela. Avec le lecteur Ubuntu pour des temps de démarrage plus rapides et l'accent mis sur la consommation d'énergie dans les ordinateurs portables et les netbooks, je suis surpris que cela n'ait jamais été résolu. J'apprécie l'aide cependant.
"Lancez gedit en tant que root et éditez /etc/modprobe.d/blacklist.conf" <- ok, est-ce moins de ligne de commande pour vous? - maco
Fonctionne bien sur Samsung Q35 avec Ubuntu 13.10, alors que l'approche «rfkill block bluetooth» ne le fait pas. Merci! - user27164
DELL E6410 fonctionne pour moi. Bon qui peut fonctionner à nouveau sans réinitialisation. - Ruslan Gerasimov
Ne vous préoccupez pas d'essayer "d'éviter les éléments de la ligne de commande" lorsque vous configurez le système d'exploitation. Est-ce que Ctrl + Alt + T et quelques ctrl-shift-V (coller) sont trop demander? - doug65536


Étape 1: Accédez au terminal et entrez la commande suivante pour modifier le système /etc/rc.local fichier:

gksudo gedit /etc/rc.local

Étape 2: Ajouter la ligne suivante avant le exit 0 ligne:

rfkill block bluetooth

16
2018-05-04 20:44



Ceci est réglé sur bluetooth, je pense que c'est la même chose que désactiver son service et fonctionne bien. - Smile.Hunter
@Robert: $ man rfkill: "Désactiver le périphérique correspondant à l'index donné."Malgré le nom, il ne fait que désactiver BT, essayez simplement la commande rfkill block bluetooth sur le terminal, vous devriez voir l’icône devenir grise. - Daniel


Depuis ubuntu 16.04, systemd gère les services de démarrage tels que bluetooth ... pour afficher le problème de statut actuel dans un terminal

sudo systemctl status bluetooth.service 

désactiver le bluetooth sur le problème de démarrage ceci

sudo systemctl disable bluetooth.service

puis sur le prochain redémarrage bluetooth ne sera pas actif ... pour activer le problème Bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Cela fonctionne pour moi, mais comme un effet secondaire, blueman-applet s'est arrêté pour fonctionner aussi. Il démarre, mais n'apparaît pas dans la zone de l'indicateur, il n'y a donc pas de moyen rapide d'activer le Bluetooth, uniquement dans le terminal. - Yuri Gor
Dans Xubuntu, au moins, si vous cliquez sur Blueman, l'option «Désactiver Bluetooth» est disponible. Je pense que c'est ce que le PO souhaiterait automatiser. Votre solution supprime complètement Blueman, ce qui rend plus difficile la réactivation de Bluetooth si vous le souhaitez. - Adrian Keister
Mettez sudo systemctl disable bluetooth.service && sudo systemctl arrêtez bluetooth.service dans un script Disable, et chmod 755 dessus. Faites de même pour sudo systemctl enable bluetooth.service && sudo systemctl lancez bluetooth.service dans un script Enable. - Adrian Keister


Tapez ce qui suit dans un terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Au bas du fichier, ajoutez la ligne:

blacklist bluetooth

Enregistrez le fichier et redémarrez - Bluetooth devrait maintenant être désactivé.


7
2017-10-16 21:25



Cela ne marchera pas sur mon pc ... - Floqqi
@Floqqi: Pouvez-vous s'il vous plaît essayer à nouveau? J'ai mis à jour ma réponse. - Nathan Osman
J'ai essayé environ 20 choses sur mon ThinkPad Ubuntu 12, c'est le seul qui a fait l'affaire. - OlivierBlanvillain


Vous pouvez modifier les services démarrés au démarrage avec l'aide de CLOCHARD.

Installez-le: sudo apt-get install bum

Courir: sudo bum

enter image description here 

Décochez la case et cliquez Appliquer.


7
2018-05-05 00:09



Merci, desgua, je pensais à ce genre d'outils. J'en ai déjà utilisé dans le passé, mais ils sont devenus obsolètes et le nouvel ubuntu, avec son obsession minimaliste, n'a rien de tel. Est-ce le seul que vous savez ou le meilleur que vous sachiez? - Robert
Peut-être fonctionne-t-il mais au début il m'a déçu car il a commencé à montrer le bluetooth comme non activé au démarrage, pourquoi? et comme ne fonctionnant pas lorsque rfkill, l'applet et hciconfig le montrent en cours d'exécution. Je me sens éteint et allumé mais je continue à montrer le service comme étant éteint. J'ai activé le service au démarrage mais le statut du service continue à être erroné. - Robert
désolé ne fonctionne pas sur elementaryOS Freya - Hoang Tran
Je reçois beaucoup d’avertissements lorsqu’ils sont exécutés. Désolé, je ne peux pas faire confiance à cela. - doug65536
Maintenant, le paquet n'est pas disponible. Cela dit, Bum est virtuel. - Satya Prakash


Je pense que le meilleur moyen est d’empêcher le démarrage du service. Il existe une méthode générale pour désactiver les services qui fonctionne parfaitement:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Cela fonctionne pour Ubuntu 13.10 et probablement pour les versions antérieures.


5
2018-01-18 09:49



Comment activer le Bluetooth, tout en utilisant les paramètres fournis ultérieurement? dis que je veux l'utiliser juste pour 5 min. toutes les 10 bottes .. - b1r3k


J'ajoute

"/etc/init.d/bluetooth stop"

dans

"/etc/rc.local" 

avant la commande "exit 0" pour le démarrage avec bluetooth désactivé.


5
2017-08-23 13:00



cela a fonctionné pour moi, merci! - woohoo
Cela a supprimé l'icône du plateau Bluetooth mais a laissé mon témoin Bluetooth allumé (indiquant que le courant était toujours envoyé à la radio). Edit: ceci en conjonction avec la réponse de Stepbaer (InitiallyPowered = false) travaillé pour moi (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Cela ne fonctionnait pas sur mon Ubuntu 14.04 dell inspiron 64 bits. Seul rfkill a fonctionné pour moi. - faizal


1. bluetooth bloque dans rc.local

Ajoutez cette ligne à la fin du fichier /etc/rc.local juste avant la ligne exit 0:

rfkill block bluetooth

Cela fera l'affaire, mais seulement dans les anciennes versions d'Ubuntu utilisant parvenu.

2. réactiver rc.local sur systemd

Sur Ubuntu 15.10 avec systemd en tant que gestionnaire de démarrage le /etc/rc.local fichier n'est plus utilisé par défaut, appelez cela sur un terminal:

sudo systemctl edit --full rc-local

Ce qui ouvre un éditeur. A la fin du fichier, j'ai ajouté:

[Install]
WantedBy=multi-user.target

Ces changements sont activés par

sudo systemctl reenable rc-local

Maintenant le fichier /etc/rc.local est utilisé comme vous le savez.

3. désactiver blueman-applet au démarrage

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Maintenant, blueman-applet est visible et vous pouvez le désactiver à partir des programmes de démarrage

4. Redémarrez pour voir l'effet


5
2017-11-10 12:29



Pour moi sur Ubuntu 17.04 avec blueman: gsettings set org.blueman.plugins.powermanager auto-power-on false travaillé, de wiki.archlinux.org/index.php/Blueman. Bien que j'ai fini par faire sudo apt remove blueman puis gérer le bluetooth via les paramètres du système et cocher "Afficher le statut Bluetooth dans la barre de menus". Blueman commençait et allumait le bluetooth était le problème. - Michael Jackson