Question Wifi pour Centrino Wireless-N 1000 Intel Corporation (HP Pavilion dm4 - 2070us) ne fonctionne pas


J'ai un HP Pavilion dm4-2070us qui possède un adaptateur Intel Corporation Centrino Wireless-N 1000.

Le problème est que mon ordinateur ne montre pas les réseaux sans fil après avoir mis à niveau mon système vers Ubuntu 11.10. Voici ma sortie pour sudo lshw -class network:

*-network DISABLED      
   description: Wireless interface
   product: Centrino Wireless-N 1000
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlan0
   version: 00
   serial: 8c:a9:82:81:5a:30
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:42 memory:c2500000-c2501fff

*-network
   description: Ethernet interface
   product: AR8151 v2.0 Gigabit Ethernet
   vendor: Atheros Communications
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: eth0
   version: c0
   serial: 2c:41:38:07:f3:e3
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.1.7 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
   resources: irq:44 memory:c1400000-c143ffff ioport:2000(size=128)

La sortie pour rfkill list all:

0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hp-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hp-wwan: Wireless WAN
    Soft blocked: no
    Hard blocked: no

J'ai également recherché l'état du réseau WiFi affiché comme étant désactivé. D'une manière ou d'une autre, tout indiquait que mon appareil sans fil était éteint et qu'il ne pouvait être activé que sous Windows. Cependant, je n'ai pas de partition Windows et il n'y a que Ubuntu 11.10, donc je ne vois aucun intérêt à activer le périphérique sous Windows.


5
2017-11-02 08:34


origine


De plus, lorsque je clique dans le coin supérieur droit de l’écran sur l’icône réseau disponible, cela indique que les appareils sans fil ne sont pas encore prêts! Avant Ubuntu 11.10, j'avais Ubuntu 11.04! et tout fonctionnait bien, même si à ce moment-là j'avais un système dual bootable. - new_bie
ok encore une chose .... mon ami a un ordinateur portable lenovo ... il a la même carte sans fil ... et il utilise 11.10 et il ne fait face à aucun problème avec sa carte sans fil. - new_bie
est la différence que votre ami a installé 32bit 11.10 et vous avez 64bit? - fossfreedom♦
non .. même s'il a un ubuntu 11.10 64 bits !!! Ce problème n'est pas spécifique au fournisseur car nous avons tous deux la même carte sans fil centrino ... !! de plus mon wifi fonctionnait correctement quand j'avais 11.04 .. !! - new_bie


Réponses:


Après avoir essayé différentes distributions et lutté avec ma carte sans fil, je suis finalement tombé sur un lien qui contournait le problème. Apparemment, le nouveau noyau ne parvient pas à détecter la carte sans fil Centrino 1000 N dans certains ordinateurs portables (hp dm4) alors qu'il existe d'autres ordinateurs portables sur lesquels cela fonctionne parfaitement, comme Lenovo Y560P.

Le lien suivant donne la solution !! Même si je ne suis pas sûr que ce travail contiendra plus d'impacts plus tard ou non, mais pour le moment, cela fonctionne bien.

http://community.linuxmint.com/tutorial/view/608

"Pour (temporairement) travailler sans fil sur les nouveaux noyaux:

sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.ucode.backup
sudo modprobe -r iwlagn
sudo modprobe iwlagn

Cela devrait faire en sorte que le sans-fil utilise l’ancienne 1000-3.ucode qui fonctionne pour le moment. "


4
2017-12-14 19:16



S'il vous plaît noter exactement le même problème existe toujours pour moi avec mon Acer 1810-TZ avec une carte wifi Intel sans fil N-1000. MAIS Ubuntu 12.04 PLUS MAINTENANT est livré avec l'ancienne version 3 du microprogramme Intel - j'ai fini par le sortir d'une ancienne distribution Ubuntu que je devais remettre. - Maks
@Maks Voulez-vous dire que vous avez obtenu l'ancienne version du microcode d'une autre distribution? J'ai essayé de l'obtenir du site Web d'Intel intellinuxwireless.org/?n=downloads&f=ucodes_1000  et le copier dans le chemin / lib / firmware. Mais ça n'a pas marché. Est-ce que j'ai râté quelque chose? - new_bie
Désolé, c'était mon erreur, en utilisant l'ancienne version du microcode fait ne pas en fait le réparer pour moi, qu'est-ce qui était de désactiver 802.11 N, J'ai mis à jour ma réponse à l'autre question pour refléter cela. - Maks


Aucune des solutions ci-dessus n'a fonctionné pour moi, je devais passer l'option de mod ci-dessous

/etc/modprobe.d/iwl.conf 
options iwlwifi bt_coex_active=0 

Je l'ai trouvé sur le forum d'Intel que je ne peux pas trouver le lien maintenant.


2
2018-06-20 12:43





J'ai essayé:

echo 'options iwlagn 11n_disable=1' | sudo tee /etc/modprobe.d/iwlagn.conf >/dev/null

et ça marche.


1
2018-02-18 09:06





Eh bien, la meilleure solution consiste à avoir soit le firmware corrigé ou plus probablement le pilote pour fonctionner correctement avec la version 5 du firmware.

Semble que cela a été rapporté "en amont" dans le traqueur de bugs intels.

Mais jusqu'ici, il n'y a pas de meilleure solution que de remplacer la version 5 du firmware par une version plus ancienne 3.

Je vais surveiller le bogue dans le tracker et mettre à jour ma réponse ici une fois qu'ils auront trouvé une meilleure solution.

METTRE À JOUR:

Il s'avère que je me suis trompé - en utilisant l'ancienne version 3 du microcode (ucode), le micrologiciel ne résout pas le problème pour moi. Ce que j'ai confirmé fonctionne dans mon cas au moins utilise la version 5 ucode (telle que livrée en 12.04) mais -charger le pilote avec "N" désactivé:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

selon une réponse à cette question fil de forum.


0
2018-05-02 04:25



J'ai essayé les commandes comme mentionné dans le lien suivant: lien  mais le problème persiste. J'ai aussi essayé de télécharger les images du microcode depuis le site Web d'Intel lien  et j'ai copié le microcode dans le chemin en conséquence. Mais même cela n'a pas fonctionné. Est-ce que j'ai râté quelque chose?? - new_bie
hmmm ... vous avez accepté la réponse - je présume que cela a été résolu par cette réponse? - fossfreedom♦
J'ai mis à jour ma réponse avec plus d'informations, car j'ai découvert que le passage à l'ancien firmware ne fonctionnait pas vraiment pour moi. La vraie résolution de ce problème est bien sûr de faire en sorte que les pilotes du noyau Intel ou un autre développeur utile du noyau propose un correctif à ce problème et que Ubuntu fournisse le pilote mis à jour. - Maks
J'ai essayé tout ce que vous avez mentionné mais sa ne fonctionne pas. Mon matériel est-il en faute? et j'ai posté ma sortie pour le réseau de classe lshw. la section sans fil est affichée comme NON CLAIMÉE !! - new_bie
Je viens de vérifier sur mon ordinateur portable et non, je n'ai pas UNIMAIMED la prochaine fois l'entrée pour le N 1000. Pouvez-vous poster la sortie de votre dmesg | grep iwl ? cela peut avoir des informations utiles sur ce qui se passe lorsque le code ucode est chargé par le pilote. - Maks


J'ai également eu des problèmes avec cela et j'ai essayé beaucoup de suggestions qui étaient ici et dispersées sur Internet sans succès.

J'ai trouvé la commande inxi -N très utile pour déterminer exactement quelle carte sans fil j'utilisais.

Finalement, la solution consistait à copier les pilotes téléchargés depuis le site Web d’Intel. http://wireless.kernel.org/en/users/Drivers/iwlwifi pour / lib / firmware lors du redémarrage sans fil a parfaitement fonctionné.


0
2017-08-03 15:00