Question Le système de paquet est cassé (16.04)


J'ai rencontré un problème de gestion de paquets et je ne sais pas comment le résoudre. j'ai essayé sudo apt -f install plusieurs fois, mais cette erreur persiste. J'ai aussi essayé sudo apt autoremove; sudo apt update, sudo apt-get clean; pourtant l'erreur persiste. Est-il possible de corriger cette erreur?

Voici le message d'erreur pour sudo apt-get -f install:

Lire les listes de colis ... Fait
Arbre de dépendance du bâtiment
Lecture des informations d'état ... Terminé
Corriger les dépendances ... a échoué.
Les packages suivants ont des dépendances non satisfaites:
navigateur chrome: dépend: chrome-codecs-ffmpeg-extra (= 56.0.2924.76-0ubuntu0.16.04.1268)
 mais 57.0.2987.98-0ubuntu0.16.04.1276 est installé ou
 chromium-codecs-ffmpeg (= 56.0.2924.76-0ubuntu0.16.04.1268) mais il n'est pas installé
chrome-browser-l10n: dépend: navigateur chrome (> = 57.0.2987.98-0ubuntu0.16.04.1276)
 mais 56.0.2924.76-0ubuntu0.16.04.1268 est installé
E: erreur, pkgProblemResolver :: Résoudre les ruptures générées, cela peut être
causé par des paquets tenus.

E: Impossible de corriger les dépendances

Sortie de apt policy chromium-browser :

navigateur chrome:
  Installé: 56.0.2924.76-0ubuntu0.16.04.1268
  Candidat: 57.0.2987.98-0ubuntu0.16.04.1276
  Table de version:
57.0.2987.98-0ubuntu0.16.04.1276 500
        500 http: //us.archive.ubuntu.com/ubuntu xenial-updates / universe amd64 Packages
        500 http: //security.ubuntu.com/ubuntu xenial-security / univers amd64 Packages
*** 56.0.2924.76-0ubuntu0.16.04.1268 100
        100 / var / lib / dpkg / status
49.0.2623.108-0ubuntu1.1233 500
        500 http://us.archive.ubuntu.com/ubuntu xenial / universe amd64 Packages

Resultats de sudo apt install chromium-browser=57.0.2987.98-0ubuntu0.16.04.1276

Lire les listes de colis ... Fait
Arbre de dépendance du bâtiment
Lecture des informations d'état ... Terminé
Vous pourriez vouloir lancer 'apt-get -f install' pour corriger ces problèmes:
Les packages suivants ont des dépendances non satisfaites:
update-manager: Depends: update-manager-core (= 1: 16.04.5) mais 1: 16.04.6 doit être installé
update-manager-core: Dépend: python3-update-manager (= 1: 16.04.6) mais 1: 16.04.5 doit être installé
E: dépendances non satisfaites. Essayez 'apt-get -f install' sans paquets (ou spécifiez une solution)

0
2018-04-07 14:06


origine


S'il vous plaît éditer votre question pour ajouter la sortie de apt-cache policy chromium-browser. - fkraiem
@fkraiem: s'il vous plaît voir la mise à jour. J'ai un peu modifié le format, mais le contenu est le même, car ils n'autorisent pas plus de 2 liens dans le post pour les utilisateurs à faible réputation comme moi ... merci beaucoup! - kensaii
Votre version de chromium-browser n'est pas le dernier; essayer sudo apt upgrade, et si cela ne fonctionne pas sudo apt install chromium-browser=57.0.2987.98-0ubuntu0.16.04.1276 pour savoir pourquoi le paquet ne peut pas être mis à niveau. - fkraiem
@fkraiem j'ai ajouté les sorties de sudo apt install chromium-browser=57.0.2987.98-0ubuntu0.16.04.1276 aux questions. j'ai un autre paquet cassé update-manager-core - kensaii
Votre version de update-manager est également derrière, encore une fois vous devez essayer d'installer manuellement la dernière version pour voir ce qui empêche la mise à niveau ... - fkraiem


Réponses:


Un message d'erreur comme celui-ci

navigateur chrome: dépend: chrome-codecs-ffmpeg-extra (=   56.0.2924.76-0ubuntu0.16.04.1268) mais 57.0.2987.98-0ubuntu0.16.04.1276> est installé

doit être interprété comme "votre version de chromium-browser dépend d'une ancienne version de chromium-codecs-ffmpeg-extra". La cause la plus probable est que la mise à niveau de chromium-browser échoué pour une raison quelconque, et en effet apt-cache policy chromium-browser confirme que la version installée n'est pas la plus récente disponible. C'est un problème parce qu'en principe tous les paquets installés sur un système doivent toujours être à leur dernière version.

Nous devons donc mettre à jour chromium-browser à sa dernière version, qui selon la apt-cache policy est 57.0.2987.98-0ubuntu0.16.04.1276. Une façon de faire est de courir sudo apt install chromium-browser=57.0.2987.98-0ubuntu0.16.04.1276.

Malheureusement, cela n'a pas fonctionné car certains autres paquets présentaient le même problème; ils doivent également être mis à niveau manuellement en les ajoutant au apt installcommande (par opposition à une commande séparée) jusqu'à ce que tous les packages obsolètes soient pris en compte.


2
2018-04-07 16:34