Question Quel IDE fonctionne sur Ubuntu 14.04 et fonctionne pour Brightscript Development? [fermé]


Roku BrightScript est un langage de script puissant qui facilite   et rapide pour créer des médias et des applications en réseau pour incorporé   dispositifs. Le langage a intégré le support pour BrightScript   Composants, une bibliothèque de composants légers. Les API du   La plate-forme (périphérique) sur laquelle BrightScript est exécuté est exposée à   BrightScript comme composants BrightScript.

J'ai trouvé que eclipse est un IDE pour le développement de brightscript. Mais je veux savoir, y a-t-il un autre IDE? S'il vous plaît me suggérer


0
2018-06-16 19:26


origine




Réponses:


Je ne pense pas qu'il existe une réponse correcte à cela, cependant, je lancerai une option non IDE.

Il existe un ensemble de définitions pour Sublime Text. Ce n'est pas un IDE, mais toujours une option en fonction de ce que vous préférez.

Pour installer Sublime Text 2 dans Ubuntu 14.04.

sudo add-apt-repository ppa:webupd8team/sublime-text-2
sudo apt-get update
sudo apt-get install sublime-text-installer

Une fois Sublime installé, vous pouvez installer le kit avec les éléments suivants.

cd ~/Library/Application\ Support/Sublime\ Text\ 2/Packages/
git clone git://github.com/cmink/BrightScript.tmbundle.git

Informations sur l'ensemble de définition Brightside

https://github.com/cmink/BrightScript.tmbundle


2
2018-06-16 19:59