Question Comment installer PostgreSQL 8.4 sur 8.04?


Comment installer Postgresql 8.4 pour Ubuntu Hardy 8.04?

sudo apt-get install postgresql va installer postgreSQL 8.3

J'ai essayé d'installer des paquets individuels à partir de

http://www.ubuntuupdates.org/package/core/hardy/main/backports/postgresql-8.4

mais pas capable de résoudre les dépendances

Puis essayé d'ajouter

deb http://de.archive.ubuntu.com/ubuntu hardy-backports main
deb http://de.archive.ubuntu.com/ubuntu hardy-updates main restricted universe
deb http://de.archive.ubuntu.com/ubuntu hardy-security main restricted universe

à /etc/apt/sources.list 

Fonctionnement sudo apt-get update montré

W: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/hardy-updates/main/binary-amd64/Packages.bz2  Hash Sum mismatch

W: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/hardy-updates/universe/binary-amd64/Packages.bz2  Hash Sum mismatch

E: Some index files failed to download, they have been ignored, or old ones used instead.

Puis la commande sudo apt-get install postgresql-8.4

Reading package lists... Done
Building dependency tree
Reading state information... Done
postgresql-8.4 is already the newest version.
You might want to run âapt-get -f installâ to correct these:
The following packages have unmet dependencies.
  libpq-dev: Depends: libpq5 (= 8.3.9-0ubuntu8.04) but 8.4.6-1~hardy1 is to be installed
  postgresql-8.4: Depends: postgresql-common (>= 109~) but it is not going to be installed
  postgresql-client-8.4: Depends: postgresql-client-common (>= 104~) but it is not going to be installed
E: Unmet dependencies. Try âapt-get -f installâ with no packages (or specify a solution).

Toute aide appréciée


0
2018-03-09 08:46


origine




Réponses:


Il semble que le miroir allemand que vous utilisez n’a pas été livré. Vous pouvez réessayer, ou si le problème persiste, essayez un autre miroir (passez de de.archive.ubuntu.com dire, uk.archive.ubuntu.com).


1
2018-03-09 13:48



Essayé, mais a reçu le même message d'erreur - Mithun Sreedharan
Je l'ai essayé aussi maintenant et cela a parfaitement fonctionné (miroir du Royaume-Uni). Pourriez-vous réessayer? Si le problème persiste, pourriez-vous vérifier qu'il n'y a pas de problèmes avec votre système de fichiers: est-ce complet? Monté avec des erreurs? Problèmes signalés dans le journal du système / dmesg? Ou, pourrait-il y avoir un proxy entre vous et le miroir qui vous donnerait des fichiers obsolètes? Dans ces cas, j'essaierais sudo rm /var/lib/apt/lists/??.archive.ubuntu.com_ubuntu_dists_hardy-updates* Même s'il est peu probable que cela aide, cela ne devrait rien casser. Faites juste un apt-get update ensuite. - taneli


Le message 'Hash Sum mismatch' est important - essayez un serveur différent de celui de (ce qui est, je suppose, situé en Allemagne). Essayez d’ajouter les serveurs britanniques à la place:

deb http://uk.archive.ubuntu.com/ubuntu hardy-backports main
deb http://uk.archive.ubuntu.com/ubuntu hardy-updates main restricted universe
deb http://uk.archive.ubuntu.com/ubuntu hardy-security main restricted universe

alors sudo apt-get update && apt-get install postgresql-8.4


1
2018-03-09 13:49



Essayé, mais a reçu le même message d'erreur - Mithun Sreedharan