Question Le pilote graphique Nvidia est installé mais la carte graphique n'est pas utilisée!


Il semble que le système ait réussi à installer le pilote propriétaire nvidia, comme illustré dans l'image ci-dessous.

driver installed

Cependant, il semble que le système n'utilise pas la carte graphique.

enter image description here

Je ne suis pas sûr de ce que je devrais faire d'ici. J'ai suivi presque toutes les étapes nécessaires pour utiliser le pilote graphique mais il ne l'utilise toujours pas.

enter image description here

BTW, il devrait y avoir un moyen de configurer pour utiliser la carte graphique sur les paramètres du serveur NVIDIA-x, mais il ne s'affiche pas sur ma machine.

De plus, la sortie de glxinfo montre clairement que mon système n’utilise pas la carte graphique nvidia.

jaebum@jaebum-laptop:~$ glxinfo | grep renderer
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 

Toute aide est la bienvenue :)

Notez que mon système est Ubuntu 16.10.

(* c’est un ordinateur portable donc je suis sûr que je ne me suis pas trompé comme Mes pilotes reconnaissent ma carte graphique, mais nvidia paramètres ne )

MODIFIER

J'ai aussi ajouté le résultat de la commande suivante

jaebum@jaebum-laptop:~$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
    DeviceName:  Onboard IGD
    Subsystem: Micro-Star International Co., Ltd. [MSI] HD Graphics 530
    Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
    Subsystem: Micro-Star International Co., Ltd. [MSI] GM107M [GeForce GTX 960M]
    Kernel modules: nvidiafb, nouveau, nvidia_375_drm, nvidia_375
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)

EDIT2

sortie de la commande suivante

root@jaebum-laptop:/usr/lib/x86_64-linux-gnu# dkms status
bbswitch, 0.8, 4.4.0-79-generic, x86_64: installed
bbswitch, 0.8, 4.8.0-54-generic, x86_64: installed

0
2018-06-07 08:08


origine


Désactiver le démarrage sécurisé dans le BIOS. - Pilot6
déjà fait ça :) - Jaebum
S'il vous plaît modifier votre question et ajouter une sortie de lspci -k | grep -EA3 'VGA|3D|Display' commande de terminal. - Pilot6
Je viens d'ajouter la sortie de cette commande @ Pilot6 - Jaebum
Le module du noyau ne se charge pas pour une raison quelconque. Qu'est ce que prime-select query sortie? Il s'agit soit d'un problème de démarrage sécurisé, soit d'une installation incorrecte du pilote. - Pilot6


Réponses:


Vous avez probablement un Démarrage sécurisé option activée, et cette fonctionnalité empêche les noyaux de nVidia de se charger, ainsi Ubuntu utilisera uniquement la carte intégrée.

Essayer temporairement désactiver la fonctionnalité de démarrage sécurisé et tester si la carte nVidia est utilisée.

Désactiver le Démarrage sécurisé devrait être possible via votre UEFI BIOS (j'accède au mien avec F2 lorsque le système commence à démarrer).

Si tel est le cas, vous devez signer le pilote nVidia, qui est une saga en soi.


1
2017-08-23 12:14





Votre ordinateur portable a un graphique hybride. Il bascule vers NVIDIA GPU lorsque les applications nécessitent davantage de mémoire vidéo.

Vous devez installer bumblebee pour rendre le graphique. F.e. optirun firefox >/dev/null 2>&1 &.

S'il vous plaît vérifier cette ressource:

Bubmlebee pour Ubuntu

Comment installer les pilotes nVidia avec Bumblebee sur Ubuntu 14.04


0
2018-06-07 08:26



Est-il possible d'exécuter tous les programmes uniquement sur les pilotes NVIDIA, sans utiliser le gadget intel? - Jaebum