Question Comment faire pour activer l'affichage des sous-répertoires dans Apache2 sous WWW sous Ubuntu 16.04


Récemment, j'ai fait une installation "propre" d'Ubuntu 16.04. J'ai également installé MariaDB, Apache2 et PHP 7.0.

Sous Ubuntu 14.04, je pouvais voir les sous-répertoires sous "/var/www". À la suite de cette mise à niveau, je ne peux plus les voir avec"localhost" en dessous de "/var/www". Toutefois, "localhost"montre des fichiers limités.

Par exemple, "phpmyadmin"apparaît OK. Et si je tape juste"localhost", J'obtiens le prévu"Apache2 Ubuntu Default Page"qui se trouve dans le"html"répertoire. Aussi si je tape"http://localhost/index.php", Je peux avoir la page phpinfo ().

Cependant, si je tape: "http://localhost/PHP_Intermediate/store/admin/admin.php"Je reçois le message d'erreur 404:"The requested URL /PHP_Intermediate/store/admin/admin.php was not found on this server."

Le propriétaire de tous les fichiers a été défini sur "www-data"avec toute personne disposant temporairement de droits de lecture / écriture / d’accès pour les tests.

Comment la visualisation des sous-répertoires (accès) peut-elle être activée pour "var/www"?


0
2017-08-13 16:18


origine


Veuillez éditer votre question pour utiliser des blocs de code. C'est beaucoup plus beau comme ça. Merci! - Android Dev
Jetez un coup d'oeil au journal des erreurs. Vous devriez avoir une information plus détaillée sur ce qui a mal tourné. Vous verrez également quel fichier est apache à la recherche et vérifier si elle existe vraiment sur le disque. - nobody
Aucun message d'erreur ne s'affiche. Néanmoins, le journal des erreurs impliquait un problème de sécurité. J'ai désactivé le "commutateur de moteur SSL". Aucun effet. Je n'arrive toujours pas à accéder à mes autres pages Web sous "www" - Steve R.
En guise de test, j'ai déplacé un des sous-répertoires existants dans "var / www / html" et "localhost" affiche les fichiers comme prévu. Besoin de faire un peu plus de travail pour vérifier que le problème peut être résolu de cette manière. - Steve R.


Réponses:


J'ai apparemment trouvé une réponse. J'ai remarqué dans phpinfo() cette DOCUMENT_ROOT = /var/www/html. J'ai effectué une recherche sur Internet pour localiser le fichier dans lequel se trouve la chaîne. Le fichier est /etc/apache2/sites-enabled/000-default-conf. Voir le code ci-dessous. "#" sort de la ligne avec html en elle et a ajouté une nouvelle ligne sans html.

ServerAdmin webmaster@localhost
#DocumentRoot /var/www/html
 DocumentRoot /var/www

Solution trouvée sur ce site: Modification de la racine du document apache2

Lors de la navigation suivante, je suis tombé sur un autre article qui parle de ce problème: Qu'est-ce qui a changé dans apache2 de saucy à trusty pour les projets dans / var / www [duplicate]


1
2017-08-14 02:26