Question Qu'est-il arrivé aux préférences de l'application de démarrage?


en 11.04 je peux aller à system-> preferences -> applications de démarrage et faire des choses comme décocher Gnome Login Sound quand j'ouvre les applications de démarrage en 11.10 l'écran est vide


7
2017-10-15 15:18


origine


Juste curieux ... avez-vous au moins un Ubuntu ou le programme de mise à jour? - alex
J'ai un compte Ubuntu et j'ai un gestionnaire de mise à jour - Awm Lamp


Réponses:


Le comportement que j'ai découvert est identique à celui de KDE (les fichiers .desktops locaux remplacent ceux du système). Pour pouvoir désélectionner / sélectionner des éléments dans les applications de démarrage, procédez comme suit:

mkdir -p ~/.config/autostart # If not already created
cd ~/.config/autostart
cp /etc/xdg/autostart/*.desktop .
sed -i "s/NoDisplay=true/NoDisplay=false/g" *.desktop

Ensuite, choisissez vos applications de démarrage dans le panneau de configuration des applications de démarrage. De là, "Déconnexion / Connexion" à appliquer (grâce à duffydack).


7
2017-10-17 00:07





Cela peut vous aider: http://maketecheasier.com/disable-login-sound-in-ubuntu-oneiric-quick-tips/2011/09/15

Apparemment, les fichiers .desktop ont désormais une option pour ne pas apparaître dans les préférences de l'application de démarrage au 11.10. En définissant cette option sur FALSE, ces éléments apparaissent dans les préférences de démarrage et vous pouvez ensuite les désactiver.

EDIT: Comme l'a dit Jo-Erlend Schinstad, le lien peut ne pas être disponible. Donc, je vais expliquer l'idée ici.

La solution consiste à modifier le fichier .desktop de l'application à afficher dans les préférences de démarrage. Par exemple, pour le son de connexion, vous devez ouvrir le fichier:

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Puis changez la ligne qui dit

NoDisplay=true

à

NoDisplay=false

3
2017-10-15 16:15



C'est un lien externe, ce qui signifie qu'il pourrait disparaître sans avertissement, rendant votre réponse inutile. Pour cette raison, il serait préférable de l'expliquer dans votre réponse. - Jo-Erlend Schinstad
Merci, le lien fournit une bonne solution pour le son de gnome et économiseur d'écran - Awm Lamp


Pour les activer à nouveau, exécutez

find /etc/xdg/autostart/ -name "*.desktop" -exec sudo sed -i "s/NoDisplay=true/NoDisplay=false/g" '{}' \;

Cela fonctionnera mais ne serait que temporaire. Par exemple:

dpkg -S /etc/xdg/autostart/ubuntuone-launch.desktop 
ubuntuone-client: /etc/xdg/autostart/ubuntuone-launch.desktop

Donc, si ubuntuone-client est mis à jour, il disparaîtra des «applications de démarrage». Un développeur m'a dit quand j'avais une situation similaire avec KDE de copier d'abord le fichier .desktop dans ~ / .kde4 / share / kde4 / services / et de l'éditer ici (le local remplacera celui du système); Sois gentil si Gnome avait aussi ça ici.


1
2017-10-15 16:22



Merci pour cette solution élégante qui remplace toutes les options de démarrage automatique! - Awm Lamp
merci pour les informations supplémentaires concernant le système local, ne l'a jamais su. - duffydack
@AwmLamp Bienvenue à askubuntu, et souvenez-vous de bien choisir vos réponses. - belacqua