Question Le pilote ATI interrompt les mises à jour Unity, Fglrx ou Fglrx


Ubuntu démarre et s'exécute avec le pilote open source, mais une fois que je vais dans les pilotes supplémentaires et que j'active les pilotes propriétaires des mises à jour Fglrx ou Fglrx et que je redémarre, rien dans Ubuntu ne s'affiche. Il semble rompre l'unité.

Je dois réinstaller Ubuntu pour revenir à l'open source, quel est mon prochain plan d'action pour faire fonctionner Catalyst?

V: 13.04 A: HD 5730 ATI


0
2018-05-07 05:34


origine


Quelle version de Ubuntu utilisez-vous, quel adaptateur graphique avez-vous? Comme il est cette question ne peut pas être répondu. - Bruno Pereira
13.04 et HD 5730 - jake


Réponses:


Il semble y avoir beaucoup de problèmes avec les pilotes propriétaires dans Raring. C'est une nouvelle version et tout ne fonctionne pas toujours comme il se doit.

Assurez-vous de ne pas avoir de pilotes propriétaires et open source installés simultanément. Lorsque vous essayez différents pilotes, gardez toujours une trace de celui qui est chargé. Pour ce faire, vous pouvez utiliser cette commande:

$ lspci -nnk | grep -iA3 vga

Si vous vous trouvez dans une situation où quelque chose tombe en panne et que vous ne pourrez pas résoudre le problème en utilisant une interface graphique, vous pouvez toujours accéder à la ligne de commande. Tout d'abord, vous pouvez essayer d'appuyer sur Ctrl + Alt + F <1-6> (choisissez un nombre entre 1 et 6). Une autre option consiste à entrer en mode de récupération au démarrage, ce qui vous donne également accès à la ligne de commande. Alors peut-être que vous n'avez pas réinstallé l'intégralité du système d'exploitation.

Vous obtenez une liste des paquets installés avec ceci:

$ dpkg --get-selections

Lorsque vous supprimez un paquet avec apt-get, utilisez «purge»:

$ sudo apt-get purge <package-name>

Forfaits Fglrx:

fglrx fglrx-amdccele

Packages de mise à jour Fglrx:

fglrx-updates fglrx-amdcccle-updates

Packages de pilotes Open Source:

xserver-xorg-video-ati xserver-xorg-video-radeon

Pour installer un paquet, utilisez le bon vieux:

$ sudo apt-get install <package-name>

Si vous voulez vraiment les avantages du pilote propriétaire, vous pouvez également télécharger des pilotes propriétaires directement depuis le site d'assistance amd.

Dans le fichier zip, il y a un programme d'installation. Je vous suggère de créer deb-file à partir de cela (plus de détails et de conseils ici et ici) car le pilote est plus facile à supprimer s'il ne fonctionne pas. Si vous devez tout faire depuis la ligne de commande, voici les étapes à suivre:

Téléchargez le pilote:

$ wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip

Décompressez le pilote:

$ unzip amd-catalyst-13.4-linux-x86.x86_64.zip

Rendre le fichier exécutable:

$ chmod +x amd-catalyst-13.4-linux-x86.x86_64.run

Créez deb-file depuis le programme d'installation:

$ sudo ./amd-catalyst-13.4-linux-x86.x86_64.run --buildpkg Ubuntu/raring

Cela pourrait vous donner une erreur car vous pourriez manquer de paquetages nécessaires. Selon ce site au moins Precise avait besoin que ces paquets soient installés.

$ sudo apt-get install dh-make dh-modaliases execstack

Installez le fichier deb (remplacez le signe * par la terminaison réelle - pour vérifier le nom de fichier correct que vous pouvez utiliser) ls -l commander):

$ sudo dpkg -i fglrx*.deb

Si cela ne fonctionne pas non plus, je suppose que vous êtes coincé avec les pilotes open source jusqu'à ce que les problèmes soient résolus. Aussi que lorsque quelque chose est censé fonctionner mais n'est-ce pas un bogue et ceux-ci ne sont corrigés que si des bogues sont signalés. En rapportant des bogues voir ceci. Vérifiez toujours que le bogue n'a pas déjà été signalé, mais même s'il existe, vous devez toujours cliquer sur le fait que vous avez été affecté par le bogue, car il soulève son importance.


1
2018-05-07 08:56



@jake Le téléchargement du pilote depuis le site d'assistance est ce qui a fonctionné pour moi, Radeon HD mobilité 7670. Mais fglrx n'a pas rompu l'unité, il a simplement été transformé en 2D. Cela a fonctionné pour moi: support.amd.com/us/kbarticles/Pages/… - Jack Mayerz


Dans mon expérience, n'installez pas de pilotes utilisant l'interface de pilotes supplémentaire. utiliser synaptic (non installé par défaut dans un ou des ubuntu (s) récents, ou un terminal).

Utilisez les référentiels x-swats ou x.org edgers. (Vous pouvez les google pour apprendre à les ajouter, mais ne les utilisez pas tous les deux)

installer les paquets suivants

sudo apt-get installe cdbs build-essential dh-make dkms execstack dh-modaliases générique linux-headers fakeroot libqtgui4 devscripts lib32gcc1

faites ensuite une mise à jour.

sudo apt-get update

puis installez le paquetage fglxr-updates.

Vous pouvez utiliser synaptique si vous n'êtes pas à l'aise avec le terminal. et redémarrer.


0
2018-05-07 11:10



Il faudra également installer gksu pour pouvoir utiliser le centre de contrôle du catalyseur en mode root. - mojo