Question Désactiver la notification de périphérique amovible pour les disques durs


J'utilise Ubuntu 12.04 avec deux disques durs.

Le deuxième lecteur est configuré pour monter sur /home/myuser/DATA et ça monte bien. Cependant, gnome affiche un élément 'Périphériques amovibles' dans la zone de notification qui répertorie mon disque dur avec le bouton de démontage.

Comment faire pour que Ubuntu traite le second disque dur comme le premier, sans me suggérer de le démonter dans la zone de notification?


6
2018-05-08 12:31


origine


Je suis également intéressé par la réponse à cette question, car j'ai le même problème avec les lecteurs cryptés LUKS. - zigg


Réponses:


La solution consiste à changer le point de montage en / mnt / "quelquechose". Modifiez votre fstab et il ne devrait plus afficher l'option de démontage.

Ensuite, vous pouvez lier le montage au répertoire souhaité:

UUID=your_uuid_here /mnt/DATA ext4       defaults        0       2
/mnt/DATA             /home/yrogirg/DATA   none bind 0 0

5
2018-05-18 15:04



Impossible de tester cela, car ma partition LUKS est montée en tant que / et ne peut être déplacé. - zigg
hm @zigg Je n'ai pas encore essayé, car je n'ai pas besoin de monter pour /mnt non plus. Mais si monter à /mnt puis liez mount à / ? - Yrogirg
Cela a fonctionné pour moi, To Do, j'ai modifié votre réponse un peu pour inclure la ligne fstab de bind mount. et il y a une faute de frappe, ça devrait être "UUID" - Yrogirg


Il semble que les gens de GNOME en soient déjà conscients. voir ce bug:

https://bugzilla.gnome.org/show_bug.cgi?id=660595

(Pour le moment, cependant, cela me dérange suffisamment de voir une solution, d’où la prime.)


2
2018-05-11 19:27





Modifiez votre / etc / fstab en ajoutant une ligne comme suit:

UUID=[your second hdd UUID] /               ext3    errors=remount-ro,user_xattr 0       1

Vous souhaiterez peut-être modifier "/" avec un autre point de montage ou ext3 avec le système de fichiers approprié.


0
2018-05-16 13:42



comment est-il censé résoudre le problème? Est-ce à cause de 1? ou user_xattr? - Yrogirg
Essayez simplement de me dire si cela fonctionne ... C'est un combo entre ces options. - jasmines
Cela ne fonctionne pas pour les appareils LUKS. Ma partition chiffrée, qui est déjà activée / et a déjà un fstab entrée avec un numéro de passe de 1 (FWIW: le numéro de passe est utilisé par fsck pour déterminer l'ordre des vérifications du système de fichiers au démarrage), affiche toujours comme un lecteur amovible. Je ne suis pas tout à fait sûr de ce que user_xattr était censé faire pour cela de toute façon. - zigg
2 autres astuces. 1) Essayez avec pysdm (c'est un éditeur graphique de fstab). 2) en regardant dans / sys / block / j'ai vu deux fichiers qui pourraient être de l'aide: / sys / block / sda / amovible (il contient 0) et / sys / block / sr0 / amovible (il contient 1). - jasmines
Je crains que vous (vous) devrez attendre la prochaine version de la série GNOME 3, qui est prévue pour le 24 septembre 2012. Cependant, vous pouvez essayer la version de développement en direct (actuellement dans un tout début de la version 3.5. 1) pour voir si le problème est en cours de traitement: news.softpedia.com/news/… - jasmines