Question Scintillement agaçant dans 16.04 LTS - Chrome


Je suis passé de 4.4.0 à 4.4.8, puis de 4.5.2 sur Ubuntu 16.04 LTS 64 bits, et ça continue.

À 4.5.2 c'est encore plus fréquent, et principalement dans Chrome (n'a pas encore essayé Firefox ou Opéra). Chaque fois que j'ouvre une nouvelle page Web. Un moyen de résoudre ce problème, ou est-ce un bug?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

À votre santé.


196
2018-05-03 06:31


origine


Même chose sur Ubuntu 14.04.4 - Billal Begueradj
Je suis également confronté au même problème, particulièrement en utilisant Facebook. C'est trop agaçant. - sgiri
Essayer --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   quelques informations supplémentaires ici: productforums.google.com/forum/#!topic/chrome/… - Postadelmaga
Googler ici. Ce bogue est en cours de suivi dans le tracker de problème Chrome # 606152 - Scintillement sur Intel avec des téléchargements en une copie. - Dan Dascalescu
Je suis passé à la pile HWE (noyau 4.8 et X-7.7). Il a arrêté le flickr. Il y a un problème avec i915 (Intel HD Graphics Driver) dans la série 4.4 du noyau. - Manoj Sawai


Réponses:


Après quelques recherches, j'ai trouvé une solution à ce problème. Ça marche pour moi maintenant.

J'ai désactivé l'accélération matérielle pour mon navigateur depuis

Settings > Advance Settings > System > uncheck the hardware acceleration

J'espère que cela fonctionne sur votre machine.


j'utilise google-chrome-stable Version 50.0.2661.94 (64-bit) sur Ubuntu 16.04

-----MODIFIER----

Si vous rencontrez un retard de défilement et une déchirure de l'écran. Faites comme suggéré par Amos Folarin dans le commentaire ci-dessous:

Aller à: chrome://flags/#smooth-scrolling et l'activer.


186
2018-05-05 17:54



J'ai essayé cela, corrige le problème mais rend mon défilement décalé et déchire l'écran. - Mookey
Cela ne devrait vraiment pas être accepté, car ce n’est pas une solution, c’est définitivement une solution. - theV0ID
Cela n'a aucun effet sur le scintillement pour moi. - DavidJ
Cette solution a fonctionné pour mon XPS13 9343, le scintillement s'est définitivement arrêté ou n'est pas perceptible. J'ai également essayé l'autre solution suggérée ici en définissant chrome: // flags / # enable-gpu-rasterization sur 'Force-enabled pour tous les calques' mais cela ne fonctionnait pas, seule la désactivation de l'accélération matérielle dans Chrome semblait fonctionner. Mais d'accord avec @ theV0ID que ce n'est pas une idée. - Amos Folarin
Essayez également d'activer chrome: // flags / # smooth-scrolling pour un défilement régulier. J'utilise XPS13 + Ubuntu16.04 fonctionne bien avec l'option hardware accel décochée - Amos Folarin


J'ai eu le même problème, le paramétrage de la rasterisation du GPU sur 'Force-enabled pour toutes les couches' semble enfin fonctionner:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



lien rapide: chrome: // flags / # enable-gpu-rasterization - JohannesNE
travaillé pour moi aussi. - Sufiyan Ghori
Il a cessé de fonctionner, le scintillement est de retour, je pense qu'après la mise à niveau vers la version 53.0.2785.92 de Chrome (64 bits) - Omid
Cela réduit considérablement le scintillement, mais il est toujours présent dans la boîte de réception Google, par exemple (actuellement le seul endroit où je le vois). - TiGR
Fonctionne, mais maintenant, seul le coin supérieur gauche de certaines images est affiché. Qu'est-ce que cela a fait pour moi était chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Ouvrez un terminal et entrez cette commande:

sudo nano /usr/share/applications/chromium-browser.desktop

et défilez jusqu'à ce que vous arriviez à cette ligne:

Exec= chromium-browser

Puis ajoutez ces deux paramètres

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Appuyez sur Ctrl + O pour enregistrer et Ctrl + X pour quitter.

Puis entrez cette commande:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

et ajoutez ces lignes

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Appuyez sur Ctrl + O puis Ctrl + X.

Ouvrez Chrome et écrivez dans la barre d'adresse: chrome://flags/ et entrez.

  • Activer la copie zéro
  • Activer la liste de rendu des logiciels
  • Activer le canevas de liste d'affichage 2D

Enfin, ouvrez les paramètres de chrome et cliquez sur:

  • Utiliser l'accélération matérielle si disponible

38
2017-07-27 08:10



Fonctionne sur mon processeur Dell XPS 15 95050 Intel® Core i7-6700HQ à Intel® HD Graphics 530 à 2,60 GHz (Skylake GT2). - Prydie
Dans mon cas (après avoir essayé plusieurs solutions), j'ai simplement activé les drapeaux que vous avez mentionnés (zero-copy, Override Software Rendering List, Display 2D List Canvas) et il semble l’avoir corrigé (sur Intel HD Graphics). - Nahuel
Les deux commutateurs de ligne de commande (désactivation des solutions de contournement / activation des mémoires tampons gpu natives) ne semblent plus fonctionner, mais la création du 20-intel.conf fichier a fonctionné pour moi! Également activé la pixellisation GPU (pas sûr que ce soit important). - terabaud
La seule solution travaillée pour moi. Merci - Darkside
Juste en ajoutant 20-intel.conf travaillé pour moi - je n'avais rien d'autre à faire. - Vadi


Je l'ai réparé comme suit:

sudo apt-get purge xserver-xorg-video-intel

puis redémarrez. C'est parce que les pilotes Intel sont passés à modesetting. Pour plus d'infos voir ce commentaire dans le fil de bogue de chrome.


37
2017-08-19 14:25



Je suis allé sur la route des drapeaux chromés, puis je suis passé par cette voie et j'ai réinitialisé les drapeaux par défaut et purgé le contenu d'Intel. Jusqu'ici tout va bien. - Sethen
Merci. J'ai un Intel NUC qui a quelques années et qui a subi quelques mises à jour. C'est sur 16.04.2 mais votre suggestion a trouvé des paquets à purger. Il ne clignote plus (ma vidéo HDMI clignote à environ 1 ou 2 Hz après quelques mises à jour récentes; je pense qu’elle a développé une défaillance matérielle après 8 ans de service). - Tim Richardson
Cette réponse devrait être beaucoup plus élevée! - Galgalesh
Ça y est? Ça marche impeccable !!! Réponse totalement sous-estimée. Merci beaucoup camarade! - uloco
Merci! Cela a résolu le problème pour moi. Votre réponse devrait être supérieure de quelques points. - Anthony D.


Aucune de ces réponses ne semble m'aider. Ce que j'ai fini par faire semble l'avoir réparé (ma référence était ce site http://www.bang-olufsen.com/ qui a clignoté comme CRAZY et maintenant ça fonctionne bien) est la suivante:

1.- Naviguer vers chrome://gpu/. C'est ce qu'il a montré:

enter image description here

2.- J'ai essayé de réparer les problèmes un par un. Dans mon cas, activer ces drapeaux en a réparé certains: GPU rasterization, Override software rendering list. Ensuite, il a montré comme ceci:

enter image description here

3.- J'ai édité le lanceur de bureau et ajouté les paramètres --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Après cela, plus de problèmes détectés, tout montre comme "accélération matérielle" et, plus important encore, plus de scintillement:

enter image description here

Si vous ajoutez les paramètres au lanceur en premier, la liste des problèmes doit être plus courte et il sera probablement plus facile de déterminer quels drapeaux vous aideront à résoudre les problèmes qui vous restent.


24
2017-09-14 12:29



C'est une bonne référence. Je l'ai utilisé pour résoudre mon problème avec Firefox, où il a été simplement résolu en décochant la case "Utiliser l'accélération matérielle" dans les paramètres avancés. - Bach
Cela a réduit le scintillement pour moi, mais ça arrive encore souvent ... - addison


Avec Chrome Version 51.0.2704.103 (64 bits) les drapeaux

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

ne fonctionne plus.

La meilleure façon de faire est de revenir à Chrome 50 (version 50.0.2661.86 (64 bits)), voici une instruction pour savoir comment revenir en arrière: Comment puis-je rétrograder Google Chrome? 

Important: nous mettons la pression sur Google pour résoudre ce problème, votez pour le bogue dans Chrome et sur la page du produit Google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Ne fonctionne pas pour moi. - ComBin
@ ComBin: avez-vous essayé de revenir à la v50 et utilisé les drapeaux? Cependant, suivez le lien vers le bogue de chrome. Il existe de nombreuses propositions de solutions différentes pour que ceci fonctionne avec les versions actuelles de chrome / -ium. - user157697
je ne veux pas v50, merci. Je suis trouvé le meilleur moyen de le réparer, voir ma réponse ci-dessous. - ComBin
AHa, dans le bogue du chrome, les gars signifiaient que cela aurait des problèmes de performances énormes. Cependant, je vais essayer certaines suggestions des bugs de chrome quand j'en aurai le temps, pour autant que je sache, le chrome n'est que le symptôme, pas la cause. Je vous tiendrai au courant si je trouve quelque chose de mieux / d'autre. À votre santé. - user157697


chrome://flags/ > GPU rasterization > Enable,

Cela a finalement fonctionné pour moi! Vous l'avez trouvé au bas de ce formulaire Google! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44





Je pense avoir trouvé la solution:

drapeaux --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers et aussi activer-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection

4
2017-07-07 15:14



Il y a des drapeaux manquants, voici mon étape par étape: bugs.chromium.org/p/chromium/issues/detail?id=606152#c72 - Hermann Bier
J'ai été en mesure de résoudre mon problème avec seulement la section dans le fichier 20-intel.conf sans drapeaux supplémentaires en chrome sur bionic beaver 18.04 - Brandon Søren Culley


Essayez de charger avec certaines options GPU désactivées:

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Après avoir essayé, vous pouvez également manipuler certains paramètres de rendu dans les indicateurs about: // et voir si quelque chose aide, mais la plupart de mes scintillements ont été résolus par les deux indicateurs de la ligne de commande. Si vous avez un fichier .desktop de lanceur, ajoutez ces indicateurs à l'entrée Exec supérieure avant le '% U'. Vous pouvez également les ajouter aux autres entrées Exec pour que les indicateurs soient appliqués à tous les modes de démarrage.


2
2018-05-04 15:44





J'ai trouvé les correctifs actuels ne fonctionnent pas pour la version actuelle de chrome, d'autres choses doivent être changées (au moins pour ma configuration).

Je peux confirmer cela fonctionne (supprime à la fois le scintillement et le déchirement) - avec grâce à https://bugs.chromium.org/p/chromium/issues/detail?id=606152#c72

Ordinateur: XPS13 9343 Graphisme: 00: 02.0 Contrôleur compatible VGA: Intel Corporation Broadwell-U Integrated Graphics (version 09) Version Chrome: Version 54.0.2840.100 (64 bits)

Paramètres

1) Vérifiez les messages d'erreur avant et après les réglages de configuration ci-dessous

  • chrome: // gpu
  • Prenez une capture d'écran pour pouvoir comparer après.

2) Edit (pour chrome): /usr/share/applications/google-chrome.desktop ou pour (chrome): /usr/share/applications/chromium-browser.desktop

  • Ajouter les drapeaux --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers
  • ligne devrait ressembler à ceci: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf ajoutez ceci (vous devrez peut-être créer le fichier):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Paramètres des drapeaux Chrome: chrome: // flags:

  • Activer ("rasterizer zéro copie"): chrome: // flags / # enable-zero-copy
  • Activer (activer la liste d'affichage 2d canvas): chrome: // flags / # enable-display-list-2d-canvas
  • Activer ("Remplacer la liste de rendu du logiciel"): chrome: // flags / # ignore-gpu-blacklist
  • Activer "Canevas 2D de la liste d'affichage"): chrome: // flags / # enable-display-list-2d-canvas
  • Activer (indicateur de chrome pour un défilement régulier dans linux): chrome: // flags / # smooth-scrolling

5) J'ai conservé le paramètre Chrome> Avancé> Utiliser l'accélération matérielle lorsque disponible [garder la case]. Si vous décochez cette case vraiment frappe les performances (bien que réduit le scintillement mais ne déchire pas), les options ci-dessus ont fonctionné beaucoup mieux pour moi.

6) Redémarrez l'ordinateur.

7) Comparer les paramètres. chrome: // gpu

Cela a totalement éliminé le scintillement et le déchirement pour moi.


2
2018-02-15 14:27



En fait, cela pourrait être la réponse. - pylover