Question Comment configurer lightdm pour autoriser les connexions manuelles dans Ubuntu 14.04


J'avais l'habitude de modifier /etc/lightdm/lightdm.conf, en ajoutant la ligne greeter-show-manual-login=true, afin de permettre la connexion pour les utilisateurs cachés et root.

Maintenant, je viens d'installer le nouveau Ubuntu 14.04 et le fichier lightdm.conf n'est plus situé dans /etc/lightdm. C'est dedans /etc/init et a été totalement modifié.

Comment puis-je forcer l'écran de connexion lightdm à afficher un champ pour saisir un nom de connexion?


34
2018-04-21 09:45


origine




Réponses:


Ok j'ai finalement trouvé la solution, très simple. Le fichier à éditer est maintenant situé dans /usr/share/lightdm/lightdm.conf.d, et s'appelle: 50-ubuntu.conf.

Je viens d'ajouter la ligne:

greeter-show-manual-login=true

et au prochain redémarrage, j'ai pu saisir n'importe quel nom d'utilisateur sur l'écran de connexion.

enter image description here


27
2018-04-21 10:22



Plutôt que d'éditer un fichier système par défaut, pourquoi ne pas ajouter le vôtre au dossier lightdm.conf.d? - bshacklett
Si vous créez un fichier complètement nouveau comme suggéré par @bshacklett, vous devez le démarrer avec [SeatDefaults]. - pix


J'ai aussi eu le même problème avec l'installation d'Ubuntu 14.04. Mais j'ai résolu le problème en suivant ce site.

La solution consiste à créer un fichier lightdm.conf à l'intérieur /etc/lightdm/ et y mettre le contenu suivant:

[SeatDefaults]
greeter-show-manual-login=true

Après un redémarrage du système, j'ai pu me connecter avec d'autres utilisateurs.


10
2018-05-03 12:57



Sur Ubuntu 14.04 64bit, le fichier de configuration a changé pour /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf - user3597121


Aussi, vous devriez faire l'étape suivante:

mettre à jour /etc/pam.d/common-session et changez la ligne:

session sufficient pam_lsass.so

à:

session [success=ok default=ignore] pam_lsass.s

Après un redémarrage, mon chemin était correct et tout semble redevenir normal.

Voir le rapport d'erreur


0
2017-07-14 10:30





En plus de greeter-show-manual-login=true option, on pourrait utiliser greeter-hide-users=true. Personnellement c'est ce que j'ai dans mon /etc/lightdm/lightdm.conf : l'option de connexion manuelle est mise en commentaire, avec l'option Masquer les utilisateurs uniquement.


0
2018-02-25 08:12



Si je vous comprends bien, cette option permet uniquement de vous connecter en tant qu'utilisateur invité. - gone
@ non, la connexion est autorisée pour tous les utilisateurs, pas seulement pour les invités. Il vous suffit de taper le nom d'utilisateur, au lieu de choisir dans une liste dans le greeter - Sergiy Kolodyazhnyy
Pas sur mon installation. Il n'y a pas où taper un nom d'utilisateur. Il y a juste une étiquette avec Guest Session et le bouton Log In >Si vous cliquez ou appuyez sur Entrée, l'utilisateur invité se connecte. L'utilisation des flèches haut / bas n'aide pas non plus. Le changement d'utilisateur après la connexion en tant qu'invité ne fonctionne pas non plus. - gone
@gone Et quelle version d'Ubuntu vous utilisez? - Sergiy Kolodyazhnyy
U14.04.3 LTS dans une VM VirtualBox sur un Macbook Pro avec MacOS. - gone