Question Le clavier se verrouille dans IntelliJ IDEA sur Ubuntu 14.04


Pourriez-vous m'aider avec un problème étrange? J'utilise Intellij IDEA 13 sur Ubuntu 14.04 et, de temps en temps, mon clavier se verrouille complètement dans IDEA. Je peux toujours faire tout ce que je veux dans IDEA avec ma souris, aussi je peux utiliser le clavier partout ailleurs sauf IDEA. Et cela ne peut être corrigé qu'en redémarrant IDEA jusqu'à présent.

Quelqu'un peut-il donner un indice, s'il vous plaît?


165
2017-07-24 06:58


origine


Est-il possible que votre clavier soit simplement capturé par un champ dans IntelliJ? Est-ce une chose aléatoire ou est-ce que quelque chose de spécifique le déclenche? - Ruraj
Je ne pense pas qu'un champ puisse capturer un clavier comme ça, mais je le vérifierai plus précisément la prochaine fois. Et cela semble être une chose aléatoire. - Treble Snake
Mon collègue et moi vivons exactement la même chose (même OS et IntelliJ 13.1.4). Je dois redémarrer IntelliJ une fois toutes les quelques heures (je peux cependant utiliser Alt-F4) - extrêmement ennuyeux. Je trouve également que cela se produit complètement au hasard. La dernière fois j'étais en train d'éditer un fichier HTML. Pas en appuyant sur un raccourci. - Halle Knast
J'ai eu deux instances d'IntelliJ en cours d'exécution et elles ont toutes deux gelé. Je ne sais pas si c'est pertinent, mais quand je ferme l'EDI, le détachement d'un serveur d'applications en cours d'exécution prend normalement très peu de temps. Après un gel, je dois annuler cela car il ne semble pas se terminer. - Halle Knast
Il s'agit d'un problème Java qui affecte les autres interfaces graphiques Java Swing, y compris l'interface utilisateur SOAP. "ibus-daemon -rd" corrige également le problème - rjdkolb


Réponses:


Il y a un un problème ouvert dans jetbrains youtrack pour intellij idea qui recommandent deux solutions:

  1. La saisie au clavier peut être déverrouillée en redémarrant le démon IBus depuis une console:

    ibus-daemon -rd
    
  2. IBus peut être désactivé pour IDEA en désactivant env. variable XMODIFIERS, mais la capacité à saisir des caractères nationaux dans IDEA sera perdue:

    XMODIFIERS="" idea.sh
    

J'ai utilisé le second et j'ai corrigé mon problème.


206
2017-10-18 16:50



> "ibus-daemon -rd" depuis une console. Ça a marché! Merci beaucoup!) - Treble Snake
6 mois plus tard, l’option 1 n’est plus recommandée car elle peut causer un arrêt brutal de la JVM: / - mike
Qu'entendez-vous par caractères nationaux, @Mike, cela a fonctionné pour moi aujourd'hui le 2 juin - Abderrahmane TAHRI JOUTI
"ibus-daemon -rd" - J'envisage sérieusement de le tatouer sur mon bras. - Balázs Mária Németh
La dernière mise à jour sur le sujet (17 juin 2015) recommande de export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


J'ai pu le résoudre avec ce que j'ai trouvé ici c'est essentiellement l'ajout export XMODIFIERS="" sur idea.sh


14
2018-03-05 16:45



semble travailler ici! - Marc Hauptmann


Pour un solution permanente, la  01 oct 2015 mise à jour sur la question recommande de:

Mettez à niveau IBus vers la version 1.5.11 ou ajoutez export IBUS_ENABLE_SYNC_MODE=1 à ton ~/.profile, puis redémarrez une session.

Alternativement, vous pouvez désactiver IBus à System Settings | Language Support | Keyboard input method.

IDEA 15 affichera un avertissement si une version incompatible d’IBus est utilisée.


5
2017-11-30 11:53





J'ai essayé ceci et son fonctionnement jusqu'à présent, mais je mettrai à jour si ça se fige à nouveau. J'ai vu une suggestion sur youtrack qui suggère d'éteindre iBus qui semble interférer en particulier à cause de l'utilisation du raccourci ctrl + espace pour modifier les paramètres de langue. Vous pouvez le faire en allant sur:

prise en charge linguistique> système de saisie clavier> aucun

enter image description here

**** METTRE À JOUR *****

Après l'avoir fait tourner pendant un moment, cette technique ne fonctionnait toujours pas car je continuais à geler. Je suppose que pour le moment je vais continuer à contourner ce problème pour redémarrer ibus, ce qui est un peu gênant, mais que pouvez-vous faire?

entrer dans le terminal

type:

ibus-daemon -rd

1
2018-04-05 00:33



Merci, ibus-daemon -rd est ce que je cherchais. - Lambart