Question Comment obtenir un lecteur formaté avec exfat fonctionne?


Dans Ubuntu 13.04, il y avait une option pour utiliser le PPA by Relan afin d'obtenir la fonctionnalité ExFat. Voyant que dans Ubuntu cette fonctionnalité est maintenant disponible à partir des référentiels sans le PPA, j'ai essayé cela, mais n'a pas réussi à le faire fonctionner.

Alors ma question est de savoir comment activer le support exfat?


163
2017-11-03 10:43


origine


Assez curieusement, lorsque je recherche le terme exfat dans le centre de logiciels, je peux toujours trouver les utilitaires de fusion (après avoir montré des éléments techniques) mais après avoir cliqué dessus, il est dit "Introuvable - Il n'y a pas de logiciel "Dans vos sources de logiciels actuelles." - davorao


Réponses:


Il s'avère que les paquets des dépôts officiels font l'affaire. Installer juste exfat-utils et exfat-fuse paquets en utilisant le gestionnaire de paquets de votre choix, ou simplement en utilisant apt-get depuis la ligne de commande:

sudo apt-get install exfat-utils exfat-fuse

Cela devrait fournir un système de fichiers exfat fonctionnel (support de lecture et d'écriture, mais pas de formatage des exfat via Gnome Disks et GParted).

A partir de 13.04+, cela n'a pas été nécessaire mais si vous utilisez 12.04 vous pourrait besoin de redémarrer votre ordinateur avant de pouvoir monter votre partition exfat. Si cela ne fonctionne pas après l'installation des packages, essayez de redémarrer.


274
2017-11-09 19:20



Pour moi, cela fonctionne maintenant même sans redémarrage. Utiliser Ubuntu 13.10 x64. - Andrew Ensley
Fonctionne parfaitement sans redémarrer pour que Ubuntu reconnaisse un SSD externe Samsung T1. Merci! - friederbluemle
Fonctionne parfaitement! Aucun redémarrage requis! S'il ne veut pas travailler directement après l'installation, débranchez le lecteur et rebranchez-le ... - ntninja
J'ai dû redémarrer pour 15.04. mais ça marche très bien. - Mateo
A fonctionné parfaitement dans Ubuntu 16.04 avec un lecteur WD formaté avec exfat. Merci! - Jorge Arévalo


Enfin, faites-le fonctionner sur mon 13.10.

J'ai fait:

sudo apt-add-repository ppa:relan/exfat
sudo apt-get install fuse  # (only fuse)

et enfin

sudo apt-get install exfat-fuse   # (instead of fuse-exfat)

Branché mon disque dur externe et cela fonctionne en lecture / écriture.


21
2017-11-07 12:33



Je ne suis pas sûr de ce qui a changé, mais cela ne semble plus être nécessaire car les paquets officiels, exfat-utils et exfat-fuse travaille bien pour moi. - Andrew Ensley
Cela a fonctionné pour moi en 14.04, merci. - badsyntax
Si vous formatez votre propre volume d'exfat, assurez-vous de définir l'ID de la partition sur ntfs, et non sur gras - sinon, OSX ne le reconnaîtra pas. au moins, c'est ce que cela a pris sur mon système. - user1539216


Je viens de faire une installation réussie le 03/04/2014 avec Ubuntu 13.10, entièrement mis à jour, en utilisant uniquement cette commande:

sudo apt-get update && sudo apt-get install exfat-utils

Aucun redémarrage requis et le lecteur monté automatiquement avec un support de lecture / écriture complet.


6
2018-04-03 16:36





fuse-utils déplacé à fuse. fuse-utils a été un métapaquet de base (quelque chose qui dépend du nom du nouveau paquet) depuis le 12.04.

Cela ne vous aide pas beaucoup si vous avez quelque chose qui a une dépendance de paquet sur fuse-utils parce que vous avez raison, le métapaquet a été supprimé maintenant. La chose la plus simple à faire pourrait être de simplement télécharger la version Raring et installez ça. Cela ne devrait rien nuire, car il ne fait aucune demande sur quelle version de fuse pour installer, juste que il y en a un installé.


5
2017-11-03 10:48



Bonjour @Oli je vais essayer ça. Merci pour le conseil. Va écrire comment ça a fonctionné. - davorao
@davorao Si c'est une consolation, ça pourrait être la ligne principale (et pas besoin de fusible) par la prochaine version d'Ubuntu. Il y a déjà un pilote de noyau mais ce n'est pas encore tout à fait prêt, d'après ce que je peux voir. - Oli♦
C'est en fait La version Raring ne voudrait pas fonctionner, alors je vais attendre et voir comment elle évolue avec le temps. Merci. :) - davorao