Question Comment puis-je faire en sorte que Mutt arrête de faire des sauts de lignes d'insertion de vim tous les quelques caractères?


Chaque fois que je tape un email avec Mutt, il insère ces lignes tous les 70 caractères environ. Je préférerais que cela se fonde simplement sur le retour à la ligne, car mon style de montage (beaucoup de révision) rend le reformatage douloureux. Y a-t-il un moyen de configurer cela dans muttrc?


4
2017-10-13 01:53


origine




Réponses:


Vous pouvez définir le editor option dans votre .muttrc option et inclure les options de ligne de commande. Les options de ligne de commande peuvent définir les paramètres vim. Un exemple serait:

set editor="vim +':set textwidth=0' +':set wrapmargin=0' +':set wrap'"

ou

# use vim, tell it to set cursor on first line of body
set editor="vim -c 'set expandtab textwidth=65 | normal }j'"

Et ainsi de suite. Voir le vim man page pour beaucoup plus d'options.


6
2018-01-28 13:25





Une autre approche consiste à spécifier un fichier source supplémentaire uniquement pour mutt avec vim -S drapeau cli:

Voici la valeur de l'éditeur dans mon fichier .muttrc:

set editor="vim -S ~/.mutt/vimrc"

Et puis voici mon ~ / .mutt / vimrc:

set textwidth=0
set wrapmargin=0

1
2017-09-23 03:23





Essayez les paramètres de la largeur de texte à 0:

; ~/.vimrc
:set textwidth=0
:set wrapmargin=0

0
2017-10-13 13:14



Je n'ai aucun problème à changer les paramètres de vim, mais ce sont les paramètres vim par défaut de mutt que je ne peux pas définir. - Jon
Hmm, puisque je n'utilise pas Mutt, je ne peux pas vous aider plus que cela, je suppose :-( - Martin Ueding