Question Désactiver le démarrage automatique pour un service sans désinstaller? [dupliquer]


Cette question a déjà une réponse ici:

Comment puis-je désactiver le démarrage automatique pour un service sans désinstaller? Par exemple, je voudrais laisser Tomcat installé, mais je ne veux pas qu’il s'allume à chaque redémarrage.


144
2018-02-19 15:22


origine




Réponses:


Cela devrait faire l'affaire:

Terminal ouvert (Ctrl + Alt + T) et entrez la commande suivante:

sudo update-rc.d tomcat disable

Fondamentalement update-rc.d va modifier les liens de niveau d'exécution existants pour le script /etc/init.d/tomcat en renommant les liens de démarrage pour arrêter les liens.


174
2018-02-19 15:59



Notez que le nom du service tomcat par défaut est "tomcat7" dans Ubuntu 14. - eaykin
Si votre tomcat est tomcat6, vous devrez faire "sudo update-rc.d tomcat6 disable" sinon vous obtiendrez une erreur. - Dung
Bizarrement, cela a supprimé les liens, puis en a créé de nouveaux lorsque je l'ai fait pour postgresql. Dunno - mlissner
Vous pourriez vouloir considérer ce message dans le update-rc.d: The disable|enable API is not stable and might change in the future. - Sahil Arora


Plus générique et plus visuel, avec une belle interface utilisateur: sysv-rc-conf

Décochez les cases pour tomcat7 (niveaux d’exécution 2 à 5), quittez et c’est tout.


41
2017-08-24 14:18



cool, c'est un outil que je n'ai jamais vu auparavant. Il était utile de confirmer que le update-rc.d commande avait effectivement fonctionné - STW
Cet outil est génial, c'était la chose que je cherchais. Merci beaucoup pour cela. - Utku Özdemir


le disable|enable L'API n'est pas stable et pourrait changer dans le futur. Je vous suggère d'utiliser la commande suivante pour supprimer tous les liens symboliques dans /etc/rc?.d/:

update-rc.d -f tomcat remove

38
2018-03-05 09:07



Celui-ci a fonctionné pour moi. J'avais désinstallé Tomcat manuellement mais il essayait de le fermer avant tout redémarrage. Désactiver sans -f paramètre yelded "fichier n'existe pas". - amenadiel


Pour les travaux novateurs, vous devez désactiver ce service (par exemple, mysql):

$ sudo -s
# echo "manual" > /etc/init/mysql.override
# exit

ou en utilisant ce one-liner:

$ echo "manual" | sudo tee /etc/init/mysql.override > /dev/null

20
2018-06-21 10:37



+ 1 million, c'est ce qui a fonctionné pour moi. J'essayais d'arrêter la transmission-démon de démarrer au démarrage et la méthode update-rc.d utilisé pour fonctionner, mais il semble qu'il a été converti en un script Upstart maintenant, donc c'est la seule méthode qui fonctionne - Erin Drummond
Merci, cela a fonctionné pour moi et désactiver mongodb! Je ne pouvais pas le faire fonctionner avec echo alors je l'ai fait à l'ancienne sudo vi /etc/init/mongodb.override façon - twig