Question Où puis-je trouver un paquet g ++ 4.7?


Il y a quelque temps, j'ai réussi à trouver PPA avec g ++ - 4.7 build. Cependant, j'ai dû tout réinstaller sur ma machine et j'ai perdu le nom de ce PPA. Quelqu'un pourrait-il me le signaler? J'ai essayé de le retrouver, mais sans aucune chance. Je suis sur l'installation d'Ubuntu 11.10.


24
2017-11-07 19:31


origine


Je vous recommande fortement de ne pas installer 4.7 au lieu de gcc qui est avec votre version. Si vous le faites, vous courez le risque de casser votre système. - Thomas Ward♦
@ ThomasWard: Je sais, je ne suis pas un débutant complet. - Griwes
@Griwes, vous n'êtes peut-être pas un «débutant», mais d'autres pourraient l'être et son observation est correcte. - Gearoid Murphy
En relation. (Mais si nous décidons que c'est un doublon, nous devons nous assurer de demander que les réponses soient fusionnées, car c'est à peu près ce qu'il faut faire lorsque cela ne fonctionne pas.) - Eliah Kagan


Réponses:


le Test de chaîne d'outils construit PPA contient de nombreux paquets, y compris gcc-4.7.

Vous pouvez ajouter le référentiel en utilisant

sudo add-apt-repository ppa:ubuntu-toolchain-r/test

Ensuite, pour l'installer utilisez

sudo apt-get update
sudo apt-get install g++-4.7

Pour modifier le compilateur par défaut, utilisez update-alternatives

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.6
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7
sudo update-alternatives --config gcc

22
2018-02-24 11:33



N'a pas travaillé pour moi. Je ne vois que gcc-4.6 (sur Ubuntu 11.10) - Ugo
Travaillé avec Ubuntu 12.04 - Ugo
Comment désinstaller g ++ - 4.6 sans désinstaller g ++? Actuellement j'ai des paquets g++, g++-4.6 et g++-4.7 installée. à la suite g++ --version me donne la version 4.6. - expert
Ah peut-être ai-je simplement besoin de renommer g ++ - 4.7 en g ++ - expert
sudo: add-apt-repository: commande introuvable $ sudo apt-get install-software-properties-commun python-software-properties - LeeGee


Je n'ai pas trouvé de PPA pour g ++ - 4.7 mais il existe un package gcc-snapshot.

Je suppose que vous devez le compiler vous-même: http://www.lukaszbyczynski.com/archives/208


0
2017-11-07 20:21



Eh bien, je ne peux pas le trouver maintenant, mais je me souviens de faire apt-get install g++-4.7 gcc-4.7... - Griwes


Voir http://ask.debian.net/questions/backporting-more-recent-versions-of-the-gcc-toolchain-to-debian-stable

pour ma description de backporting de gcc 4.7 vers Debian stable.


0
2018-02-27 07:55