Question Le Wifi ne fonctionne pas après la suspension après la mise à niveau de 16.04


Cette version particulière du "ne fonctionne pas après la suspension" est venue après la mise à niveau vers 16.04. Il semble que la mise à niveau inclue une applet Wicd (ajoutée à la barre des tâches Metacity Classic Gnome avec une icône réseau normale), mais ne semble pas fonctionner après une suspension. UNE sudo service network-manager restart duplique ce problème. Il faut un redémarrage complet pour que le Wifi recommence. Des idées pourquoi?


133
2018-04-23 11:42


origine


Avez-vous déposé un bug sur le tableau de bord pour le problème ??? - apos
bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/1556357 - Alberto Salvia Novella
On dirait que ce problème a été autour depuis Ubuntu 14. - Dan Dascalescu
Cela ne s'est jamais passé sous 14.04 LTS pour moi. La mise à niveau vers 16.04 LTS est tellement géniale que je la garde, mais elle oublie toujours mon mot de passe WiFi. - SDsolar
Cela ne s'est jamais passé sous 14.04 LTS pour moi. La mise à niveau vers 16.04 LTS est tellement géniale que je la garde, mais elle oublie toujours mon mot de passe WiFi. Le service fonctionne clairement; juste qu'il oublie le mot de passe et ne se connecte pas. J'ai posté ceci: askubuntu.com/questions/934958/… - et je ne veux pas faire face à une liste noire ou quelque chose d'étrange. - SDsolar


Réponses:


16.04 fonctionne sur systemd. Essayez ce qui suit:

sudo systemctl restart network-manager.service

Si cela fonctionne, vous pouvez créer un script pour l’automatiser.

Ouvrez un terminal et tapez ce qui suit:

sudo nano /etc/systemd/system/wifi-resume.service Collez maintenant le script avec un clic droit. Quittez avec CTRL + X et appuyez sur Y pour enregistrer. Maintenant pour l'activer: sudo systemctl enable wifi-resume.service

Scénario:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

J'espère que cela t'aides. Cela fonctionne sur mon ordinateur portable.


161
2018-04-23 13:17



Je dirais que ce n'est pas la peine de réinstaller pour cela. J'ai effectué une installation propre et je rencontre ce problème le 16.04. Jamais eu un problème avec 14.04. - Michael Martin-Smucker
Parfois ça marche et parfois pas :( - tokam
@mikeymop Je pensais aussi à ça. Je sais que certaines parties du système utilisent toujours le démarrage, ce qui pourrait déclencher quelque chose. Étant donné que 16.10 est complet et n’a pas d’erreur, vous avez peut-être raison. - Joakim Koed
Comment puis-je supprimer cela, cela ne fonctionnera pas sur mon système - buzhidao
Le script ne fonctionne pas pour moi. "Wifi désactivé" est affiché dans mes réseaux, j'ai un pilote realtek RTL8723be - Arshad


@ 147pm Avez-vous déjà eu ce travail?

J'ai trouvé que j'avais un problème assez similaire, bien que je sois sur Kubuntu 16.10 (basé sur KDE, pas sur Gnome), et sur un ordinateur portable HP ProBook. Et contrairement à vous, ce n’est pas mon Wifi qui est mort après la suspension / réveil, mais mon port Ethernet. Pourtant, je me demande s'ils sont liés.

Je vois aussi que vous n'avez pas le problème sous KDE. Mais je serais intéressé de savoir si la solution ci-dessous aide sous Gnome, car la solution ne repose pas sur un gestionnaire de fenêtres, un environnement de bureau ou des applets.

Tout d'abord, juste pour confirmer que le redémarrage du service de gestionnaire de réseau ..

$ sudo systemctl restart network-manager.service

N'a pas travaillé pour moi.

Cependant, j'ai trouvé une réponse qui a fonctionné, grâce à la question de buzhidao et aux infos sur ne peut pas se connecter à Internet après la suspension et le commentaire de GAD3R.

En utilisant leurs informations, j'ai trouvé que la première recherche sur le matériel Ethernet, le pilote / module que j'exécutais, puis sur la suppression et la réinstallation de ce module, a fonctionné pour moi (mais pas pour buzhidao):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Le deuxième (ethernet) était ce que j'ai utilisé, et j'ai trouvé:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

J'ai donc réinstallé le pilote 'r8169':

$ sudo rmmod r8169 && sudo modprobe r8169

et le tour est joué! Cela a fonctionné. Mon port / connexion Ethernet est revenu (après suspension / réveil) sans avoir à redémarrer.

(Je n'avais pas non plus de périphérique Realtek, mais un Atheros Qualcomm (mod: ath9k), ce qui explique peut-être pourquoi le wifi a continué à fonctionner après le wake-from-suspend.)

Comme vous pouvez le constater dans mon commentaire sur cet autre poste, je me suis demandé si le problème était l’élément commun entre Buzhidao et moi-même: les dispositifs Realtek Semiconductor. Même s'ils utilisent des modules différents, ils peuvent partager un code commun? Ou même être traité différemment par le nouveau code du noyau maintenant?

Avez-vous un périphérique wifi basé sur Realtek? (en utilisant lspci ci-dessus)? Avez-vous de la chance de réinstaller le module (rmmod / modprobe ci-dessus)?

En tout cas, juste un coup dans le noir. Si vous avez trouvé une réponse éventuelle pour vous, faites-le nous savoir! THX.


8
2018-03-16 22:40



J'ai aussi un ethernet RTL8111 / 8168/8411 et sudo rmmod r8169 && sudo modprobe r8169 résolu le problème. - lenooh
Même problème sur Debian 9 avec KDE. Réinstaller comme ci-dessus corrigé. Merci beaucoup. - sumitkm
Mon ordinateur * possède également un périphérique Ethernet RTL8111 / 8168/8411 et sudo rmmod r8169 && sudo modprobe r81691 finalement résolu le problème pour moi. Je n’avais pas ce problème avant la version 4.16 du noyau. (* Debian 10 avec GNOME, Kernel 4.16 et micrologiciel propriétaire de Realtek) - ossbuntu


Pour redémarrer automatiquement NetworkManager après la reprise dans un environnement sans sudo accéder, créer un script dans /etc/pm/sleep.d (n'importe quel nom), définissez le bit exécutable via chmod +xet insérez le contenu suivant:

case "${1}" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Pour moi, le service ligne a travaillé, mais systemctl peut fonctionner mieux pour vous.

La source: https://askubuntu.com/a/92235/30266.


6
2017-11-05 07:50



le service NetworkManager restart a travaillé pour moi, mais le placement du script n'a pas (sur 16.04). Je devais déplacer le script pour /lib/systemd/system-sleep/script-name-here. Dans ce cas, le premier argument du script est [pre | post], je devais donc changer la déclaration de cas en case "${1}" in ... post) .... J'ai également enveloppé la déclaration intérieure dans case "${2}" in ... suspend) .... - Chester
Devrait être /lib/systemd/system-sleep/ pour 15.04+ - qwr


Pour moi, cela semble être aléatoire, mais parfois, le wifi se déconnecte simplement si je suis connecté ou ne montre pas les réseaux si je ne le suis pas. Parfois, mettre mon ordinateur en mode veille semble le déclencher, mais pas toujours.

Une combinaison de ceux-ci le fait généralement revenir sans redémarrer:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Il suffit d'appeler restart ici ne semble jamais fonctionner pour moi. On dirait qu’elle essaye de la démarrer avant qu’elle ne soit fermée, donc j’ai plus de chance de faire une pause entre stop et start.
  • Désactivez le wifi dans l'interface utilisateur; attendez quelques secondes; le rallumer

Aucun de ceux-ci ne semble fonctionner de manière cohérente, mais je les ai listés dans l'ordre des plus susceptibles de réussir en premier.


2
2017-12-20 16:07





Méthode de travail sur Ubuntu 16.04:

Créez le service: sudo nano /lib/systemd/system/wifi-resume.service

Le service appelle le programme à partir de:
/etc/init.d/network-manager

Collez le code:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Activez ensuite le service:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Cela crée les liens symboliques dans les répertoires [Install] indiqués de / etc / systemd / system et active le service

Ensuite, vous pouvez vérifier le statut avec: systemctl status wifi-resume.service


2
2018-01-23 00:59





J'ai eu le même problème avec Bluetooth: après la suspension, ma souris Bluetooth ne fonctionnait pas. J'ai donc trouvé la solution ci-dessus:

sudo nano /etc/systemd/system/bluetooth-resume.service

activé le nouveau service

sudo systemctl enable bluetooth-resume.service

et édité le service

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

J'ai aussi essayé d'éditer ...

sudo nano /etc/bluetooth/main.conf

et changé

AutoEnable=true

MAIS cela n'a pas fonctionné pour le "problème de reprise" et n'avait de toute façon aucun impact sur les nouveaux périphériques Bluetooth!


1
2017-08-31 11:11





J'ai eu le même problème sur mon ordinateur portable Dell Inspiron 15R avec Ubuntu 16.04. Pour moi a travaillé le script a signalé sur la deuxième réponse.

Après avoir installé le script, j'ai essayé la suspension avec la commande dans le menu en haut à droite et même en fermant la lèvre pour résoudre le problème.

Je dois dire que le problème alternait dans son comportement (c’est-à-dire qu’il fonctionnait parfois avant l’installation du script).


1
2018-01-18 14:58





Pour moi, la solution était de courir

nmcli nm sleep false

dans un terminal


0
2018-04-08 11:01