Question Firewalld ne démarre pas au démarrage


J'ai installé firewalld et désinstallé ufw avec les commandes suivantes:

sudo apt install firewall-applet
sudo systemctl start firewalld
sudo systemctl enable firewalld

Cela fonctionne mais ne démarre pas seul au redémarrage.

$ sudo systemctl status firewalld.service
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/lib/systemd/system/firewalld.service; enabled; vendor preset
Active: inactive (dead)

May 10 18:39:03 Yyyy systemd[1]: Stopped firewalld - dynamic firewall daemon. lines 1-5/5 (END)

Mon ordinateur portable exécute Ubuntu 16.04 LTS.

La sortie de sudo systemctl status iptables.service:

● iptables.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

Iptables est installé. La sortie de dpkg -s iptables

Package: iptables
Status: install ok installed
Priority: important
Section: net
Installed-Size: 1624
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Version: 1.6.0-2ubuntu3
Depends: libxtables11 (= 1.6.0-2ubuntu3), libc6 (>= 2.14), libnfnetlink0
Description: administration tools for packet filtering and NAT
 iptables is the userspace command line program used to configure
 the Linux packet filtering ruleset. It is targeted towards system
 administrators. Since Network Address Translation is also configured
 from the packet filter ruleset, iptables is used for this, too. The
 iptables package also includes ip6tables. ip6tables is used for
 configuring the IPv6 packet filter
Homepage: http://www.netfilter.org/
Original-Maintainer: iptables devel team <pkg-netfilterdevel@lists.alioth.debian.org>

j'ai essayé sudo firewalld-cmd --runtime-to-parmanent mais ça n'aide pas firewalld commencer au démarrage

Merci


3
2018-05-10 22:50


origine


S'il vous plaît exécuter ceci et donner le résultat: sudo systemctl status iptables - George Udosen
@ George iptables est désactivé et inactif. J'ai mis à jour la question avec la sortie. - user68186
Avez-vous masqué les iptables aussi ...sudo systemctl mask iptables lors de la configuration de firewalld? - George Udosen
Je l'ai fait et cela n'a fait aucune différence. - user68186
S'il vous plaît exécuter cette systemctl status firewalld et laisse voir ce qu'il dit - George Udosen


Réponses:


J'ai également rencontré le même problème que OP sur mon Ubuntu 16.04.4 nouvellement installé.

J'ai vérifié le fichier de service - /lib/systemd/system/firewalld.service Il dit conflit firewalld avec iptables.service ip6tables.service ebtables.service ipset.service

Ensuite, je trouve que ebtables.service est installé et activé; Après l'avoir désactivé et masqué par

sudo systemctl disable ebtables
sudo systemctl mask ebtables

firewalld peut être démarré sans autre script / astuce après le redémarrage, de coz il devrait être activé.

Donc, la cause de mon problème est - ebtables.service empêche le démarrage de firewalld.service.


1
2018-04-23 13:27



Cela fonctionne et c'est une meilleure solution. Merci! - user68186


Un petit tour dans la documentation du pare-feu cette page. Il semble que vous ayez besoin de configurer une "configuration permanente" qui sera chargée à chaque arrêt / redémarrage du service ou au démarrage de la machine. firewall-cmd --runtime-to-permanent prendra votre configuration d'exécution existante (une fois que vous l'avez configurée correctement et fonctionnera, bien sûr) et la fera migrer en permanence.

C'est la seule suggestion que je peux offrir; Espérons que cela aide.


2
2018-05-13 00:49



Merci pour l'idée. Je l'ai essayé, mais cela n'a eu aucun effet. Firewlld ne démarre toujours pas au démarrage. - user68186


Une façon de démarrer le pare-feu au démarrage consiste à l'exécuter à l'aide de cron en utilisant le @reboot attribut:

ouvrez un terminal et tapez:

sudo crontab -e

à la fin du fichier, entrez la commande:

@reboot systemctl start firewalld

Enregistrez le fichier et quittez.

La commande ci-dessus exécutera la commande une fois que l'ordinateur démarre.

METTRE À JOUR

Méthode 2

Si vous avez accès à l'interface graphique d'ubuntu, ouvrez le tableau de bord en appuyant sur le bouton Démarrer (touche Windows).

Tapez startup Applications et cliquez sur l'icône des applications de démarrage.

Vous obtiendrez comme écran ainsi:enter image description here

Clique sur le Ajouter bouton et Ajouter la commande comme ça:

enter image description here

Et cliquez sur Ajouter.

Tu es prêt.


2
2018-05-18 09:59



Cela semble fonctionner! Merci beaucoup. J'attendrai quelques jours et je m'assurerai que cela fonctionne bien et qu'aucune meilleure réponse ne se présente. - user68186
@ user68186 génial .. hâte de la prime .. :) - Shakti Phartiyal
En ce qui concerne la Méthode 2 as-tu besoin sudo avant systemctl? - user68186