Question Comment puis-je installer la version 7.0.8-0ubuntu0.16.04.3 de php7.0-common


Je veux donc installer php7.0-mcrypt avec apt-get

sudo apt-get install php7.0-mcrypt

et c'est une erreur que j'ai eue:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 php7.0-mcrypt : Depends: php7.0-common (= 7.0.8-0ubuntu0.16.04.3) but 7.0.14-2+deb.sury.org~trusty+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Que devrais-je faire? Comment puis-je installer la version 7.0.8-0ubuntu0.16.04.3 de php7.0-common?


3
2017-12-27 08:27


origine


essaye ça sudo apt -f install php7.0-mcrypt - George Udosen
essayer sudo apt-get install php7.0-common --reinstall et donnez-moi la version php7.0 - Nullpointer
Assurez-vous de n'avoir que des référentiels pour la version d'Ubuntu que vous exécutez. - fkraiem
Comme ma suggestion est d'ajouter le dépôt php7 et d'essayer de réinstaller; selon mon expérience, cela fonctionnera. - Nullpointer
Pouvez-vous me donner une sortie de sudo apt-cache policy php7.0-mcrypt - Nullpointer


Réponses:


Comme le montre l'erreur, il y a des conflits de dépendances entre php7.0-common-7.0.8-0ubuntu0.16.04.3 Et php7.0-common-7.0.14-2+deb.sury.org~trusty+1 depuis php7.0-mcrypt Besoins 7.0.8-0ubuntu0.16.04.3 mais 7.0.14-2+deb.sury.org~trusty+1 est celui qui va être installé.

Utilisation aptitude,sudo apt-get install aptitude
Résoudre simplement les conflits de dépendances car cela donnera des options pour le faire,

Pour installer do sudo aptitude install php7.0-mcrypt puis choisissez l'option qui résoudra votre problème, aptitude vous proposera plusieurs solutions possibles.


2
2017-12-27 09:01



Ce n'est pas un apt question, mentionnez ici clairement ce problème de dépendance. - Nullpointer
avez-vous même compris la réponse? - Arduino_Sentinel
oui, qu'est-ce que vous en pensez? - Nullpointer
Ai-je dit n'importe où sur cette réponse qu'il y a un apt problème? - Arduino_Sentinel
ajoute aussi ceci packages.ubuntu.com/xenial/amd64/php7.0-mcrypt/download - Nullpointer


Cela pourrait se produire en raison de la mise à niveau des dépendances de tiers. Installez ppa-purge et utilisez-le pour supprimer les ppas indésirables. (Soyez prudent. Ne retirez pas les ppas essentiels.) Les supprimer via ppa-purge va rétrograder les dépendances, supprimer et installer certains paquets (les supprimer des autres méthodes peut ne pas le faire).

sudo apt-get install ppa-purge
sudo ppa-purge ppa:yourppahere

Et puis faites ceci:

sudo apt-get install -f
sudo apt autoremove
sudo apt-get install php7.0-mcrypt

2
2017-12-27 10:03