Question Comment puis-je définir le terminal par défaut utilisé dans Unity?


Comment puis-je définir le terminal par défaut utilisé dans Unity?

Je voudrais utiliser le Ctrl+Alt+T raccourci clavier pour démarrer un terminal autre que celui par défaut. Le terminal par défaut est gnome-terminal.

Où puis-je modifier la valeur de terminal par défaut?


124
2017-10-22 06:53


origine




Réponses:


Pour 12.04 et plus récent

gconf est maintenant obsolète - http://en.wikipedia.org/wiki/GConf - et gsettings peut être utilisé à sa place.

gsettings set org.gnome.desktop.default-applications.terminal exec 'terminal'

Terminal est la commande que vous utiliseriez pour l'ouvrir depuis le terminal.


118
2018-02-16 02:30



J'ai installé terminator en tant que terminal et désinstallé gnome-terminal mais la commande que vous avez suggérée ne fonctionne pas pour moi. - Gaurav Agarwal
Fonctionne bien pour moi le 13.10. - Martin
J'utilise Terminator comme terminal principal, mais après avoir exécuté cette commande, ctrl + alt + T ne fonctionne plus du tout. - user1880405
@ TorbenGundtofte-Bruun remplacer konsole avec gnome-terminal - Rumesh
Fonctionne toujours pour Ubuntu 16.04 - geekQ


sudo update-alternatives --config x-terminal-emulator

68
2018-04-24 10:31



Bien que ce soit une excellente réponse à la question (et généralement un moyen préférable de modifier un programme IMHO par défaut), cela peut ne pas être «l'arme de choix» en toutes circonstances. Pour élaborer: je voulais définir le terminal de guake par défaut mais il ne s’est jamais montré en essayant de le faire en update-alternatives. - FuzzyQ
Aussi, vous pouvez éditer directement dans le script xdg-open :) sudo gedit `which xdg-open` - iegik
Cela ne change pas le résultat de la commande de raccourci, comme cela est clairement indiqué dans la question, je ne comprends pas pourquoi il y a tant de votes positifs. - m3rosss
Cela fonctionne pour moi sur Ubuntu 17.04. j'ai installé terminology et c'est devenu le terminal Ctrl + Alt + T. Ran update-alternatives et changé à nouveau à gnome-terminal, et cela a fonctionné immédiatement. - rjh


Seulement dans Ubuntu 11.10 ou plus tôt! Pour les nouvelles versions, voir LucaB répondre!

Ouvrir un terminal (p.ex. gnome-terminal)

Exécutez la commande suivante:

gconftool --type string --set /desktop/gnome/applications/terminal/exec <YOUR-TERMINAL>

par exemple.:

gconftool --type string --set /desktop/gnome/applications/terminal/exec terminator

Terminé :).


39
2017-10-26 11:37



Cela ne résout pas le problème pour moi. Lorsque je lance Htop via son fichier .desktop (qui spécifie Terminal=True), ça commence dans le terminal Gnome, peu importe quoi. Y a-t-il encore un autre endroit pour changer l'émulateur de terminal par défaut? - Ryan Thompson
LA REPONSE CORRECTE EST BELLOW! - Gerep
@gerep Ma réponse est correcte, car la question a défini exactement la version d'Ubuntu: 11h10. Bien sûr, dans les nouvelles versions, gconftool est obsolète, ce n'est donc pas la bonne solution. - Regisz


Pour modifier le raccourci et non le termainal par défaut,

  1. recherche de clavier
  2. aller aux raccourcis et aux raccourcis personnalisés
  3. appuyez sur le signe plus pour ajouter un nouveau raccourci (dans ce cas, terminateur)
  4. quand on lui dit que le raccourci ctrl + alt + t est déjà utilisé, appuyez sur "reasign"

search for keyboard add new shortcut reasign


28
2018-05-06 20:14



Exactement ce que je cherchais, merci! - John Hamelink
ne fonctionne pas pour moi - Gaurav Agarwal
+100 pour être le plus facile à comprendre et celui qui a résisté à l'épreuve du temps. - Brandon Bertelsen


Essayez de changer d'option x-terminal-emulator via l'application "ALternatives Configurator".

pour Ubuntu, vous pouvez utiliser la commande ci-dessous:

sudo update-alternatives --config x-terminal-emulator

Il listera toutes les options de terminal que vous avez installées et vous pourrez ensuite choisir (par le numéro) celui que vous voulez.


7
2017-10-26 10:42



un peu d'aide: «Alternatives Configurator» est «galternatives» - Regisz


Pour configurer le terminal par défaut dans gnome, vous devez installer dconf-tools (sudo apt-get install dconf-tools).

Après cela, vous pouvez utiliser le gsettings pour définir votre émulateur de terminal préféré.

Disons que votre émulateur de terminal préféré est termite.

Installez-le avec sudo apt-get install termite

Après cela tapez cette commande

gsettings set org.gnome.desktop.default-applications.terminal exec termite

Depuis termite ne prend aucun argument (ou cela dépend de ce que vous en faites, vous pouvez les configurer de cette façon)

gsettings set org.gnome.desktop.default-applications.terminal exec-arg ""

Après ça termite sera votre émulateur de terminal par défaut.


5
2017-10-26 20:26



il y a une autre manière décrite dans askubuntu.com/questions/70540/… - krumpelstiltskin
C'est la même chose, vraiment pas important, de cette façon utilise l'outil de remplacement pour gconf - Bruno Pereira
exec-arg n'a malheureusement pas fonctionné pour moi. J'essayais de démarrer le terminal en mode plein écran. La seule option qui a aidé était de spécifier l'option dans la configuration. J'utilise le terminateur - Tim


Essayer

sudo update-alternatives --config x-terminal-emulator

3
2017-10-26 19:17



Hmm, à bien y réfléchir, cela ne semble pas le mettre à jour. - Kris Harper
Cela fonctionne parfaitement. Je vous remercie. - pedrorolo


Le système update-alternatives est une chose de Debian, mais Gnome exécute beaucoup plus de distributions, il a donc sa propre façon de définir les applications préférées.

Vous pouvez définir le terminal par défaut via l'utilitaire gnome-default-applications-properties, également accessible par gnome-control-center comme Applications préférées.

Sinon, vous pouvez définir la clé de registre gconf /desktop/gnome/applications/terminal/exec.

Cependant, il n'est pas garanti que toutes les applications fournies par Gnome, comme Nautilus, respecteront ce paramètre ou utiliseront plutôt leurs propres paramètres.


2
2017-10-26 20:17





Cela a fonctionné dans Ubuntu 13.10

gsettings set org.gnome.desktop.default-applications.terminal exec terminator

2
2017-09-14 17:22



C'est ce qui a fonctionné pour moi sur Ubuntu 14.04 avec terminator - trueCamelType