Question Problèmes lors de la mise à niveau de gnome-session


J'ai des problèmes depuis hier après une mise à niveau. La session GNOME a été perturbée et je ne peux plus installer de nouvelles mises à jour ni d'applications. Voici ce que j'ai reçu du terminal après avoir fait les recommandations apt-get install -f;

(Lecture de la base de données ... 166876 fichiers et répertoires actuellement installés.)
Se préparer à remplacer gnome-session 3.0.1-0ubuntu1 ~ build2 (en utilisant ... / gnome-session_3.0.2-0ubuntu3 ~ natty1_all.deb) ...

Déballer le remplacement gnome-session ...
dpkg: erreur de traitement /var/cache/apt/archives/gnome-session_3.0.2-0ubuntu3~natty1_all.deb (--unpack):

 essayer d'écraser «/usr/share/xsessions/gnome-shell.desktop», qui se trouve également dans le package gnome-shell 3.0.1-0ubuntu1 ~ build1

Des erreurs ont été rencontrées lors du traitement:
 /var/cache/apt/archives/gnome-session_3.0.2-0ubuntu3~natty1_all.deb
E: Le sous-processus / usr / bin / dpkg a renvoyé un code d'erreur (1)

Dans var/log/apt/history.log, ça dit:

Date de début: 2011-05-29 17:56:16
Ligne de commande: apt-get -f install
Mise à niveau: gnome-session: amd64 (3.0.1-0ubuntu1 ~ build2, 3.0.2-0ubuntu3 ~ natty1)
Erreur: le sous-processus / usr / bin / dpkg a renvoyé un code d'erreur (1)
Date de fin: 2011-05-29 17:56:21

Aucune idée de ce que tout cela signifie.


3
2018-05-29 21:03


origine




Réponses:


J'ai désactivé le PPA de GNOME 3, exécuté la mise à niveau, laissé utiliser l'original d'Ubuntu gnome-session, puis réactivé le PPA GNOME 3 et exécuté à nouveau la mise à niveau. Cette fois il n'y avait pas d'erreurs de dépendance.


2
2018-05-31 00:51



Choisissez cette réponse en utilisant la case à cocher située à gauche du message pour informer tout le monde que le problème a été résolu. - Oxwivi


Cela ressemble à un cas d’emballage cassé dans les paquets Gnome 3 que vous utilisez: La nouvelle version de gnome-session contient le fichier /usr/share/xsessions/gnome-shell.desktop, qui appartient également à la version actuelle du gnome-shell paquet que vous avez installé. L'erreur est due à ce conflit.

Peut-être vérifier s'il y a une nouvelle version du gnome-shell package disponible dans le PPA que vous utilisez?


1
2018-05-30 02:06