Question L'unité ne fonctionne pas après la mise à niveau d'Ubuntu 13.04 à 14.04


Le problème est que Unity semble brisé après une mise à niveau de 13.04 à 14.04 LTS sur x64, alors voici:

1) L'écran d'ouverture de session Unity semble étrange - par ex. les noms d'utilisateur sont difficilement lisibles en raison d'un contraste médiocre - mais je peux toujours utiliser l'écran pour me connecter. Le problème décrit ci-dessous affecte tous les utilisateurs.

2) Après vous être connecté, le fond d'écran Ubuntu standard apparaît "vierge" sans panneau ni lanceur. Il y a simplement "Ubuntu 14.04 LTS" en bas à gauche, apparemment reporté de l'écran de connexion.

3) Je peux passer au terminal de texte avec Ctrl+Alt+F1.

4) J'ai fait une série de correctifs trouvés en ligne, tels que:

rm -rf .compiz-1
  dconf reset -f / org / compiz
  unité setid
  unité-tweak-tool --reset-unit
  export DISPLAY =: 0
  dconf reset -f / org / compiz
  L'unité --reset-icons & disown

Je lance également ccsm et m'assure que le plug-in Unity et OpenGL sont activés.

5) Je peux maintenant commencer l'unité pour la session en cours en entrant la commande unity, mais je dois passer au terminal texte et entrer unity chaque fois que je me connecte maintenant.

6) La sortie de la commande "unity" est la suivante:

ATTENTION: pas de variable DISPLAY définie, mise à: 0

stop: job inconnu unit-panel-service

début: job inconnu unity-panel-service

compiz (core) - Info: Chargement du plugin: core

compiz (core) - Info: Lancement du plugin: core

compiz (core) - Info: Chargement du plugin: ccp

compiz (core) - Info: plugin de démarrage: ccp

compigconfig - Info: Backend: gsettings

compigconfig - Info: Intégration: true

compigconfig - Info: Profile: unity

compiz (core) - Info: Plugin de chargement: composite

compiz (core) - Info: Plugin de départ: composite

compiz (core) - Info: Chargement du plugin: openg1

compiz (core) - Info: plugin de démarrage: openg1

compiz (core) - Info: Unity est entièrement supporté par votre matériel

compiz (core) - Info: Unity est entièrement supporté par votre matériel

compiz (core) - Info: plugin de démarrage: openg1

7) avec Ctrl+Alt+F7 Je peux passer à la session Unity, où le lanceur fonctionne et les icônes d’application standard apparaissent sur le côté gauche. Mais le panneau est complètement vide. Les fenêtres ont toutes l'air d'un "vieux style" pour moi (je pense).

Toute aide très appréciée!


3
2018-06-07 16:28


origine


Essayez de le réinstaller ici askubuntu.com/questions/468204/… - JoKeR


Réponses:


Essayez une installation propre:

sudo apt-get update

sudo apt-get remove unity unity-2d unity-2d-panel unity-2d-spread unity-asset-pool unity-services unity-lens-files unity-lens-music unity-lens-applications gir1.2-unity-5.0 unity-common indicator-sound indicator-power indicator-appmenu libindicator7 indicator-application indicator-datetime indicator-messages libnux-2.0-0 nux-tools libunity-misc4 unity-2d-common

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get install unity unity-2d unity-2d-panel unity-2d-spread unity-asset-pool unity-services unity-lens-files unity-lens-music unity-lens-applications gir1.2-unity-5.0 unity-common indicator-sound indicator-power indicator-appmenu libindicator7 indicator-application indicator-datetime indicator-messages libnux-2.0-0 nux-tools libunity-misc4 unity-2d-common

sudo apt-get upgrade

J'ai pu résoudre un problème similaire dans le passé comme celui-ci.


2
2018-06-07 17:52



Cela a fonctionné pour moi - l'écran d'ouverture de session semble maintenant normal et Unity commence bien, y compris le panneau. Maintenant, le problème est que IBUS démarre à l'ouverture de session et que la disposition du clavier passe à l'anglais américain, mais je suppose que c'est un autre problème ... - user289372