Question Comment activer l'accès root ssh sur Ubuntu 14.04


Je voudrais activer le ssh accès root sur Ubuntu 14.04. Modifier le /etc/ssh_config (PermitRootLogin yes) n'a rien affecté.


118
2018-05-19 13:48


origine




Réponses:


Le simple ajout d'un mot de passe pour root ne suffit pas pour Ubuntu 14.04 Server.

Vous devez également modifier /etc/ssh/sshd_configet commentez la ligne suivante:

PermitRootLogin without-password

Juste en dessous, ajoutez la ligne suivante:

PermitRootLogin yes

Puis redémarrez SSH:

service ssh reload

Pour Ubuntu 16.04.1 LTS (GNU / Linux 4.4.0-59-generic x86_64) PermitRootLogin without-password a été remplacé par PermitRootLogin prohibit-password.


178
2018-06-27 21:12



En faisant cela via ssh, service ssh reload est utile. - Torsten Römer
J'exécutais Ubuntu sur VM, mais je ne sais pas si ces modifications n'ont pas fonctionné avant d'avoir redémarré une fois la VM (il se peut que je doive arrêter / démarrer les services réseau en plus des étapes ci-dessus). - VSB
je dois faire PermitRootLogin yes parce que j'avais un mot de passe clair - JorgeeFG
Si ssh ou scp vous indique "Autorisation refusée, veuillez réessayer" dans une autre fenêtre, quittez et réessayez ssh (ou scp) au lieu de simplement ressaisir le mot de passe. - Camille Goudeseune
N'oubliez pas non plus de vérifier si root est mentionné dans sshd_config: AllowUsers root - Jan


Vous devez configurer un mot de passe pour le compte root, puis cela fonctionnera.

sudo passwd

Entrez le même mot de passe deux fois.

P.S. Après avoir modifié / etc / ssh / sshd_config, n'oubliez pas de recharger le serveur openssh.

sudo service ssh reload

36
2018-05-19 13:51



Cela fonctionnera mais à l'OP: réfléchir à deux fois avant de le faire. Si vous le faites toujours et que votre PC est sur Internet, envisagez d'ajouter fail2ban au système. (Ce commentaire concerne l'activation de la connexion root via ssh; le fait d'avoir ou non un mot de passe local pour root est une question de goût). - Rmano


Avec Ubuntu 14.04 Server.

Définir le mot de passe

sudo passwd

Changements dans / etc / ssh / sshd_config

Changer PermitRootLogin

PermitRootLogin yes

Vous devrez peut-être également vérifier la valeur de PasswordAuthentication. S'il est défini sur no, réglez sur yes

PasswordAuthentication yes

Puis redémarrez SSH:

service ssh restart


17
2018-02-01 09:27



C'est la seule réponse complète. D'autres réponses manquent une partie. - wisbucky
Sauf que le mien n'a pas cette ligne. L'ajouter ne le fait pas fonctionner. - SDsolar
OMG, oui !! Je vous remercie! PasswordAuthentication était le chaînon manquant - mpen
J'ai purgé openssh-service et openssh-client sur les deux systèmes (Kali Linux et Ubuntu 18), les ai réinstallés, appliqué cette réponse et Everytihng a parfaitement fonctionné. - mk1024


Pour 14.04, vous devez commenter la ligne dans / etc / ssh / sshd_config

#StrictModes yes

3
2017-08-03 17:55



Au lieu de désactiver la vérification du mode fichier, il serait préférable de s'assurer que /root/.ssh et les fichiers qui s'y trouvent ne sont lisibles par aucun autre utilisateur que root. - Adaephon


Pour moi, aucune de ces étapes n'a fonctionné, j'ai même essayé quelque chose que je n'essayerais jamais d'autre chose qu'une vm de jouet: PermitRootLogin without-password

La seule chose qui a fonctionné pour moi était de désactiver le module PAM pour cela:

UsePAM no

Cette option est normalement à la toute fin du fichier. Pour être honnête, je ne connais pas les inconvénients réels, mais comme vous n'êtes pas censé autoriser la connexion root en ligne, je suppose que c'est correct pour un dev-vm privé.

Néanmoins, définissez toujours un mot de passe fort. Non, ce n'est pas une exception. Pas même seulement cette fois...


-1
2017-08-27 19:31



PermitRootLogin without-passwordCela ne signifie pas que l'utilisateur root se connecte sans authentification. Cela signifie que l'utilisateur root n'est pas autorisé à se connecter avec un mot de passe. Au lieu de cela, l'utilisateur root doit se connecter à l'aide de clés RSA, ce qui est plus sécurisé. - Craig
@Craig le problème auquel je fais référence n'est pas que root devrait alors utiliser les clés SSH RSA. Le problème est que root est un utilisateur que tout le monde à la porte de votre serveur SSH sait qu'il existe. Ce qui n'est pas une bonne chose à mon avis. Mais n'hésitez pas à laisser la connexion root via SSH, mais comme vous l'avez dit, assurez-vous au moins d'utiliser les touches pour le faire! - Kjellski
Tu as dit que tu n'essaierais pas PermitRootLogin without-password pour tout sauf un jouet VM. C'est ce que vous utilisez pour désactiver l'authentification par mot de passe pour root, de sorte que la seule façon dont root peut se connecter consiste à utiliser des clés RSA. Vous n'avez pas déclaré que vous aviez essayé cette option avec Clés RSA. Si vous avez essayé cette option sans clé, cela ne pourrait pas réussir. Si tu utilises PermitRootLogin without-password, vous ne pouvez pas vous connecter avec l'authentification par mot de passe, pas avec un mot de passe fort, pas avec un mot de passe vide, pas du tout. - Craig