Question 16.04 Problèmes de connexion wifi LTS avec l'adaptateur Realtek


J'ai découvert plusieurs problèmes avec la connexion wifi après l'installation de 16.04 LTS.

Tout d'abord, le wifi ne se reconnecte pas normalement après un sommeil ou une veille prolongée. Parfois, l'icône du réseau se transforme en "flèches haut et bas" (je ne sais pas à quoi ça sert) après le réveil mais est toujours connecté. Parfois, le réseau est simplement perdu et il n’affiche aucun réseau dans la liste, il est donc tout simplement impossible d’utiliser le wifi.

J'ai d'abord essayé de redémarrer le gestionnaire de réseau en exécutant sudo service network-manager restart. Cela a fonctionné mais n'était pas une résolution permanente.

Ensuite, selon un autre sujet, j'ai ajouté SUSPEND_MODULES="iwlwifi"à

/etc/pm/config.d/config

Après cela, le problème de reconnexion semble être résolu (peut se reconnecter automatiquement et l'icône ne change plus). Cependant, je trouve que la connexion wifi est perdue au hasard (environ toutes les 30 minutes) même lorsque l'ordinateur est en marche et l'icône réseau reste l'état connecté lorsque la connexion est perdue.

Un autre problème après l’ajout du code est que lorsque je mets mon ordinateur en veille, l’écran s’éteint une seconde, puis se rallume pendant environ 5 secondes (pendant lesquelles le système coupe la connexion wifi). Et puis l'ordinateur va dormir après ce processus inhabituel "en deux phases".

Plz trouver des informations sur les cartes sans fil ci-dessous

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Mise à jour: Je ne sais pas ce qui s'est passé mais le problème s'aggrave maintenant. La connexion Wifi se perd environ toutes les 5 minutes et je dois me reconnecter ou redémarrer le gestionnaire de réseau.


116
2018-04-25 05:13


origine


Les flèches haut et bas sont pour les connexions filaires - je les vois si j'utilise un périphérique Android par exemple. Il y a beaucoup de rapports de bogues liés à votre carte par exemple celui-là où il semble que l'installation de nouveaux pilotes a fonctionné pour certaines personnes. Peut-être trouverez-vous quelque chose ... - Zanna
Vous auriez dû utiliser SUSPEND_MODULES="rtl8723be" au lieu d'iwlwifi, votre carte n'utilise pas iwlwifi. Essayez aussi echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf et redémarrer - Jeremy31
Il peut réparer à la fois l'option fwlps qui désactive la gestion de l'alimentation et qui peut entraîner des déconnexions et d'autres problèmes - Jeremy31
J'ai vu beaucoup de questions sur le problème du wifi et je ne comprends pas une chose qui explique pourquoi il y a tant de problèmes liés au réseau, en particulier le wifi en 16.04 LTS. - d a i s y
@RyanNerd et une fois qu'ils ont le Mac, lancez Ubuntu dessus bien sûr! La bonne raison d'obtenir le Mac en premier lieu :-) - zwets


Réponses:


Finalement, j'ai pu résoudre les problèmes après avoir essayé un certain nombre de méthodes différentes.

  1. Obtenez des détails sur votre carte sans fil PCI en exécutant sudo lshw -class network
  2. Obtenez les informations relatives au modèle de votre carte en fonction de la gamme de produits.
    Par exemple, comme vous pouvez le voir dans la description de la question, il est écrit
      product: RTL8723BE PCIe Wireless Network Adapter donc le modèle de ma carte est RTL8723BE

    Ou product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller donc le modèle de ma carte est RTL8101/2/6E

  3. Donner la permission sudo chmod 755 /etc/pm/config.d/

  4. Ouvrir ou créer config et ajouter SUSPEND_MODULES="rtl8723be"(remplacez rtl8723be par votre propre numéro de modèle)
      Puis courir
      echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
      (notez que lors du remplacement rtl8723be avec ma carte qui est RTL8101/2/6E je devrais seulement taper .../modprobe.d/RTL8101.conf; et /2/6E ne devrait pas être écrit)

Relancez enfin votre système.

Maintenant, votre système devrait être capable de se reconnecter automatiquement après le sommeil, et la connexion wifi n'a jamais été perdue une fois pour toutes.

"Les flèches haut / bas sont probablement un bug de gestionnaire de réseau qui a pour conséquence que le gestionnaire de réseau pense que le périphérique wifi est en réalité Ethernet.", Selon Jeremy31.voir les infos de bogue ici Vous devriez pouvoir le réparer en installant NetworkManager-1.2.0.

Merci à Jeremy31 pour avoir fourni les solutions.


44
2018-05-06 03:09



Cela fonctionne comme un correctif à la sortie de la suspension. C'est la troisième solution qui fonctionne pour mon ordinateur portable avec une carte Intel 7260 wifi. Mais même après l'installation de NetworkManager-1.2.0, je reçois toujours les flèches (les miennes sont horizontales et non verticales) et une carte wifi complètement déconnectée lorsque j'essaie de changer de réseau. - Rsync
J'ai installé Ubuntu 16.04 il y a quelques heures et j'ai eu le même problème (mauvaise icône + wifi perdu au hasard). Semblait résolu avec sudo apt-get update && sudo apt-get dist-upgrade. Après le redémarrage, tout allait bien: des connexions plus stables et aucune icône erronée. - gwarah
Il n'y a pas d'attribut "product:" retourné pour mon dongle wifi. Seulement "configuration: ... driver = r8712u ..." - James Bowery
Soyez prudent avec cette solution. Il a complètement bouleversé mon réseau sur LM18. Je devais me rappeler quelles commandes je faisais pour pouvoir supprimer les fichiers de configuration et redémarrer. Imprimez cette page au cas où vous auriez besoin de référencer le processus. Je ne dis pas que c'est mauvais, cela a évidemment fonctionné pour certaines personnes. Mais pensé qu'un avertissement est en ordre ici. - RyanNerd
@KillABug - Le problème et / ou la solution ci-dessus peuvent être spécifiques à Realtek; avec l'appareil Centrino, je n'ai plus de problèmes après le sommeil mais je perds la connexion au hasard, surtout pendant le téléchargement. Ignorer IPv6 ne l'a pas réparé. - cipricus


J'ai exactement le même problème. Après s'être réveillé, le wifi fonctionne toujours mais les réseaux ne s'affichent pas. Je résous le problème en redémarrant le gestionnaire de réseau.

sudo service network-manager restart

Encore très ennuyeux. J'espère qu'ils vont bientôt résoudre ce problème.


37
2018-04-28 04:25



Ceci est seulement une solution temporaire. Pensez-vous que c'est un bug avec 16.04 LTS? - Lixu
ça marche pour moi. c'est probablement un bug. - avi software
travaille également à utiliser nmcli con up wifi-sid, si vous voulez un bodge rapide. - Rick-777
Cela n'a pas fonctionné pour moi. J'utilise Xubuntu 16.04 LTS et je suis connecté à un lecteur partagé Windows lorsque mon ordinateur est en veille. Fonctionnement sudo service network-manager restart juste gelé mon système encore pire. J'ai ensuite fait une fermeture de session - encore pire, et maintenant les icônes de mon bureau ont disparu. Ensuite, j'ai fait un redémarrage complet et maintenant les icônes de mon bureau ont disparu. Aucune idée de pourquoi, mais je vais désactiver le sommeil à coup sûr. C'est une mauvaise affaire. Ces types de problèmes où des choses simples devraient fonctionner me font vraiment manquer Windows, et je n'aime pas ce sentiment. J'espère qu'Ubuntu / Xubuntu va mieux. - Gabriel Staples
Avez-vous trouvé une solution pour le moment? - Emad Arshad Alam


C'est un bug à coup sûr. Bug a été déposé à https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347


30
2018-05-02 17:22



Ce bug a été fermé, en connais-tu un autre que je peux marquer comme affecté par? :) - Ads20000
Peut-être que ce bug a été fermé, mais le mien tombe parfois de temps en temps; et je n'utilise jamais de suspension. askubuntu.com/questions/938321/… - SDsolar


Informations supplémentaires: J'ai le même problème que celui décrit dans OP, mais uniquement le problème où l'icône de l'applet nm se transforme en flèches et n'affiche pas les informations wifi. Le wifi fonctionne toujours lorsque cela se produit.

$ killall nm-applet && nm-applet & 

Est-ce que le truc pour obtenir l'icône à afficher à nouveau, donc c'est juste une solution de contournement pour le moment si quelqu'un veut le mettre dans un script.

Peut confirmer ce problème sur deux ordinateurs distincts exécutant le package xubuntu-desktop.

En outre, les deux ordinateurs, j'ai exécuté des cartes wifi récentes. (quelque chose comme AC-7260)


10
2018-04-26 02:40



avez-vous trouvé une solution - Lixu
Merci, j'ai le même problème, mais cela ne m'arrive que lorsque je perds la connexion avec le routeur Wi-Fi, il arrive parfois que mon routeur reçoive des erreurs et une perte de connexion. - Aleksandar Đorđević
J'ai rencontré exactement le même problème que celui décrit ici sur manjaro-i3-20161201. Et successfly a ce problème résolu. Je vous remercie! - navigaid
Une autre chose que j'ai trouvé utile est, si vous voulez, de supprimer /etc/xdg/autostart/nm-applet.desktop pour l'empêcher de démarrer au démarrage et d'utiliser l'utilitaire nmtui pour vous connecter à un terminal wifi in. J'ai essayé la méthode et la connexion se reconnecte automatiquement lorsque mon ordinateur portable se remet en veille, même après la fermeture de nmtui. - navigaid


J'avais le même problème. J'ai corrigé le problème de la suspension en créant ce script à /etc/systemd/system/wifi-resume.service (celui que l'OP a posté ne fonctionnait que pour le session active; au redémarrage, il a dû être appelé à nouveau):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Il suffit ensuite d'émettre cette commande dans le terminal pour l'activer: sudo systemctl enable wifi-resume.service. Cette solution vient de une autre réponse à la question askubuntu, et fonctionne à la fois après la suspension et après le redémarrage.

Cependant, même après que cela a été corrigé, j'obtiens le même comportement que lors de la veille lorsque j'essaie de changer de réseau wifi: le wifi est essentiellement mort, avec les deux flèches, et l'applet dit "appareil pas prêt"Je peux redémarrer le wifi en émettant sudo service network-manager restart, mais je ne peux pas changer de réseau.

Est-ce que quelqu'un d'autre fait l'expérience de ceci et / ou a une solution?


6
2018-04-29 01:20



Comme vous avez toujours le problème, à quoi sert le script de toute façon? - Lixu
Le script FIXE le premier problème de l'OP: pas de wifi au réveil de la suspension. Cependant, il ne résout pas le second problème (pour moi): impossible de changer de réseau wifi sans perdre l’accès wifi. Si je n'étais pas clair, le deuxième problème existe indépendamment du premier. Le script ne crée pas le deuxième problème, il corrige simplement le premier. - Rsync
Je ne pense pas que ce script fasse quelque chose pour ma situation. Il s'est avéré que la connexion wifi se perd plus fréquemment après l'avoir utilisée. - Lixu
Essayez l'un des autres scripts autour (par exemple, askubuntu.com/questions/761180/…). Les deux ont travaillé pour le sillage de la suspension. Cependant, l'incapacité à changer de réseau m'a amené à revenir à 15.10. De plus, lors d’une nouvelle installation du 16.04, j’ai rencontré un troisième problème: le gestionnaire de réseau créait une nouvelle connexion wifi chaque fois que je me connectais à un réseau (par exemple, WIFI_1; WIFI_2; WIFI_3). Par conséquent, je devais saisir le mot de passe à chaque fois. - Rsync
Je n'utilise pas de CV mais cela semble prometteur. Merci d'avoir posté ceci. Voici ma question et une bonne réponse à la question: askubuntu.com/questions/938321/… - SDsolar


J'utilise LinxuMint 18 Mate (ubuntu16.04) et j'ai eu le même problème.

Tout le reste ci-dessus n'a pas fonctionné pour moi sur mon thinkpad T440S.

La seule solution qui semble fonctionner jusqu'à présent est la mise à niveau du noyau vers la version 4.6.3

  • Aller à ce site.

  • Obtenez les fichiers suivants:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Depuis un terminal, accédez au dossier contenant les fichiers ci-dessus et exécutez:

    sudo dpkg -i *.deb
    sudo reboot
    

Si vous utilisez Virtualbox, exécutez ceci sudo /sbin/vboxconfig

Si vous souhaitez les supprimer, exécutez:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Après quelques tests, la situation est presque la même, j'ai eu le wifi, mais mon nm-applet est incapable de voir tous les WIFI autour de moi. Donc, je ne sais pas si c'est une bonne solution :-)


2
2017-08-09 09:28



En utilisant LM18 aussi. Toutes les autres solutions ont tué mon réseau. Cette solution semble fonctionner. J'utilise Cinnamon et la mise à niveau du noyau a compliqué mon pilote Nvidia - pas la faute du noyau. Je suis certain que les développeurs de Nvidia utilisent l'acide b / c, ils ne peuvent pas suivre leurs propres spécifications chaque fois que je fais une mise à jour majeure du noyau. Je passe une heure ou plus à combattre la stupidité du pilote nvidia. - RyanNerd
J'ai voté ceci et je l'ai laissé de côté parce que la mise à jour vers le dernier noyau fonctionnant pour LM18 où je regardais ailleurs ne faisait pas de bonnes choses sur mon système. Malheureusement, la mise à niveau vers le noyau 4.6.3 n'a pas résolu mon problème de connexion Wi-Fi stupide à des moments aléatoires. Seulement arrive à la maison. J'ai le même routeur à la maison que j'ai au travail. Je ne sais pas ce qui se passe ici. Mon ordinateur portable est doté d’un processeur Intel Wireless 7260, qui est apparemment une version d’adaptateur sans fil dont le débit est très élevé et qui présente plusieurs problèmes sous Linux et Windows. Donc je suppose que je suis bloqué jusqu'à ce que le pilote soit mis à jour pour ce morceau de matériel s__t. - RyanNerd


Il n'y a pas de solution du tout, mais j'ai trouvé un script qui m'a aidé à rester wlan:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

Autostart ce script s'ouvre simplement gnome-session-properties et l'ajouter à la liste.

Le script complet (sans reconnexion) se trouve sur cette page web.


2
2017-10-17 19:28





Définissez le code de pays WIFI pour le domaine réglementaire actuel de Kernels s'il n'est pas défini

iw reg get

Pour le définir

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Redémarrez.


1
2018-05-11 09:34



Comment ou pourquoi cela aiderait-il? - A-B-B
Cette solution m'a aidé dans une certaine mesure. Avant, il fallait parfois quelques minutes pour établir une connexion Wi-Fi (je devais redémarrer le gestionnaire réseau plusieurs fois, parfois je devais redémarrer l'ordinateur), mais après avoir défini explicitement REGDOMAIN, cela fonctionne mieux. Mais après avoir réveillé l'ordinateur du mode veille, il n'arrive toujours pas de se connecter et je dois redémarrer manuellement le gestionnaire de réseau. Ennuyeux. - kovinet


juste pour ajouter pour la réponse acceptée (avec quatre étapes)

pour une raison quelconque, une seule étape me suffisait, même si je ne sais pas ce que cela signifie:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

1
2017-09-24 00:13