Question Comment désactiver les raccourcis F1 et F10 dans gnome-terminal?


Comment puis-je désactiver le F1 (aide) et F10 (menu de notifications) raccourcis clavier?

Le premier dont j'ai besoin pour l'utilitaire d'écran et le second pour quitter mc en console.

Il n'y a pas de telles reliures clés dans le Raccourcis clavier les paramètres du système.


115
2018-04-27 13:55


origine




Réponses:


11.04

Désactiver le raccourci F1

  1. Dans un gnome-terminal ouvre Modifier ➜ Raccourcis clavier.

  2. Faites défiler jusqu'à Aide / Contenu raccourci, cliquez où il dit "F1" et appuyez sur Retour arrière:

    enter image description here

Désactiver le raccourci F10

  1. Installez le compizconfig-settings-managerInstall compizconfig-settings-manager paquet.

  2. S'ouvrir Gestionnaire de paramètres CompizConfig.

    • Frappé Super pour ouvrir le Dash, tapez "Compiz" et tapez Entrer.
  3. Tapez "unit" dans le Filtre entrée et sélectionnez le Ubuntu Unity Plugin.

  4. Cliquez sur le bouton à droite de Touche pour ouvrir le menu du premier panneau et décochez la Activée case à cocher

    enter image description here

  5. Qui a désactivé le global F10 raccourci, maintenant désactiver les gnome-terminal F10 raccourci:

    • Dans un gnome-terminal ouvre Raccourcis clavier (Modifier ➜ Raccourcis clavier et
      décocher Activer la touche de raccourci du menu (F10 par défaut)

      enter image description here

  6. F10 est mappé sur menubar_accel par quelque chose dans Ubuntu. Gnome? Metacity? Vous ne savez pas exactement ce qui la vole, mais la clé ne parvient pas à Eclipse.

    • Lancez gconf-editor, naviguez jusqu'à / desktop / gnome / interface, puis faites défiler la page jusqu'à menubar_accel et supprimez la valeur F10. [Volé d'ici]

106
2018-06-23 18:52



Comment éditez-vous les raccourcis clavier dans une fenêtre de terminal? Première ligne. - jcollum
Ah, ok, c'est "ouvrir le menu Edition, sélectionnez Raccourcis clavier". J'ai oublié que les terminaux ont des barres de menu. Je pensais que je devais taper ça :) - jcollum
Tout ce qui précède ne résout pas la touche F10 au 12.04. Il est toujours lié quelque part cliquer avec le bouton droit de la souris. - Paweł Gościcki
Comment désactiver l'aide F1 dans Ubuntu 14.04? La ligne d'aide a disparu, semble-t-il. Je suis très proche de revenir à ctwm. - towi
@towi Dans cette boîte de dialogue, vous devez d'abord cliquer sur la ligne d'aide. Le réglage de la clé doit passer de F1 à "Nouvel accélérateur ...". Si vous cliquez à nouveau dessus, il deviendra "Désactivé". - user100464


Désactiver F10 dans gnome-terminal en 12.04

Tapez ceci dans la console:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Fermez ensuite toutes les sessions de terminal. Maintenant, il devrait fonctionner comme il se doit (en mc par exemple).


44
2018-04-30 19:25



Après avoir essayé des dizaines de solutions, ONE ONE a fonctionné pour Ubuntu 12.04 LTS. - NovumCoder
HOU LA LA! Mes emacs ont dit "Merci" - Cong Hui
Pour désactiver d'autres liaisons liées à gnome, je vous suggère cette solution ainsi que - csguimaraes


début gconf-editor et suivre /apps/gnome-terminal/keybindings/help

enter image description here

La description:

"Touche de raccourci clavier pour lancer l'aide. Exprimée sous forme de chaîne dans le même format que celui utilisé pour les fichiers de ressources GTK +. Si vous définissez l'option sur la chaîne spéciale" désactivé ", il n'y aura aucun raccourci clavier pour cette action."


23
2017-08-21 20:28



hélas, cela ne change rien. Je continue à obtenir l'écran d'aide lorsque vous appuyez sur F1. Ubuntu 14.04 Desktop, Unity. - towi
Notez que vous devez le définir sur désactivée non seulement effacer. J'ai failli lire ça. - Luc
Peut aussi être fait sans interface graphique en utilisant: gconftool-2 -s / apps / gnome-terminal / keybindings / help "disabled" --type string - Ddorda


Je suis nouveau sur Linux et cette clé F10 me rend fou. Toutes les astuces ci-dessus n'ont pas fonctionné, mais j'ai trouvé maintenant une solution (pour Ubuntu 11.10 avec le bureau classique Gnome 3). Dans un terminal, entrez la commande suivante:

gsettings set org.gnome.desktop.interface menubar-accel ""

Avec dconf-editor, on peut trouver que le F10 est vraiment parti. Notez que ce genre de trucs semble dépendre fortement de la version de Gnome / Ubuntu.


7
2017-11-29 19:34



Vaut le coup mais n'a pas fonctionné pour moi dans Ubuntu 11.10 - jcollum
+1 C'est le seul qui fonctionne dans ma machine 12.04. - Radu Maris


Pour quitter mc (avec la touche F10). Désactiver la "clé pour ouvrir le menu du premier panneau" dans le plugin Unit Compiz (ccsm)


4
2018-04-29 10:33





@kholis est correct pour désactiver F10 dans Unity, mais si vous êtes un newb comme moi, vous avez besoin d'un peu plus d'informations pour que cela fonctionne.

S'il n'est pas déjà installé, installez compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Démarrer le gestionnaire de paramètres nouvellement installé et filtrer pour "unit"

Modifier "Key pour ouvrir le menu du premier panneau" pour le désactiver ou le changer pour une autre clé.

Je n'ai pas encore trouvé de moyen de changer de F1.


4
2018-04-30 17:36





L'instruction à http://ubuntuforums.org/showthread.php?t=1317325 (cité ci-dessous) fonctionne également dans Ubuntu 11.04. (Il semble désactiver F1 à la fois sur le bureau et dans le terminal. C'est-à-dire que F1 n'envoie pas de séquence ansi au shell dans le terminal, si c'est ce que voulait l'OP.)

  1. Aller au système - Préférences - Raccourcis clavier
  2. Créez un nouveau raccourci. Nommez-le «ne rien faire» et écrivez «faux»   (sans les guillemets) dans le champ "commande". Poussez ok.
  3. Faites défiler jusqu'au bas de la liste et trouvez votre nouvelle commande. Cliquez sur   sur le "Disabled", à droite, et appuyez sur F1.

3
2017-08-22 02:12



Je vous remercie. Je travaille sur gnome classic et rien n'a aidé à ne rien faire. Merci encore. - Konrad Nowicki


Vous pouvez facilement le désactiver en utilisant CCSM (Cliquez pour installer si vous ne l'avez pas installé).

Ensuite aller à Bureau -> Ubuntu Unity Plugin -> Touche pour ouvrir le menu du premier panneau  et le désactiver ou le changer pour un autre raccourci clavier.

enter image description here

Remarque: il semble que cette méthode ne fonctionne pas dans Unity2D.


3
2017-10-26 22:03



J'ai désactivé le raccourci clavier avec CCSM, mais en appuyant sur F10, vous ouvrez toujours ce menu. - Conrad.Dean
bizarre, je l'ai désactivé et frapper F10 ne fait rien. - Binarylife
Utilisez-vous Unity2D? Parce que dans Unity 2D, il semble que cela ne fonctionne pas. Message mis à jour - Binarylife