Question Comment installer Cinnamon Desktop?


J'ai lu qu'il existe une nouvelle interface similaire à Gnome-2 appelée Cinnamon produite par les développeurs Linux Mint.

Est-ce disponible pour les utilisateurs d'Ubuntu - et si oui, comment l'installer?


115
2018-01-09 23:44


origine


Le PPA "Cinnamon Stable" à launchpad.net/~embrosyn/+archive/ubuntu/cinnamon semble être maintenu et permet à Cinnamon 2.8 d'être installé sur 14.04 et 15.10. - Mark


Réponses:


Cinnamon est une fourche de bureau Gnome-Shell. Ce n'est pas strictement une interface Gnome-2, bien que les objectifs des développeurs soient louables: produire une interface de bureau plus simple et plus traditionnelle.

Le développement semble être rapide. Il est utilisable et certainement amusant à jouer avec un nombre croissant d'extensions à installer pour étendre l'installation de base.

Comment installer

pour 13.04 et 13.10, 14.10 et plus tard

La cannelle est maintenant disponible dans le dépôt Universe

cannelle Install cinnamon

Alternativement - depuis la ligne de commande:

sudo apt-get install cinnamon-desktop-environment

Comme il se trouve dans ce référentiel, il est géré par la communauté et il appartient donc à la communauté de mettre à jour les packages au fur et à mesure de la sortie des nouvelles versions et des correctifs de bogues.

Pour Ubuntu 14.04, il n’existe actuellement aucun paquet de cannelle dans le référentiel d’Univers.

Via PPA pour 11.10 et plus tard

EDIT: 22/05/2014 - le PPA ppa:gwendal-lebihan-dev/cinnamon-stable a été supprimé ou masqué de la vue du public.  J'ai contacté le responsable et voici leur réponse:

Le PPA stable n'est en effet plus maintenu.

La PPA nocturne est conservée à des fins de développement et ne devrait pas   être utilisé sur tout type de machine de production (il peut et va casser à   à tout moment).

Pour être honnête, je n'ai pas d'alternative pour offrir aux utilisateurs d'Ubuntu au   moment, en dehors de passer à une distribution qui prend en charge   Cannelle. Il y a beaucoup de telles distributions là-bas, et je ne suis que   en espérant que quelqu'un (enfin) se rallie à Ubuntu pour fournir   paquets appropriés à ses utilisateurs.

EDIT: 25/04/14 - Deux PPA alternatifs ont été créés - tous les deux prétendant permettre stable version de Cinnamon pour les utilisateurs d'Ubuntu. Je ne peux pas garantir le la véracité de ces AAE

Option 1: utilisateurs 12.04 et 14.04 seulement:

sudo add-apt-repository ppa:tsvetko.tsvetkov/cinnamon
sudo apt-get update
sudo apt-get install cinnamon

Option 2: utilisateurs 14.04 uniquement:

sudo add-apt-repository ppa:lestcape/cinnamon
sudo apt-get update
sudo apt-get install cinnamon

Comme alternative, vous pouvez envisager les constructions automatiques nocturnes instables - veuillez noter l'avertissement de Gwendal ci-dessus:

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-nightly
sudo apt-get update
sudo apt-get install cinnamon

Option 3: De plus, vous pouvez également installer Cinnamon 2.2 dans Ubuntu 14.04 LTS et ses dérivés en ajoutant un dépôt Linux Mint 17 Qiana dans votre système.

Fichier ouvert /etc/apt/sources.list avec nano commande:

sudo nano /etc/apt/sources.list

Ajoutez la ligne suivante à la fin du fichier /etc/apt/sources.list

deb http://packages.linuxmint.com/ qiana main upstream import

Mettez à jour le référentiel puis installez la clé d'authentification

sudo apt-get update
sudo apt-get install linuxmint-keyring

Mettez à jour le référentiel à nouveau et installez Cinnamon 2.2:

sudo apt-get update
sudo apt-get install cinnamon

Après l'installation

Déconnectez-vous et sélectionnez la session Cinnamon:

enter image description here

Entrez votre mot de passe et vous verrez le bureau Cinnamon

enter image description here

... montrant le traditionnel début taper le menu et la conception des applets à partir de Gnome-2

enter image description here


Extensions / Applets

Le bureau Cinnamon utilise la même philosophie que Gnome-Shell - la fonctionnalité peut être ajoutée en installant Extensions & Applets.

Cinnamon utilise son propre outil de configuration.

Paramètres de cannelle

enter image description here

Applets à la cannelle

Semblable aux extensions gnome-shell, vous pouvez installer des applets à partir d'un site Web Mint dédié.

enter image description here


115
2018-01-09 23:45



Cela a été formidablement utile, mais j'aimerais ajouter que la purge de la cannelle supprime les paquets, mais puisque le ppa est déjà ajouté, les événements de mise à jour apt prendront les paquets de cannelle à télécharger et à mettre à jour. supprimer ppa: gwendal-lebihan-dev / cannelle-nightly - Aukhan
Ce qui m'a sauvé, c'est le site Web dédié à la Monnaie. Merci beaucoup ! - Henrique de Sousa
Il serait utile que cela puisse être mis à jour, puisque nous sommes en 2015 et que Cinnamon est en version 2.6. Il existe des descriptions sur Internet de l’utilisation du PPA à ppa:moorkai/cinnamon pour 15.04, mais pour autant que je sache, cela ne fonctionne pas en raison d’une dépendance libcjs0. - Pointy
@Pointy - la cannelle est disponible dans le repo d'univers, donc la réponse est toujours valable. En ce qui concerne 15.04 + cinnamon v2.6, vous devez contacter moorkai pour voir si l'auteur corrigera le problème PPA. Une fois terminé, nous pouvons ajouter une section "dernière version" pour la réponse. - fossfreedom♦
@fossfreedom OK merci Il y a aussi un PPA "nightly", mais la version que j'ai installée à partir de là est clairement cassée (ou il y a un énorme problème de dépendance, ou autre). Je vais contacter moorkai. - Pointy


12.04 vs 11.10

J'ai contacté la cannelle Ubuntu Propriétaire de PPA - Gwendal LE BIHAN - 2 avril - voici la réponse:

Nous sommes en train de finaliser la migration de   cannelle à gnome3.4. Le PPA sera mis à jour avec des paquets précis comme   dès que cela est fait.

Ces paquets devraient être disponibles dans une semaine ou 2, et certainement   avant la libération précise.

Notez que plus aucune version de cannelle ne sera disponible pour d'autres   versions d’Ubuntu, puisque les bibliothèques gnome3.4 ne sont pas disponibles sur   versions de Ubuntu avant de préciser.


Des versions précises sont maintenant disponibles dans la PPA et peut être installé selon la réponse liée.

Désormais, les packages Oneiric dans le PPA seront corrigés à la v1.4. Ainsi, si vous êtes un utilisateur Oneiric (11.10), votre itinéraire de mise à niveau doit se faire via le chemin de distribution 12.04, suivi par la réactivation ou l’ajout du PPA.

Vous pouvez également envisager l'une des autres réponses à la question.


17
2018-04-02 11:16





CAE pour 12.04 (construction de nuit)

Les packages pour Precise sont maintenant disponibles sur le PPA tous les soirs :

Le PPA stable prendra un peu plus de temps avant d'être mis à jour, tout commentaire sur les forfaits nocturnes sera le bienvenu.

sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-nightly
sudo apt-get update
sudo apt-get install cinnamon

10
2018-04-03 20:07





Vous pouvez télécharger deb les fichiers de github à la cannelle dépôt aussi bien

Ou vous pouvez directement utiliser Dépôt Linux Mint. Ajoutez simplement à vos sources logicielles

deb http://packages.linuxmint.com/ lisa main

et fait

sudo apt-get update
sudo apt-get install linuxmint-keyring cinnamon cinnamon-session

4
2018-01-18 11:49



C'est maintenant un peu dépassé, mais j'ai essayé rebecca main sur 14.10 - dépendances non satisfaites. - pileofrocks
Cela devrait fonctionner avec les versions jusqu'à 14.04 (avec qiana ou rebecca pour 14.04 et maya pour 12.04). Aucune version Linux Mint n'est actuellement basée sur 14.10+, donc cela ne fonctionnera pas pour ces versions - voir ici pour savoir comment les versions de Mint et d'Ubuntu sont liées. - Wilf


Édité le 25 octobre 2015

À installer Cannelle 2.6 stable

Ouvrez le terminal et exécutez les commandes suivantes:

Dans Ubuntu 15.04 Vif

sudo add-apt-repository ppa:moorkai/cinnamon
sudo apt-get update
sudo apt-get install cinnamon

À installer sur 14.04, 15.04, 15.10 

sudo add-apt-repository ppa:kranich/cinnamon
sudo apt-get update
sudo apt-get install cinnamon

3
2017-09-30 07:03





Pour 15.10:

Après avoir activé le référentiel d'univers, exécutez les commandes suivantes:

sudo apt-get update
sudo apt-get install cinnamon-desktop-environment

La version actuelle est la 2.6.2


2
2017-11-29 00:58





Vous pouvez installer Cinnamon 3.0 sur Ubuntu 16.04 LTS via PPA.

Cinnamon 3.0 a été libéré en avril 2016 avec une prise en charge améliorée de GTK + 3.20, de nouveaux paramètres d'accessibilité et de son et bien plus encore. Bien que Cinnamon 3.0 ne soit pas disponible pour être installé sur Ubuntu via son PPA officiel, vous pouvez l’installer en ajoutant un PPA communautaire. Donc, utilisez-le à vos risques et périls.

Avant d'installer Cinnamon 3.0 sur votre Ubuntu 16.04, veuillez purger cette PPA si vous l'utilisez déjà

Utilisez les commandes suivantes pour installer Cinnamon 3.0 sur Ubuntu 16.04.

sudo add-apt-repository ppa:embrosyn/cinnamon
sudo apt update
sudo apt install cinnamon blueberry

Une fois l'installation terminée, déconnectez-vous et vous pouvez sélectionner l'environnement de bureau Cinnamon en cliquant sur l'icône située à côté de votre nom d'utilisateur.

enter image description here


1
2017-08-03 13:40