Question Comment puis-je désactiver le son de batterie sur l'écran de connexion?


Je m'attendais Système ▸ Administration ▸ Écran de connexion ▸ Lecture du son de connexion pour contrôler cela, mais décocher cela n'empêche pas le son de batterie de jouer.


110
2018-02-05 18:05


origine


Effets sonores: Windows contre Ubuntu - Ubuntu a besoin de travailler dans ce domaine (même aujourd'hui). - Lonnie Best


Réponses:


Le son de démarrage peut être désactivé en modifiant la configuration d'Unity Greeter. Exécuter ce qui suit à partir d'un terminal fera ceci:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Si vous utilisez Ubuntu 12.04 LTS, assurez-vous que les mises à jour sont installées car cette fonctionnalité a été ajoutée dans une mise à jour.


57
2018-02-05 18:20



Il y a une option dans gsettings pour cela, com.canonical.unity-greeter play-ready-soundmais actuellement ne fonctionne pas. Une chose simple qui fonctionne est que, sur l'écran Greeter, il suffit de désactiver le volume dans l'indicateur sonore. Le paramètre est persistant - doug
@doug, merci Les deuxième et troisième phrases de votre commentaire ne concernent pas cette réponse. Je pense qu'ils devraient aller en tant que réponse séparée à ma question pour être plus visible. - Marco Lackovic
Je pense que la solution pour changer le son de façon permanente est de déplacer ou de supprimer ce fichier: /usr/share/sounds/ubuntu/stereo/system-ready.ogg. Voir à partir de ce fil -> ubuntuforums.org/… - emf
@ e.m.fields Inutile de recourir à un tel hack destructeur lorsque nous avons un réglage intégré à l'appui de cela. Changer ce paramètre est la solution la plus propre. - ændrük
aendruk, je suis en faveur de solutions non destructives lorsqu'elles sont disponibles, mais jusqu'à présent, il semble n'y en avoir eu aucune. Quel est ce fichier? Est-ce un correctif pour une application système existante? - emf


Pour Ubuntu 12.04+

LightDM Way

Également connu sous le nom de FluteFlute Slap, le LightDM Way implique la déconnexion et, sur l'écran de connexion du LightDM, vous pouvez modifier le volume ou même couper le son.

Dans le Greeter de connexion, vous pouvez voir le volume en haut à droite. Le réglage du volume n’affecte pas le volume au démarrage de la session, vous pouvez donc MUET le son dans le Greeter sans couper le son lorsque votre session commence:

enter image description here

Ubuntu Tweak Way

La méthode Ubuntu Tweak implique de télécharger l'application Ubuntu Tweak, puis de désactiver le son à partir de là. Effectuez les étapes suivantes et vous pouvez le faire de cette façon:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Ouvrir Ubuntu Tweak et dans l'onglet Tweak, sélectionnez l'option "Login Settings", vous devriez voir l'option Play Login Sound. Vous devez cliquer sur le bouton Verrouiller ci-dessus pour pouvoir changer cela.

enter image description here

Pour Ubuntu 11.10 et ci-dessous

Aller à System -> Preferences -> Startup Applications

Startup Applications

Désactiver celui appelé Son de connexion GNOME 

(décochez la case et cliquez sur Fermer)

Disable the sound

vous pouvez aussi aller à System -> Preferences -> Sound et désactiver l'ensemble du système audio (comme les sons Windows, les alertes, etc.)

Dans les anciennes versions, vous pouviez accéder à la partie Préférence sonore et sélectionner chaque son et ce que vous vouliez faire. Il a été supprimé autour de 9.04 ou 9.10. Ce serait bien si cela revenait.


58
2017-09-10 11:11



@AliNa ​​- Ensuite, vous avez trouvé un bug sur mon ami. Tuez-le avec un insectifuge. Vous aurez sauvé beaucoup de vies dans le processus. - Luis Alvarado♦
Vous ne pouvez pas utiliser le bouton MUTE pour couper le son (on ne s'en souvient pas). Mais vous pouvez régler le volume sur 0 qui est mémorisé et qui n'affecte pas le volume après la connexion. - rubo77
Le "LightDM Way" a coupé tous les sons de ma session (i3). Le réglage n'était pas visible dans pavucontrol et a dû être retourné dans la greeter. En changeant le réglage correspondant de LightDM était efficace. - Raphael


12.04 - 16.10 (LightDM)

Voici ce qui a fonctionné pour moi après avoir installé 12.04 la semaine dernière.

Les étapes sont celles-ci, adaptées de http://www.liberiangeek.net/2012/05/disable-the-ready-drum-sound-in-ubuntu-12-04-precise-pangolin/:

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Ajoutez ces lignes:

[com.canonical.unity-greeter]
play-ready-sound = false

Enregistrez, puis exécutez:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Redémarrez et appréciez.


54
2017-10-15 11:23



Fonctionne également le 16.10. - orschiro
Fonctionne aussi le 17.04 - Katu
Confirmez simplement que cela fonctionne le 18.04 sur Unity (pour ceux qui sont bizarres, comme moi :)). Remarque rapide pour ceux qui ne sont pas trop familiers - vous créez un nouveau fichier lorsque vous ouvrez "50_unity-greeter.gschema.override". J'étais confus quand je ne pouvais pas trouver ce fichier jusqu'à ce que je réalise que l'instruction consistait à créer un nouveau fichier. (pourrait être utile de mentionner que dans le message original?) - JamesBB


11.10 (LightDM et GDM)

Solution rapide:

Ouvrez un terminal et lancez la commande

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

Le son de batterie lightdm pour le système prêt peut être désactivé de la même manière

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  

20
2017-10-15 11:26





Pour 12.04

Par défaut, il est désactivé. Pour l'activer, ouvrez un terminal et lancez

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Puis changez la valeur pour X-GNOME-Autostart-enabled à "vrai", c'est-à-dire X-GNOME-Autostart-enabled=true

Pour 11.10

Tapez sur un terminal gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop et changer la valeur NoDisplay de vrai à faux:

enter image description here

Maintenant, allez à vos applications de démarrage et vous devriez voir et pouvoir désactiver l'option nécessaire:

enter image description here


11
2018-02-05 19:43





10.10 (GDM)

Il semble y avoir un bogue dans l'écran de connexion à ce sujet. Je ne trouve pas de rapport officiel, cependant, ce post du forum confirme un correctif.

Accédez à l'écran Système / Administration / Connexion. Débloquez-le, puis cocher "Lire le son de connexion".

Fermez la fenêtre, puis retournez dans l’application, déverrouillez-la, puis décocher la même option.

enter image description here


10
2017-09-10 10:15





Si vous utilisez GDM avec 12.04

Pour désactiver les sons de connexion, le sons d'événements touche sous org.gnome.desktop.sound  pour l'utilisateur gdm doit être défini sur false.

Pour cela, nous devons d'abord donner à GDM la propriété de son propre répertoire personnel. Ouvrez un terminal et tapez: sudo chown -R gdm:gdm /var/lib/gdm

Puis lancez:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

et déconnexion (ou redémarrage).

Si vous utilisez LightDM avec 12.04

Ouvrez un terminal avec Ctrl + Alt + T et tapez / collez ce qui suit, une ligne à la fois:

sudo xhost + SI: utilisateur local: lightdm
sudo su lightdm -s / bin / bash
gsettings set com.canonical.unity-greeter play-ready-sound false
Sortie

Qu'est-ce que cela fait est de désactiver le play-ready-sound réglage pour le écran de connexion / utilisateur du gestionnaire de bureau (lightdm).


7
2018-03-07 08:03



Je n'ai pas travaillé pour moi le 12.04 avec gdm. Les paramètres gdm affichent 2 avertissements. Après le redémarrage, le son est toujours en cours de lecture. - geekQ
Attention à coller les avertissements? - ish
Avertissements: pastebin.com/KTifY1Qi - geekQ
La ligne gsettings set com.canonical.unity-greeter play-ready-sound false une erreur sur 15.04, l'erreur est (process:2257): dconf-WARNING **: failed to commit changes to dconf: Error spawning command line 'dbus-launch --autolaunch=4cc96c42d68a423d93de2cbdd23b5a89 --binary-syntax --close-stderr': Child process exited with code 1 - texasflood
dconf-editor peut être utilisé pour définir com.canonical.unity-greeter.play-ready-sound. - Raphael


11.10 (LightDM et GDM)

Pour supprimer le son de démarrage:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Pour activer le son de démarrage

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Pour supprimer le son de connexion (après vous être connecté):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Pour l'activer à nouveau:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg

5
2018-03-07 08:02



Note: le 12.04 avec GDM déplaçant le system-ready.ogg juste changements le son de démarrage de l'original à un rythme court. - geekQ


11.10 (LightDM et GDM)

Cela devrait fonctionner pour vous.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Puis changez le NoDisplay = sur false, ect.

ou pour l'enlever:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg

3
2017-09-30 07:13





11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false

3
2017-07-17 16:02





12.10 (GDM)

Rien de ce qui précède ne fonctionne pour moi avec gdm. Si je désactive le son prêt pour le système (les bongos), il produit toujours un son de batterie court (un temps).

La façon de le désactiver est la suivante:

  • Démarrez, entrez dans gdm.
  • Passez à la console (Ctrl + Alt + F1)
  • S'identifier
  • Entrer:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Revenez à gdm (Ctrl + Alt + F8)

  • Désactiver le son dans le mixeur. Je l'ai coupé dans "Lecture" et "Périphériques de sortie".
  • Fermez le mixeur, vous pourriez avoir une erreur à propos de l'écriture du fichier de configuration, ceci est sans danger.
  • Revenez à la console et entrez

    sudo service gdm restart
    

    pour tester, et exit se déconnecter


1
2018-06-27 07:51