Question Comment activer WebGL dans Chrome sur Ubuntu?


chrome://gpu/

enter image description here

Et http://webglreport.com/

enter image description here

 google-chrome --version
 Google Chrome 27.0.1453.93 

http://www.chromeexperiments.com/webgl

enter image description here

Comment activer WebGL dans Chrome sur Ubuntu?


109
2018-05-24 05:27


origine




Réponses:


Pour que WebGL fonctionne dans Google Chrome (et Chrome), procédez comme suit pour activer WebGL dans Google Chrome.

Étape 1: Ouvrez Google Chrome

Étape 2: Type chrome://flags dans la barre d'adresse

Étape 3: presse Ctrl + f et tapez " Rendering list “,“ Remplacer la liste de rendu du logiciel ” devrait venir, maintenant cliquez sur Activer et redémarrez le navigateur.

Étape 4: tuer complètement Chrome: Type killall chrome dans une console.

Étape 5: Aller à chrome://settings et permettre Use hardware acceleration when available. Par défaut, il est désactivé depuis la version 43.

Étape 6: Démarrer Chrome

enter image description here

Maintenant vérifier chrome://gpu/

enter image description here

http://webglreport.com/

enter image description here

La source


148
2018-05-24 05:27



Maintenant, j'ai YouTube dans les lecteurs HTML5 avec de belles performances! - Vitaly Zdanevich
Pourquoi n'est-ce pas activé par défaut ??? - Konstantin Schubert
@ Constantin C'est une bonne question, je vais faire des recherches à ce sujet. - Qasim
Astuce: dans Ubuntu à coup sûr (Windows aussi le plus probable), vous devrez vous assurer de tuer les threads d'arrière-plan (chrome) avant que les modifications ne prennent effet. - Lance Caraccioli
@Kostanos non, je ne sais pas que ... c'est la façon la plus simple ... - Qasim


Si vous n'obtenez toujours aucun résultat, vérifiez si l'accélération matérielle est activée dans les paramètres Chrome, Google a tendance à désactiver ce paramètre par défaut depuis la version 43. Dans ce cas, c'était le problème après la mise à jour des pilotes GPU. Liste noire du GPU, et ainsi de suite.


10
2017-07-11 10:57



Pareil ici. Je pensais que je voyais un bogue terrible mais je n'ai pas réalisé chrome: // settings -> Afficher les paramètres avancés ... -> Utiliser l'accélération matérielle lorsqu'elle est disponible d'une manière ou d'une autre désactivée. Je l'ai retourné, redémarré le navigateur et tout fonctionne. - Stephen Niedzielski
Travaillé pour moi, merci - shturm
La désactivation de l'accélération matérielle a fonctionné pour moi. - Thomas Orlita


en utilisant la version 49.0.2623.108 de chrome sur Ubuntu 14.04 (64 bits).

Ce que nous devons activer est #ignore-gpu-blacklist

C'est la première ligne de chrome://flags/

J'espère que ça peut aider,


2
2018-04-22 08:23





Peut-être trop vieux votre pilote vidéo ou pas installé correctement.

J'ai eu le même problème aussi, mais cette solution a corrigé mon problème sans déranger!

  1. Ajouter PPA pour Ubuntu 14.04 / 13.10 / 13.04 / 12.10

    Utilisateurs d'Ubuntu 14.04 / 13.10 / 13.04 / 12.10, exécutez la commande suivante dans le terminal et tapez le mot de passe de l'utilisateur à l'invite. D'autres utilisent le PPA Ubuntu-X.

    sudo apt-add-repository ppa: xorg-edgers / ppa
  2. Ajouter PPA pour Ubuntu 12.04 / 11.10 / 11.04 / 10.04

    sudo apt-add-repository ppa: ubuntu-x-swat / x-updates

    Après avoir ajouté le PPA, mettez à jour votre référentiel système.

  3. Mettre à jour

    sudo apt-get update

    Installez maintenant le pilote graphique NVIDIA GeForce 304.108 dans votre système, au fur et à mesure que vous installez d'autres packages à l'aide d'apt-get.

  4. À installer

    sudo apt-get installe nvidia-current nvidia-settings

    La commande ci-dessus installera le pilote.


La source: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/


1
2017-10-22 13:04



J'utilise cette solution sur mon bureau depuis une semaine, mais mon Chrome mange parfois tout le processeur (la tâche "Processus GPU"). - J'ai Ubuntu Trusty avec "GeForce 8400 GS Rev. 2" - Je ne peux pas trouver de solution pour cet effet secondaire, seulement j'ai une solution de contournement: Activez l'option "Désactiver le canevas 2D accéléré" dans chrome: // flags / ... Grrr - andras.tim


J'ai eu le problème que WebGL a été signalé comme indisponible après le passage de la Nvidia propriétaire aux nouveaux pilotes, une modification qui ne semble pas avoir été prise en compte dans la configuration du chrome GPU de mon profil. Le correctif est en cours d'exécution chromium-browser --single-process  une fois que pour réinitialiser la configuration du GPU.


0
2017-07-06 21:17