Question Comment modifier le système de fichiers en mode de récupération en mode lecture-écriture?


J'ai foiré mon sudoers fichier et je veux modifier l'autorisation sur elle.

Lorsque je me connecte en mode de récupération, je ne peux pas exécuter la commande chmod car c'est une option en lecture seule.

j'ai essayé mount -o remount,rw / en mode de récupération. N'a pas fonctionné pour moi:

Err : Ext4-fs remount. Opts errors=remount-ro 

Comment puis-je démarrer en mode de récupération et avec l'option lecture-écriture?


106
2018-04-01 16:45


origine




Réponses:


J'ai fait quelques recherches sur le site "Recover Mode Read Only" et je suis tombé sur ce post sur le site LinuxQuestions.org.

  1. Éteindre l'ordinateur
  2. Démarrez en mode de récupération --Après le chargement du BIOS, maintenez la touche Maj enfoncée pour accéder au menu grub --Une fois dans le menu grub, sélectionnez l’entrée se terminant par "(mode de récupération)"
  3. Dans le menu suivant, option sélectionnée pour entrer dans la session racine
  4. A la session racine, exécuter la commande mount -o rw,remount / à remonter le système de fichiers en lecture-écriture

179
2018-04-01 16:54





J'utilise toujours le moyen suivant pour passer en mode lecture / écriture

  • Connexion en mode sans échec
  • Dans le menu, allez à Ver option, il donnera un message comme La mise à jour de grub montera votre système en mode lecture / écriture. Juste choisi Oui pour monter votre système en mode lecture / écriture. Il mettra à jour votre grub et sortira de Ver menu.
  • Connectez-vous enfin comme racine, votre système sera en mode lecture / écriture.
  • Vous pouvez également choisir dpkg option du menu pour changer le système de fichiers en mode lecture / écriture.

Cela a toujours fonctionné pour moi. Cela aide lorsque vous ne vous souvenez plus de la commande pour passer en mode lecture / écriture.

Il suffit d'essayer ..


17
2017-08-28 16:52





Comme la réponse est un peu ancienne et n'a pas fonctionné pour moi, je partage avec vous ma solution. J'ai mal écrit une option dans fstab pour le / répertoire (très mauvais, je sais).

Afin de monter en mode de récupération avec l'option lecture-écriture, les solutions mentionnées ne fonctionnaient pas pour moi.

J'ai simplement choisi le noyau avec l'option de mode de récupération et j'ai appuyé sur e modifier le paramètre de démarrage à partir de ro à rw.


14
2018-06-22 02:16



+1 pour une solution alternative, même si elle n'est peut-être pas idéale dans de nombreux cas. - Stunts