Question L'unité ne se charge pas, pas de lanceur, pas de tiret


Lorsque je me connecte, rien ne se passe.

Je suis présenté avec mon fond d'écran.

Blank desktops suck

Pas de tiret, pas de lanceur, rien.


535
2017-12-14 17:24


origine


IMHO c'est un bug, mais je l'ai depuis aujourd'hui. Impossible de trouver ce bogue bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 J'ai suivi les recommandations ici: askubuntu.com/questions/17381/… Unity a été réinitialisé mais ne fonctionne pas correctement, les espaces de travail ne fonctionnent pas, même si j'active ou désactive ou modifie le montant. Aucune différence. Put plugin plante aussi l'unité, - Janghou
Mes problèmes ont commencé après le passage des pilotes nouveau aux pilotes NVIDIA (paramètres système / onglet matériel). - DanielaWaranie
Après plusieurs jours passés à lire et à lire de nombreux threads SO, j'ai trouvé que cela semblait être un bug ouvert d'Ubuntu (Status 'Incomplete' à partir de juillet 2015). Plus d'informations à ce sujet ici: bugs.launchpad.net/ubuntu/+bug/1285444  La solution rapide semble être: $ mv ~/.config/dconf/user ~/.config/dconf/user.old - xyz
@ julianromera était la seule solution sur ce sujet qui m'a aidé - Dziamid
La réponse de @julianromera a été la seule qui a fonctionné pour moi. - Paweł Adamski


Réponses:


Cette réponse s'applique aux versions d'Ubuntu exécutant Compiz.

Cette réponse suppose qu'Unity est géré par Compiz. Si vous n'avez pas compiz installé cette réponse ne vous concerne pas.

Il vous suffit de réactiver le plug-in Unity. Le problème est que c'est une douleur dans le fond parce que vous n'avez plus de méthode graphique pour le faire. Alors:

  1. Essayez d'ouvrir un terminal avec Ctrl+Alt+T.
    Cela peut ne pas fonctionner, mais vous pouvez essayer de cliquer avec le bouton droit de la souris sur le bureau et sélectionner "Ouvrir le terminal ici". Sinon, vous devrez peut-être changer de terminal en appuyant sur Ctrl+Alt+F1 et connectez-vous

  2. Installer compizconfig-settings-manager en exécutant

    sudo apt-get install compizconfig-settings-manager
    
  3. Ensuite, lancez-le avec ceci:

    DISPLAY=:0 ccsm &
    

    La première partie indique au terminal l’affichage que vous souhaitez qu’il charge (sinon il n’aura pas d’indice).

  4. Si vous êtes passé à un TTY à l’étape 1, revenez au serveur graphique en appuyant sur Ctrl+Alt+F7 (ou Ctrl+Alt+F8 parfois).
    Il devrait y avoir un gestionnaire de paramètres CompizConfig qui vous attend.

  5. Trouvez le plugin Unity. Activez-le On vous demandera "Ubuntu Unity Plugin nécessite le plugin OpenGL. Activer le plugin Ubuntu Unity / Activer OpenGL"

  6. Tout devrait entrer en jeu, mais si ce n'est pas le cas, vous devrez peut-être redémarrer. Vous pouvez le faire en retournant au terminal et en exécutant sudo reboot.


465
2017-11-07 23:23



A bien fonctionné pour moi. En passant, je n'ai pas eu besoin d'entrer dans le terminal TTY, j'ai pu utiliser le raccourci du terminal (ctrl + alt + t). - Tass
Si vous arrivez à l'étape 5 et ne voyez pas l'unité sur la liste, essayez ceci: sudo apt-get -f install && sudo apt-get --reinstall install unity - Collinux
Avait ce problème moi-même, mais je n'ai pas de chance avec la solution loin, ne fonctionne pas pour moi, toujours obtenir le même écran vide sur Ubuntu 14.04 LTS 64bit. Je reviendrai sur les étapes pour vérifier si quelque chose a été manqué. Lenovo X201S Thinkpad i7 2.0 GHz 8 Go de RAM. Jamais eu ce problème avec 12.04 LTS - therobyouknow
Le fait que ce soit un problème si commun et de longue durée est pour moi plutôt inquiétant. Est-ce que quelqu'un sait pourquoi cela continue, et qu'est-ce qui le cause? - fouric
ccsm se bloque sur les icônes de chargement, mais si je ctrl-alt-F7 revient à l'affichage principal, les options de compiz sont là. J'ai activé le bureau Unity, je suis revenu à tty1 (ccsm a été exécuté avec succès) ... mais pas d'unité. Redémarrer: pas d'unité. Si je recharge le ccsm, Unity est toujours sélectionné et "on" mais aucune unité n'apparaît. - JeanSibelius


Une solution bonne pour moi (a résolu le même problème):

dans un terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

et alors

setsid unity

166
2018-05-04 00:50



Fantastique. Fonctionne avec Ubuntu Linux 13.04 Desktop dans Parallels sur Mac OS X. - Elliot
Merci! Fonctionne aussi avec Ubuntu 14.04. Je me demande pourquoi cela est arrivé de nulle part si :-( - Sadi
J'ai eu besoin export DISPLAY=:0 premier. - Uri
sudo dconf reset -f / org / compiz / Erreur spawning en ligne de commande 'dbus-launch --autholaunch = c0c0f8bf86119c64ccb710000000006 --binary-syntax --close-stderr': processus enfant sorti avec le code 1 - JeanSibelius
Un problème avec ceci est que courir dconf comme sudo fait mon ~/.config/dconf/user fichier avoir root la propriété (il avait mon utilisateur avant). Je me demande si cela devrait être fait sans sudo. C'était beaucoup mieux que de supprimer le fichier et de partir de zéro! - Tim Tisdall


Aux 13.04 et 14.04:

unity --replace est déconseillé. Utilisez plutôt les éléments suivants:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Redémarrez si cela ne fonctionne pas tout de suite.


72
2018-04-27 02:39



Cela a fonctionné pour moi après l'installation de pilotes appropriés pour ma carte graphique Nvidia. Voir ma réponse askubuntu.com/questions/288235/… - Thomas Arildsen
dconf reset commande donne l'erreur de code de sortie 1 et ne fonctionnera pas 13.10. - Peterdk
activer les plugins Unity avec ccsm résolu certains des problèmes, le reste ont été fixés avec rm -r .Xauthority .ICEauthority .compiz-1/ .gconf/ .config/compiz-1/ .config/dconf/ - precise
Impossible de lancer automatiquement le D-bus sans X11 $ DISPLAY. Rien n'a fonctionné jusqu'à présent - jimifiki
Cela fonctionne pour Ubuntu 16.04 aussi, juste résolu mon problème - Priyadarshi Paul


Pour 12.10 et ci-dessous:

presse Ctrl+Alt+T pour un terminal et courir ccsm, puis réactivez votre plugin 'Unity'.

Vous devrez peut-être aussi exécuter un unity --replace.


60
2017-10-02 02:33



unity --reset est obsolète maintenant et ne fonctionne pas. Y a-t-il un remplacement? - Shahbaz
@Shahbaz - unity --replace. - horIzoN
@ nerof61 également obsolète à partir de 13.04. Voir ma réponse ci-dessous: askubuntu.com/a/286349/2638 - Brandon Bertelsen
ni --reset ni --replace a travaillé pour moi avec mon Ubuntu 12.04 unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ... J'ai attendu et attendu, puis je ne pouvais pas, interrompu par ctrl + c .. et maintenant pour essayer ce que d'autres réponses suggérées .. - precise


Il est conseillé de vérifier que votre pilote graphique est configuré pour utiliser l’accélération matérielle et qu’il est configuré pour utiliser OpenGL. Essayez de rechercher Ask Ubuntu et Ubuntu Forums pour obtenir des informations spécifiques à vos GPU et à votre saveur Ubuntu. Pour les utilisateurs de graphiques hybrides, voir la dernière section "Graphiques hybrides" ci-dessous.

Vous pourriez vouloir exécuter le compizconfig-settings-manager  Install compizconfig-settings-manager package et assurez-vous que le plug-in Unity est coché (voir Quels sont certains des problèmes avec CCSM et pourquoi voudrais-je l'éviter?).

Pour 12.04 et plus récent

  1. Changer pour tty1 en appuyant Ctrl+Alt+F1 et connectez-vous

  2. Installer compizconfig-settings-manager en exécutant

    sudo apt-get install compizconfig-settings-manager
    
  3. Ensuite, lancez-le en faisant ceci:

    export DISPLAY=:0
    ccsm
    

    La première partie indique au terminal l’affichage que vous souhaitez qu’il charge (sinon il n’aura pas d’indice).

  4. presse Ctrl+Alt+F7 (ou Ctrl+Alt+F8 parfois) pour revenir à l’affichage graphique où il devrait y avoir un écran CompizConfig Settings Manager.

  5. Trouvez le plugin Unity. Activez-le CCSM

  6. Tout devrait entrer en jeu, mais si ce n'est pas le cas, vous devrez peut-être redémarrer. Vous pouvez le faire en retournant à tty1et courir sudo reboot.

Si l'unité ne charge toujours pas, essayez:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Redémarrez si cela ne fonctionne pas tout de suite.

Pour 11.10 et plus

Si vous espérez dans un ATS (Ctrl+Alt+F1 par F6) et courir:

DISPLAY=:0 unity --replace

Il réinitialisera Unity sur TTY 7 (Ctrl+Alt ++F7).

Vous pouvez aussi essayer simplement:

DISPLAY=:0 unity

Mais cela ne fonctionnera pas si un gestionnaire de Windows est déjà en cours d’exécution sur l’écran 0 (cela vous donnera une erreur, utilisez simplement unity --replace dans ce cas).

Si unité absolument refuse de redémarrer essayer ceci:

Installer gnome-panel:

sudo apt-get install gnome-panel

Ensuite, lancez-le sur l'affichage 0:

DISPLAY=:0 gnome-panel

Vous devriez alors avoir des panneaux de style Gnome 2 sur votre bureau, que vous pouvez utiliser pour vous déconnecter.

Graphiques hybrides

Vous trouverez des informations très utiles et des lectures supplémentaires pour les utilisateurs de graphiques hybrides ici.

Une fois les GPU configurés correctement pour l'accélération 3D et OpenGL, vous pouvez:

  1. Installer les pilotes Nvidia à partir de https://edge.launchpad.net/~xorg-edgers/+archive/ppa:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    ou:

    Je préférerais vraiment la PPA stable, mais il ne semble pas avoir encore de paquet pour 13.04. Mise à jour: celles-ci semblent être disponibles à partir du 25 septembre. Je voudrais installer ce PPA stable - vous pouvez essayer mais je ne l'ai pas testé.

    Les pilotes Nvidia fournis par Ubuntu étaient déjà installés et je me suis simplement installé à partir de ce PPA en l’ajoutant et en effectuant une mise à jour du package en utilisant update-manager.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installez Bumblebee à partir de https://launchpad.net/~bumblebee/+archive/stable

    MISE À JOUR: à partir du 6 octobre ppa:xorg-edgers/ppa semble contenir aussi des bourdons. Donc, si vous installez à partir de ce PPA, vous pouvez essayer d'ignorer l'ajout du PPA Bumblebee et de l'installer à la place.

    Si vous avez choisi le PPA stable à l'étape 1, installez le PPA stable Bumblebee comme suit:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. MISE À JOUR: Après avoir ajouté les PPA, mettez à jour vos listes de paquets:

    sudo apt-get update
    

    Si vous aviez déjà des pilotes nvidia installés à partir des référentiels standard d'Ubuntu, mettez simplement à niveau pour obtenir la nouvelle version du référentiel choisi à l'étape 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Effectuez les commandes suivantes pour "réparer" Unity (à partir de Brandon-Bertelsenla réponse à L'unité ne se charge pas, pas de lanceur, pas de tiret):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    

51
2017-12-27 12:45



En 14.10: unity --reset-icons & disown m'arrête: Travail inconnu: unity-panel-service // début: travail inconnu: unity-panel-service // compiz (core) - Info: chargement du plugin: core // compiz (core) - Info: plugin de démarrage: core ... et aucune autre action. Alt-F7 me ramène au graphique où j'ai un menu latéral mais pas de menu "Démarrer" (rien dans le menu principal - pas d'icône de connectivité, icône d'alimentation, etc. - retour à tty1 me donne des écrans et des écrans d'informations. .. redémarrage et je suis de retour dans les affaires! MERCI POUR VOTRE VOODOO MAGIQUE - JeanSibelius
Votre section "Pour 12.04 et plus récentes" ne fonctionne pas sur Ubuntu 16.04. - Luís de Sousa
apt-add-repository? - disparu - Kalpesh Soni


La manière la plus simple de le faire est d'appuyer sur Ctrl+Alt+T pour obtenir un terminal puis émettre:

rm -rf ~/.compiz-1 ~/.config/compiz-1

et votre session d'unité reviendra sous vos yeux ..

Cette technique est préférable à la relance de ccsm, car vous pouvez entrer dans la condition d'erreur de l'OP sans même désélectionner accidentellement l'unité dans le ccsm; vous pouvez l'obtenir simplement en appuyant accidentellement sur le bouton "préférences" dans ccsm.


32
2017-11-10 05:55



suppose que tu veux dire .config / compiz-1 - matteo
Je ne peux pas utiliser ctrl-alt-T - jimifiki
@jimifiki: appuyez sur 'crtl' + 'alt' + 'f1' puis faites ce que achiang a suggéré. bien que personnellement, je les éloigne de tout ce que vous avez trouvé si vous rencontrez plus de problèmes. - isaaclw
@isaaclw j'ai fait ce que suggère. Rien n'a changé. Remarquablement la session invité fonctionne normalement. - jimifiki
Pour mon Ubuntu 16.04, les fichiers à supprimer étaient .cache, ne pas .config. Alors rm -rf ~/.cache/compizconfig-1 travaillé pour moi - tparker


J'ai eu ce problème également. Je l'ai résolu en supprimant le contenu du fichier ~ / .config / compiz-1 / compizconfig et le reloger.

rm -rf ~/.config/compiz-1/compizconfig/*

25
2017-10-30 06:23



n'a pas fonctionné pour moi, à peu près comme tout le reste sur cette page - matteo
Oui! Merci, ça a marché! J'ai Ubuntu 16.04 installé dans VirtualBox et après l’une des mises à jour, j’ai eu ce problème. C'est la seule solution qui a fonctionné pour moi! Oh, et n'oubliez pas de redémarrer après avoir appliqué ce correctif. - informatik01
Ne fonctionne pas sur Ubuntu 16.04. - Luís de Sousa
Je n'ai pas travaillé pour moi le 16.04 - 43Tesseracts
Pour mon Ubuntu 16.04, les fichiers à supprimer étaient .cache, ne pas .config. Alors rm -rf ~/.cache/compizconfig-1 travaillé pour moi - tparker


J'ai eu exactement le même problème.

Si vous avez installé Compiz Config Settings Manager, il se peut que Unity Desktop Plugin soit désactivé.

Connectez-vous à un bureau 2D Unity et vérifiez qu'il est activé dans CCSM comme ceci,

CCSM

Unity Shell ne se charge pas sur le bureau par défaut si la case à cocher n'est pas cochée et que vous obtenez la session dans votre image.


21
2017-10-22 07:09





Les développeurs corrigent toujours les bogues, donc une alternative consiste à attendre et à suivre les progrès de la correction des bogues (s'abonner au développement d'Unity dans Launchpad).

  1. presse Ctrl+Alt+F2.

  2. S'identifier.

  3. Courir sudo shutdown -r now dans un terminal.

  4. Sur l'écran de connexion après le redémarrage de votre système, choisissez Unity 2D (pour l'instant) en cliquant avec le bouton droit sur l'icône du pignon.

  5. Attendez un correctif pour Unity 3D / Ubuntu 11.10 (par exemple une semaine).

  6. Mettez à jour votre système pour obtenir le correctif; dans un type de terminal sudo apt-get update && sudo apt-get upgrade.

METTRE À JOUR: J'ai pu résoudre ce problème en utilisant ccsm, à partir de la connexion 2D Unity.

(Ceci est adapté de ce forum Ubuntu post.)

  1. Sur l'écran de connexion, sélectionnez Unity 2D et connectez-vous.

  2. Installer ccsm (Gestionnaire de paramètres CompizConfig) en exécutant un terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra.

  3. Début ccsmet sélectionnez la catégorie Bureau. Activer le Ubuntu Unity Plugin; Si vous êtes invité à résoudre des conflits, sélectionnez le bouton MIDDLE pour tous les conflits. Fermer ccsm lorsque vous avez terminé.

  4. Redémarrez, sélectionnez Unity (3D) et connectez-vous.


19
2017-10-15 21:47